×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

StellarMate 1.5.8 Success!

  • Posts: 22
  • Thank you received: 2
I've been using StellarMate for a few months.  It's always worked for me... but had some quirks which I kept having to deal with... auto-focus, meridian flips, polar align, etc.  However, I updated my RPi with 1.5.8 and everything worked right away!  I had a great session last night and used align, plate solve, auto focus, guiding (PHD2), and meridian flip... and everything worked perfectly.  I'm going to try the internal guiding tonight.  I would like to use it to simplify my environment.

Thanks to the Stellarmate team... nicely done!

Ron
Mounts: Sky-Watcher EQ6-R Pro, Meade LX85, Celestron NexStar Evolution Alt/Az
OTAs: Celestron 8" Edge HD w/Celestron Focus Motor, Meade 80mm APO Triplet Refractor w/ZWO EAF
Cameras: ZWO ASI183MC Pro, ZWO ASI120MC-S, ZWO ASI224MC
Raspberry Pi 4 with Stellarmate OS, MacBook Pro
The following user(s) said Thank You: AstroNerd, max sidorov
1 month 3 days ago #71326

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Nice! I'm running the same version. Hope to get it all ready before Wednesday May 26th (total lunar eclipse out here).

I've found one issue which I don't understand -
So, I'm tinkering away with an Arduino next to the Raspberry Pi, in order to drive a servo and a relay, and that's all sort-of OK so far
I can run that on the StellarMate via VNC,
I use VNC on my laptop to tunnel through the hotspot into the Stellarmate,
I can edit the /usr/share/indi/<my device>_sk.xml setup for the indiduino device,
I run KStars and then EKOS on the Stellarmate, and
I can configure the indiduino <my device> settings in EKOS, and
the switch switches and the servo serves, etc. 

HOWEVER then when I tunnel back out and run KStars and EKOS on my laptop, using the remote StellarMate as an indi-server, I cannot add <my device> to my virtual observatory. 

What am I doing wrong here?
Do I need the <my device>_sk.xml on my local laptop as well, and if so, where ?
It seems strange to me that the client needs to have the configs for the server ?!?

Cheers, Otte
 
1 month 2 days ago #71362

Please Log in or Create an account to join the conversation.

Time to create page: 0.428 seconds