×

INDI Library v1.7.9 Released (23 Jun 2019)

INDI Library v1.7.9 is mostly a maintenance release to fix a few bugs in several drivers.

Mount won't stop slewing (ekos/stellarmate)

  • Posts: 4
  • Thank you received: 0

Mount won't stop slewing (ekos/stellarmate) was created by Ganymede

Hi All,

First, big fan of ekos/kstars - I've got my rig setup so that it is all setup as a R-PI so that its all connected up, I just take it outside, plug in one power plug and polar align/focus and I'm done. I can go inside and everything is connected and on wifi.

The problem I've had in recent upgrades (sorry, not sure exactly when this started happening) is that the mount is now mis-aligning. To try and sort it out, I tell it to park at polar home (sometimes it is off), I then adjust the clutches so it is definitely in polar home. At this point, it should in theory know roughly where it is. I then tell it to slew to a target - it got that wrong by miles: ~90 degrees azimuth and maybe 20-30 degrees altitude (i.e. no small amount in either direction). I then told it to park again at polar home, and whilst DEC slews fine, RA just keeps running for ever!

In terms of kit, this is an EQ5 skywatcher mount, which has run fine on windows with eqmod/etc for ages. Its connected now to a stellarmate raspberry pi running kstars-bleeding at latest levels (apt update/apt upgrade yesterday). The mount is connected via serial connection into the handcontroller (no EQDIRECT cable yet) with PC Direct mode.

Happy to talk technical, I know linux and astro pretty well, so more than happy to tinker to resolve this, but can't solve this one.

One other thing I would note (and I've had this with EQMOD too on windows, different laptop): I can't enable the horizon abort logic - if I do, then the mount will just randomly stop during tracking (even though it is not near a limit). It is odd - I know how to polar align/drift align, the mount is looking to be fine in the alt/az numbers, but it will still stop the mount. Not sure if that is related, but as it is a mount related issue, I'll pass it on in case it inspires.
2 months 2 weeks ago #37586

Please Log in or Create an account to join the conversation.

  • Posts: 38
  • Thank you received: 2

Replied by AradoSKYindi on topic Mount won't stop slewing (ekos/stellarmate)

Hello,

Consider copying Scopeconfig.xml to Scopconfig.old. Then restart EKOS and reconfig the mount driver. Could be a corrupted ScopeConfig.xml. The other option is ParkData.xml. This file can be corrupted also.
2 months 1 week ago #37591

Please Log in or Create an account to join the conversation.

  • Posts: 201
  • Karma: 3
  • Thank you received: 55

Replied by sterne-jaeger on topic Mount won't stop slewing (ekos/stellarmate)

Is the time of kstars in sync with your Raspberry - and does the PI have the right time?

Wolfgang
2 months 1 week ago #37592

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Replied by Ganymede on topic Mount won't stop slewing (ekos/stellarmate)

Ok thanks, I will give that a try - will report back on whether that works :)
2 months 1 week ago #37593

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Replied by Ganymede on topic Mount won't stop slewing (ekos/stellarmate)

Wolfgang - yes, I checked the time/timezone and the location too. I don't think it is that, because the motor never stops - it might account for the mis-slew in the first place though, but everything looked ok to me there. When trying to park, I watched kstars plotting the mount position on the chart, and you could see it reporting the RA moving continuously with no real attempt to move towards home or stop. It's concerning, as it means I can't leave anything unattended yet as it can be erratic
2 months 1 week ago #37595

Please Log in or Create an account to join the conversation.

  • Posts: 842
  • Karma: 6
  • Thank you received: 223

Replied by wvreeven on topic Mount won't stop slewing (ekos/stellarmate)

One more suggestion: when you start Ekos and get the Ekos configuration popup, did you ever go to the Site Management tab and set the home position? The easiest way to do that is to click the Default button and then Write Data. Then you have to go to the Options tab and click Save. Once you have done that, Ekos and the mount agree both on the same home position.


HTH, Wouter
ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
2 months 1 week ago #37596

Please Log in or Create an account to join the conversation.

  • Posts: 422
  • Karma: 3
  • Thank you received: 61

Replied by pentaxian23 on topic Mount won't stop slewing (ekos/stellarmate)

This problem keeps popping up with many users. Follow the Site Management section to setup parking here in the EQMOD driver documentation and let us know if it solves the problem:

www.indilib.org/devices/telescopes/eqmod.html
2 months 1 week ago #37649

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0

Replied by Ganymede on topic Mount won't stop slewing (ekos/stellarmate)

Thanks all, I don't think it is site management, as I think this was setup correctly. However, in my understanding, this wouldn't result in a continuous slew (which is the one that bothers me). As I said before, it might mean I don't slew to the correct location, but I will check through that again and ensure it is all correct.

One thing that does worry me is whether this relates to the fact I'm doing a serial connection into the handset, rather than bypassing the handset. Would this mean any difference - does the time/location of the handset actually come into this, or is it irrelevant because we're in PC direct mode (which is as I thought it was). Ideally I'd put a EQD cable in, but haven't got to that yet. I also wondered if comms issues might have resulted in the continous slew, but I don't know if I could debug this somehow. This is a r-pi with a usb-serial (prolifics) to the mount. The r-pi is also running the DSLR and a v4l guide cam (spc900). I'm wondering if thats too much without a powered hub too.
2 months 1 week ago #37665

Please Log in or Create an account to join the conversation.

  • Posts: 201
  • Karma: 3
  • Thank you received: 55

Replied by sterne-jaeger on topic Mount won't stop slewing (ekos/stellarmate)

Using a powered USB hub is highly recommended!

Wolfgang
2 months 1 week ago #37678

Please Log in or Create an account to join the conversation.

  • Posts: 422
  • Karma: 3
  • Thank you received: 61

Replied by pentaxian23 on topic Mount won't stop slewing (ekos/stellarmate)

No its. It the handset. I use the handset too. And You don’t need a powered USB hub. Your DSLR should be powering itself. The RPi can power small load devices like the guide cam and mount interface.
2 months 1 week ago #37680

Please Log in or Create an account to join the conversation.

  • Posts: 422
  • Karma: 3
  • Thank you received: 61

Replied by pentaxian23 on topic Mount won't stop slewing (ekos/stellarmate)

pentaxian23 wrote: No its. It the handset. I use the handset too. And You don’t need a powered USB hub. Your DSLR should be powering itself. The RPi can power small load devices like the guide cam and mount interface.


My post was supposed to say "No, its NOT the handset..." I use the handset and it works fine. And its probably not the USB. USB is a robust link. Don't worry about it. I can't recall a problem with USB and I've used the crappiest unpowered hubs.
2 months 6 days ago #37975

Please Log in or Create an account to join the conversation.

Time to create page: 0.846 seconds