×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

Can't connect NEQ6 Pro via ST4 cable

  • Posts: 3
  • Thank you received: 0


Hi all - this is my first foray into this forum, and my first attempt at controlling my rig using a dedicated computer, so please excuse any ignorance on my part. I have trawled the internet and this forum, and can't find an answer to my current problem with my ST4 cable.

I have the following:
- NEQ6 pro mount with hand controller
- ZWO ASI120MC guide camera on a 50mm Orion guide scope
- ZWO ASI183MC main camera (brand new and only just tested)
- ASUS Tinker Board (original) running Ubunutu 18.10, Kstars, Ekos, Indi & Astrometry.net (all installed this week)
- I have kept everything as close to install as possible - no tweaking

On a Windows 10 laptop I can do the following:
- Run both cameras
- Polar align with Sharpcap using the ASI120MC
- Autoguide with PHD2 using the ASI120MC and ST4 cable
- Capture images from the ASI183MC using APT

On the ASUS Tinker Board:
- both cameras configure up OK and seem to work OK
- I can't get the mount to work via the ST4 cable from the ASI120MC
- at present I have attached only the ASI120MC via USB, ST4 cable and hand controller
- I get the following error on Indi start:

2019-09-16T09:54:07: [ERROR] Failed to connect to port (/dev/ttyUSB0). Error: Port failure Error: No such file or directory. Check if device is connected to this port.

Any help would be most appreciated.

Thanks.
4 years 5 months ago #43424
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 140
Hello and welcome...
Have you tried using the serial port manager to assign serial ports to your kit, as that maybe the issue.. :)
The following user(s) said Thank You: Alex
4 years 5 months ago #43426

Please Log in or Create an account to join the conversation.

  • Posts: 467
  • Thank you received: 164
ST4 cable is only capable of sending guide pulses from camera to mount, it's not used for controlling the mount in any other way so you can't connect the mount driver with it. To control the mount from Ekos you need either serial cable from computer to hand controller or preferably EQDir cable directly to mount. For purely guiding, the same setup in PHD2 works, just don't add mount driver at all, use via camera guiding and control the mount with hand controller.
The following user(s) said Thank You: Alex
4 years 5 months ago #43427

Please Log in or Create an account to join the conversation.

  • Posts: 969
  • Thank you received: 94
Hi
Lose the synscan entry and set the guide camera on the guide tab in the 'Via' drop-down.
HTH,
Steve
The following user(s) said Thank You: Alex
4 years 5 months ago #43435

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Thanks for your help - it gets me one step closer, but now my Align window is all greyed out see jpg image 7.
4 years 5 months ago #43469
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420
Which solver did you choose in your hardware profile in Ekos?
4 years 5 months ago #43474

Please Log in or Create an account to join the conversation.

  • Posts: 969
  • Thank you received: 94
Hi
IIRC, with st4, align has no way of knowing where the telescope is pointing so it cannot be used.
Try a direct mount connection instead. Not sure what mount you have but if you were trying synscan with an eq6, eqmod may will work; you'll need a different cable however.
HTH,
Steve
Last edit: 4 years 5 months ago by alacant.
4 years 5 months ago #43476

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Hi all - thanks for your responses. Have now received my EQ6 USB cable and it works a treat ie resolved all my issues raised earlier. Have to wait for a clear night next to get some practical hands on.

If you do have some further suggestions ie what I have to do next, suggestions etc, I'm only to interested in hearing them.

Alex.
4 years 5 months ago #43593

Please Log in or Create an account to join the conversation.

Time to create page: 0.775 seconds