×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

iOptron GEM45

  • Posts: 1957
  • Thank you received: 420
Recently iOptron released a new mount: the GEM45. I have access to one and found that it doesn't work with INDI. I have tried several iOptron drivers and both a direct USB connection to the mount and via a serial cable connected to the hand controller. In both cases with all drivers I have tried out (including the iOptrom iEQ45 and iEQ45 Pro) the connection to the mount times out. But perhaps I am doing something wrong. Has anyone tried INDI with this mount?

Logs attached but I am afraid they don't say much.


Wouter
The following user(s) said Thank You: Craig
4 years 5 months ago #45623
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Apparently iOptron have reused the software for the CEM40. When we use the CEM40 driver we get a different error (no more time out, hurray!):

Mount with code 0043 is not recognized.

I will have a look at the CEM40 driver and will see if I can add that code and recompile to see if the mount will then respond. To be continued!


Wouter
The following user(s) said Thank You: Craig
4 years 5 months ago #45694

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Yes that worked. Jasem, would you like me to check it in and do a pull request?
4 years 5 months ago #45703

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Code changes committed and pull request issued.
4 years 5 months ago #45729

Please Log in or Create an account to join the conversation.

  • Posts: 912
  • Thank you received: 86

Replied by maxthebuilder on topic iOptron GEM45

Hello,
I am thinking about getting a new mount and deciding between CEM40 and GEM45.
Are they both fully supported now?
Thanks!
-- Max S
ZWO AM5. RST-135. AZ-GTI. HEQ5. iOptron SkyTracker.
TPO RC6. FRA400. Rokinon 135 and other lenses.
ZWO ASI2600MC. D5500 modified with UVIR clip-in filter.
ZWO ASI120MM Mini x 2. ZWO 30F4 guider. Orion 50mm guider.
ZWO EAF x 3.
4 years 4 months ago #46470

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Hi!

I am inclined to say that the CEM40 already was fully supported and the GEM45 now as well. Unfortunately we have been plagued by bad weather for the past three weeks so we have not been able to fully test the GEM45 support yet. Our first tests looked promising though so I am confident that all works fine. Not sure about the iPolar scope, that comes with the GEM45, yet though.


Clear skies, Wouter
4 years 4 months ago #46471

Please Log in or Create an account to join the conversation.

  • Posts: 912
  • Thank you received: 86

Replied by maxthebuilder on topic iOptron GEM45

Wouter - thanks!
Looks like GEM45 if not already fully supported, will soon be. Great!
I thought iPolar was the same for both?
There were some reports here of iPolar working under Ekos. Or I am wrong?
-- Max S
ZWO AM5. RST-135. AZ-GTI. HEQ5. iOptron SkyTracker.
TPO RC6. FRA400. Rokinon 135 and other lenses.
ZWO ASI2600MC. D5500 modified with UVIR clip-in filter.
ZWO ASI120MM Mini x 2. ZWO 30F4 guider. Orion 50mm guider.
ZWO EAF x 3.
4 years 4 months ago #46472

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Max, you are right. The support for GEM45 currently only is available in the nightly builds.

The iPolar indeed is the same for both and I have read on CloudyNights that someone got it working with INDI . See comment #13. Unfortunately the poster did not say HOW he did this. We tried with the V4L2 driver and we do get an image however during daytime it is completely white and during the night completely black. Probably during daytime it is too sensitve and quickly overexposes. During the night probably it has not been focused well so we don't see any stars.

My code changes so far only have been to map the CEM40 code to the GEM45 with a new alias and the V4L2 code to iPolar. This works but, as I said, we need more time to test the iPolar in that setup.

Finally, we have had word from iOptron that Linux and Mac drivers for the iPolar would be released soon (see also comment #12 in the CloudyNights thread) but so far that's all we know.
The following user(s) said Thank You: maxthebuilder
Last edit: 4 years 4 months ago by Wouter van Reeven.
4 years 4 months ago #46473

Please Log in or Create an account to join the conversation.

  • Posts: 912
  • Thank you received: 86

Replied by maxthebuilder on topic iOptron GEM45

Great info - thanks!
-- Max S
ZWO AM5. RST-135. AZ-GTI. HEQ5. iOptron SkyTracker.
TPO RC6. FRA400. Rokinon 135 and other lenses.
ZWO ASI2600MC. D5500 modified with UVIR clip-in filter.
ZWO ASI120MM Mini x 2. ZWO 30F4 guider. Orion 50mm guider.
ZWO EAF x 3.
4 years 4 months ago #46499

Please Log in or Create an account to join the conversation.

  • Posts: 912
  • Thank you received: 86

Replied by maxthebuilder on topic iOptron GEM45

I am about to take a plunge and order a GEM45. Hope I won't regret it.
-- Max S
ZWO AM5. RST-135. AZ-GTI. HEQ5. iOptron SkyTracker.
TPO RC6. FRA400. Rokinon 135 and other lenses.
ZWO ASI2600MC. D5500 modified with UVIR clip-in filter.
ZWO ASI120MM Mini x 2. ZWO 30F4 guider. Orion 50mm guider.
ZWO EAF x 3.
Last edit: 4 years 4 months ago by maxthebuilder.
4 years 4 months ago #46605

Please Log in or Create an account to join the conversation.

  • Posts: 1957
  • Thank you received: 420

Replied by Wouter van Reeven on topic iOptron GEM45

Good choice! I am sure you will wnjoy it a lot!
4 years 4 months ago #46614

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 1

Replied by Greg on topic iOptron GEM45

I have the IOptron GEM45-EC model and it is reporting as code 0044 which looks like will need to be added as well.

DEBUG 129.616196 sec : CMD <:MountInfo#>
DEBUG 129.649251 sec : RES <30 30 34 34>
ERROR 129.649364 sec : Mount with code 0044 is not recognized.
The following user(s) said Thank You: Jasem Mutlaq
3 years 10 months ago #55096

Please Log in or Create an account to join the conversation.

Time to create page: 0.531 seconds