×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

indi-ieq45-8407 always drives to 00:00:00

  • Posts: 22
  • Thank you received: 0
MacOS 10.10. Indi Server and Indi Control Panel from CloudMakers.
From Indi Control Panel connection via cu.usbserial is successful and IEQ45 mount coordinates are correctly reported. They change when the mount is driven from the hand box. Slew is selected. When new coordinates are entered (that are above the horizon) the mount slews to RA and Dec of 00:00:00 no mater what was entered.
From the command line: execute indiserver for this mount. Select port (ttyUSB0) and connect using indi_setprop. Use indi_getprop -v and current coordinates are shown just like from the INDI Control Panel. When new coordinates are entered the mount slews to 00:00:00 in both RA and Dec no matter what coordinates were entered.

Ubuntu 14.10. Apt-get of nidi-full and indi kstars bleeding.
From KStars Tools->Devices connection to the mount was successful. As above coordinates were correctly shown and changed with manual hand box control. Attempting to drive to any coordinates sent the mount to 00:00:00.

Any clues?
Last edit: 7 years 3 months ago by David Elmore. Reason: missed the question
7 years 3 months ago #3705

Please Log in or Create an account to join the conversation.

The driver is quite old and does not use INDI Telescope class. If you're willing to test it, I can develop a new driver that would support the following:

CEM60 (Firmware 140807 and later)
CEM60-EC (Firmware 140807 and later)
iEQ45 Pro (Firmware 140807 and later)
iEQ45 Pro AA (Firmware 140807 and later)

Is that OK?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 3 months ago #3707

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Yes, I would be happy to perform tests.
Mount iEQ45Pro 8407
HC:140825
Main:140822
RA: 140822
Dec: 140822
7 years 3 months ago #3715

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
David, let me know if you will need OSX build for testing. Peter
7 years 3 months ago #3729

Please Log in or Create an account to join the conversation.

Ok, driver is available for testing. Please follow the instructions here:

indilib.org/forum/general/571-read-befor...support-request.html

In particular, you need to turn on both driver debug and scope verbose. Make sure to log to file, and send me the file after your testing. You need to test all functions in the driver including settings custom tracking and guiding rates, sync, motion commands...etc. Also, after initial connect, check the controller to see if the time and location settings in the INDI driver are reflected in the controller, including UTC offset. Please also test the home functionality. You can also test the park functionality, but I am working on an updated park functionality for all telescope drivers, so you can hold until that is available.

The driver should be available in the PPA tomorrow.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 3 months ago #3732

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Looked at the instruction page. This will be an adventure possibly with questions that you will find trivial. But I do want to come up to speed. For example the driver should be available on the PPA has no meaning to me. I suppose some navigating around the site is in order.
This weekend I should have time to work on testing the driver under Ubuntu.

Yes please, Peter, eventually I will be operating under MacOS .
7 years 3 months ago #3733

Please Log in or Create an account to join the conversation.

  • Posts: 157
  • Thank you received: 2
About PPA - take a look here:

www.indilib.org/download.html
Linux Mint 17.1 + Kubuntu 14.10 hybrid OS, using PPA for latest KStars-bleeding and INDI
7 years 3 months ago #3735

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174

OK, I'll make OSX build later tonight, it is probably easier way to test it. Peter
7 years 3 months ago #3736

Please Log in or Create an account to join the conversation.

  • Posts: 712
  • Thank you received: 174
David, you can download it from here: INDI_Server_2.0.7.dmg Peter
7 years 3 months ago #3743

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
Installed INDI_Server_2.0.7
Ran Indi_server and Indi_Control_Panel. New dialog in Indi_Control_Panel with a Main submenu and Options submenu.
Set all the debug levels in the options submenu.
Set the port in the options submenu
Connection from Main was successful.
Looking at the log file ...
Getting firmware data timed out.
Then continuous errors processing declination and right ascension inputs.
Coordinates reported in the Control Panel were always zero even if the mount was driven manually.
I tried selecting the 'Park' position. Mount went to 00:00:00 in both axes.
7 years 3 months ago #3745

Please Log in or Create an account to join the conversation.

  • Posts: 22
  • Thank you received: 0
The attachment did not show up. Try again to Add File.

File Attachment:

File Name: indi_ieq_t....log.txt
File Size:44 KB
7 years 3 months ago #3746
Attachments:

Please Log in or Create an account to join the conversation.

Thanks for the log file, it was useful. I believe I fixed the issues, I'll ask Peter to make another OSX package so you can test.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 years 3 months ago #3753

Please Log in or Create an account to join the conversation.

Time to create page: 0.372 seconds