×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Support for iOptron CEM70

1 month 3 weeks ago
a.f.c.vandenberg
Fresh Boarder
Fresh Boarder
Posts: 5
More
Topic Author
Support for iOptron CEM70 #55699
Hi,

When will support for the iOptron CEM70 be added to INDI?

Thanks!

Kind regards,

Sander

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
knro
Administrator
Administrator
Posts: 8207
Karma: 51
Support for iOptron CEM70 #55707
I just added an alias for it, it uses the same driver as the CEM120.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
a.f.c.vandenberg
Fresh Boarder
Fresh Boarder
Posts: 5
More
Topic Author
Support for iOptron CEM70 #55709
Hi knro,

That's perfect!
Thank you very much for the effort.
Was is just as easy as adding the {"0070", "CEM70"} tuple to the Drivers::models map in ioptronv3driver.cpp?"
And do you know whether this is already tested by someone with a CEM70 mount?

Kind regards,

Sander

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
knro
Administrator
Administrator
Posts: 8207
Karma: 51
Support for iOptron CEM70 #55710
Yes I believe so, I just pushed that as well. If you can compile from GIT, please re-compile and report back!

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago
a.f.c.vandenberg
Fresh Boarder
Fresh Boarder
Posts: 5
More
Topic Author
Support for iOptron CEM70 #55711
Coming Friday I go back to the optics shop to buy my new setup.
Still doubting between the CEM70 and CEM120... difficult decision to make ;-)
It has to carry a Celestron 11 inch Edge HD with a ZWO 60mm guide scope and some camera equipment, both will do fine I guess.

One of my requirements is to have my setup working on a Linux machine (probably KStars + Ekos + INDI).
Good to see that both CEM70 and CEM120 are supported now, although the CEM70 is a new mount which is probably not tested yet with INDI.

For sure when I go for the CEM70 I will try it out with the latest INDI that you pushed and I will report back my findings.
When I go for the CEM120 I guess reporting back has not so much added value as this mount is already proven to work with INDI!
This also gives me confidence that it will work for the CEM70 as well, as they seem to be identical w.r.t. the software interface and tracking hardware.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
a.f.c.vandenberg
Fresh Boarder
Fresh Boarder
Posts: 5
More
Topic Author
Support for iOptron CEM70 #55934
Hi,

Just to let you know...
I went for the CEM120, so I have no further input / experiences with CEM70 + INDI.

Please Log in or Create an account to join the conversation.

1 week 2 days ago
Autoglassman70
Fresh Boarder
Fresh Boarder
Posts: 9
More
Support for iOptron CEM70 #57635

knro wrote: I just added an alias for it, it uses the same driver as the CEM120.


Hi Knro, I recently purchased a CEM70g which I’m trying to use on MacOS using KStars-Ekos-Indi. Going off your previous comments, I’m having problems getting Ekos & Indi to communicate with the mount. Basically the mount shows error commands in the connection. Are there any specifics I should be aware of?

I can use SS6pro which connects via the mounts WiFi and syncs with the handset, so I am able to remotely control the mount. However I would much prefer the use of KStars/Ekos/Indi as I would like to take full advantage if possible of the iPolar and iGuider as well as camera control.

Firmware for the mount is up to date, any ideas would be much appreciated, thank you.

Richard.

Please Log in or Create an account to join the conversation.

1 week 2 days ago
AstroNerd
Moderator
Moderator
Posts: 834
Karma: 1
More
Support for iOptron CEM70 #57647
The CEM 70 is a different driver to the CEM 120, so there is the issue, as it has different features...

Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85 & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 week 2 days ago
knro
Administrator
Administrator
Posts: 8207
Karma: 51
Support for iOptron CEM70 #57648

Autoglassman70 wrote:

knro wrote: I just added an alias for it, it uses the same driver as the CEM120.


Hi Knro, I recently purchased a CEM70g which I’m trying to use on MacOS using KStars-Ekos-Indi. Going off your previous comments, I’m having problems getting Ekos & Indi to communicate with the mount. Basically the mount shows error commands in the connection. Are there any specifics I should be aware of?

I can use SS6pro which connects via the mounts WiFi and syncs with the handset, so I am able to remotely control the mount. However I would much prefer the use of KStars/Ekos/Indi as I would like to take full advantage if possible of the iPolar and iGuider as well as camera control.

Firmware for the mount is up to date, any ideas would be much appreciated, thank you.

Richard.


Any logs?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 week 1 day ago
Autoglassman70
Fresh Boarder
Fresh Boarder
Posts: 9
More
Support for iOptron CEM70 #57652
Hi Knro, new update, after fiddling with the INDI Control Panel connection tab IP address and port, somehow I now have communication to the port however the mount info is defaulting to the cem120 and I have no control over the mount in KStars.
The firmware for the cem70g are

HC V2 :200303
MAIN :200115
RA :200116
DEC :200116
CATALOG :150429

Using the mount control panel to move, the logs say what I am pressing but there's no physical movement in the mount

You do not have permissions to access this page.

Please Log in or Create an account to join the conversation.

1 week 1 day ago
knro
Administrator
Administrator
Posts: 8207
Karma: 51
Support for iOptron CEM70 #57653
Enable verbose logging for mount and attach logs.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 week 1 day ago
Autoglassman70
Fresh Boarder
Fresh Boarder
Posts: 9
More
Support for iOptron CEM70 #57658



hope this is what you mean?
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.800 seconds