×

INDI Library v2.0.0 Released (01 Feb 2023)

Bi-monthly release with major changes to INDI properties and client API in addition to new drivers and improvements.

EQMod-Driver produces tty-errors ( INDI 1.9.0. )

  • Posts: 1
  • Thank you received: 2
In the new version 1.9.0 i've got issues with the delivered EQMOD-Driver, which i didn't have in the previous version.
There are several messages indicating wrong file descriptor handling.
>>> Error: Communication failed -> tty write failed, check connection: Bad file descriptor .
Please find detailled log info 

File Attachment:

File Name: log_21-23-08.txt
File Size:161 KB
in the attachment.
Thanks for your support.

 
The following user(s) said Thank You: alacant
1 year 9 months ago #70639
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 882
  • Thank you received: 87
Hi

I can confirm the same errors after update from the Ubuntu ppa to stable kstars 3.5.3

One problem at the mount is that the on-screen arrow controls in EKOS do not respond correctly. e.g. a nudge north takes a long time to respond to the mouse click and does not stop the slew on releasing the button.

TIA for any news.

Attached log.


 
kubuntu 22.04
700d, eq6, 120mm. Yes, the old one.
1 year 9 months ago #70922
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 418
  • Thank you received: 99
I am using the latest INDI and KStars, and get no such issues with my EQ6-R Pro. I'm using the built-in USB port, not a custom EQDirect cable.

I used to get similar errors with questionable cables (or was it a questionable USB hub, can't remember). Occasionally the computer (Raspberry Pi in my case) would think I unplugged and replugged the USB cable, causing the system to give it a new USB port name (it was /dev/ttyUSB0, now it's /dev/ttyUSB1), and the EQMod driver would throw fits until I gave it the new USB port name.

Haven't had any such problems since upgrading hardware and cables a while back.
The following user(s) said Thank You: alacant
1 year 8 months ago #71248

Please Log in or Create an account to join the conversation.

  • Posts: 882
  • Thank you received: 87
Hi everyone
Yes, all OK here now with the INDI updates. Old eq6 with 9 pin connector eqdir cable.
Cheers and clear skies.
Steve
 
kubuntu 22.04
700d, eq6, 120mm. Yes, the old one.
1 year 8 months ago #71253

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 3
Hello,

same problem as explain in this topic indilib.org/forum/mounts/9705-problem-to...mod-with-ubuntu.html (where I attached a log file)
An EQ6-R (with pegasus  eqdir cable) on an Ubuntu 20.10 with ekos/indi 5.3.5/1.9.0 from the stable ppa.
Crash one or two seconds after the connection.

Anthony.
1 year 8 months ago #71581

Please Log in or Create an account to join the conversation.

Time to create page: 0.741 seconds