×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

1.5.9 Wifi Adapter Problem

  • Posts: 21
  • Thank you received: 1

Replied by Tim on topic Re:1.5.9 Wifi Adapter Problem


I didn’t. I’ve had problems in the past and gotten really good customer service from BrosTrend/TrendTech. I’ve tried them multiple times, and haven’t had received a single response this time. I ended up getting a new adapter.


Sent from my iPhone using Tapatalk
2 months 1 week ago #74213

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 4
The below may or may not help.
Info is taken from this thread

askubuntu.com/questions/732985/force-upd...-unsigned-repository

Note this is a generic override of all repositories at mirrors.ocf.berkeley.edu/debian and is not the best way to do this but may allow the install to happen.
As super user, edit using your favorite editor
/etc/apt/sources.list

Add the line
deb [trusted=yes] mirrors.ocf.berkeley.edu/debian buster main

And save the file.

Try the install again

 
2 months 1 week ago #74226

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by lttnono on topic 1.5.9 Wifi Adapter Problem

Taking the public keys from the Ubuntu keyserver works.

discuss.freedombox.org/t/solved-buster-b...-raspberry-pi-1b/327

sudo apt-key adv --keyserver  keyserver.ubuntu.com  --recv-keys 04EE7237B7D453EC

To be repeated for each of the three key IDs that show up in the error message.
Last edit: 2 months 1 week ago by lttnono. Reason: Typo in the Ubuntu keyserver URL (a '494' was added when I copy-pasted from the website where the issue was discussed)
2 months 1 week ago #74238

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1

Replied by Tim on topic 1.5.9 Wifi Adapter Problem

Thanks! Unfortunately it only solved half the problem. I'm getting this now:

stellarmate@stellarmate:~ $ sh -c 'busybox wget deb.trendtechcn.com/install -O /tmp/install && sh /tmp/install'
Connecting to deb.trendtechcn.com (185.199.108.153:80)
Connecting to deb.trendtechcn.com (185.199.110.153:443)
install              100% |********************************| 16512  0:00:00 ETA
Root access is required
Package manager is: apt-get
Installing prerequisites
Hit:1 ppa.stellarmate.com/repos/apt/stable buster InRelease
Hit:2 mirrors.ocf.berkeley.edu/debian buster InRelease                  
Hit:3 raspbian.raspberrypi.org/raspbian buster InRelease                
Reading package lists... Done
Couldn't detect the appropriate kernel headers package!

 
2 months 1 week ago #74240

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by lttnono on topic 1.5.9 Wifi Adapter Problem

I had an error that was a bit similar.  The TrendTech program was trying to build kernel modules for kernel version 5.10.52 but my Stellarmate was in 5.10.17.   Updated the packages (Menu-->System Tools-->Package Updater) and then everything went smoothly.  

What's your kernel version? ( uname -r )

You could also try to install the kernel headers (sudo apt-get install raspberrypi-kernel-headers )

 
Last edit: 2 months 1 week ago by lttnono. Reason: afterthought : install kernel headers for the RPi
2 months 1 week ago #74241

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1

Replied by Tim on topic 1.5.9 Wifi Adapter Problem

I ran package updater. There was plenty that needed updating. 

My version is also 5.10.17. 

That command you suggested returns the following error:
E: Unable to locate package raspberrypi-kernel-headers

Regardless, I still got the same header error when I tried to install the TrendTech drivers again.
 
2 months 1 week ago #74242

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by lttnono on topic 1.5.9 Wifi Adapter Problem

Hmmm...ok you should try 
1- sudo apt-get update
2- sudo apt-get install raspberrypi-kernel-headers
3- run the TrendTech command to install the drivers

If this still fails, maybe there's a repository to point to (I remember I uncommented the "sources" repo in the /etc/apt/sources.list file - using midnight commander and its integrated editor that I had previously installed with sudo apt-get install mc and run with sudo mc.  Great little clone of Norton Commander from the good old days of Microsoft DOS ^^ )

BTW after all your updates are you still in 5.10.17 or have you moved up to 5.10.52?

 
2 months 1 week ago #74244

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1

Replied by Tim on topic 1.5.9 Wifi Adapter Problem

I uncommented that line in the sources.list. It did something because the sudo update command showed a few more things happening than normal. However, I'm still getting the "Unable to locate package raspberrypi-kernel-headers" error when I run the install headers command. And I'm still on the .17 version. Thanks for trying to help. 
2 months 1 week ago #74266

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by lttnono on topic 1.5.9 Wifi Adapter Problem

Well, if apt can't get to those headers, neither will the install script from TrendTech.  One more thing I fiddled with is the /etc/apt/sources.list.d/raspi.list file in which I think I uncommented the three repos.  Could you try uncommenting those, re-run a sudo apt-get update and then try again with the rasberrypi-kernel-headers (or go straight for the TrendTech install process which does the same thing at some point)? 


 
2 months 1 week ago #74267

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 1

Replied by Tim on topic 1.5.9 Wifi Adapter Problem

Still no luck. If nothing else, I'm learning a little more about RPi than I thought I ever would. Thanks for all of the suggestions. I got another adapter that is actually working, so not all is lost. Hopefully it will perform well compared to the old one. And maybe this header install problem will randomly fix itself in a future update.
2 months 1 week ago #74269

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 1

Replied by lttnono on topic 1.5.9 Wifi Adapter Problem

Probably best to let it rest indeed until a future update fixes things....I'm no Linux Guru but I don't mind fiddling around with it, which can sometimes have an adverse effect.  On a positive note : at least the public key issue was fixed :-).  
The following user(s) said Thank You: Tim
2 months 1 week ago #74270

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
I contacted Brostrend on this issue and unlike Tim I had a fast response and finished up with sharing my screen and letting their tech team sort it out. God knows what they did because my screen disappeared but I got an e-mail a few minutes later which said "The problem was a bad /etc/apt/sources.list.d/raspi.list"
The dongle now works. Although I have no idea what their message means it may help someone on here that understands Linux better than me to sort out their problem.
RPI4 with Stellarmate OS
Macbook air
ZwoASI533mc pro
ZwoASI120 mm-s
CEM 26
Telescopes (backorder)
2 months 1 week ago #74277

Please Log in or Create an account to join the conversation.

Time to create page: 1.370 seconds