INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Numerous issues with Stellarmate and the app

  • Posts: 24
  • Thank you received: 0
I bought Stellarmate OS 3 days ago as it has a mobile app that I wanted to use. Coming from Astroberry I thought that all that posts that it is unusable are fakes (you just need to setup everything correctly as in Astroberry I thought). However, now I understand why there is many negative posts. My experience went from good to bad, I managed to run everything on the first one or two boots, and then features just deasppeared.

1. When I loaded first time I got a crash with toupcam driver
Warning: Spoiler!

2. Next I pressed update through the VNC (it was the latest version already but some update was pending) and after update kstars shortcut disappeared from the descctop as well as 2 other shortcuts. (fixed)
3. So I had to reinstall stellarmate and here comes "no hotspot" issue. I tried 3 different sdcards (usual, A1 , V30) and both 32 and 64bit versions. Finally I have some sdcard that works. Thats fixed.
4. Then I could see device and connect it to home wifi but got a message "EkosLive is down", tried all steps in faq - no luck. Tried to start ekos manually through VNC - no help. Reinstall app - no luck. Decided to reinstall os again (not fixed)
5. After 3 other fresh installs app deceted device only once(!) . No I can't connect though the app at all in different os versions(32/64 bit, different sd cards), I can't even access the step "EkosLive is down", I tried to enter IP manually but the app doesn't see it(!), BUT I can access through МТС from the same smartphone(!) and through bonjour discovery name(!!) in the browser! So the issue is ddifenetly in the app. Not even a reinstall helps. (not fixed)

So I have to use Stellarmate OS same as Astroberry through VNC, the only benefit (the app) simply doesn't work for me.

PS As a mobile developer I've seen lots of apps, lots fo legacy code, but I have never had such bad experience as a user. Probably that's React Native issue, probably some internal logic. More effort should be put into mobile, it's such a waste of opportunity
1 year 8 months ago #85214

Please Log in or Create an account to join the conversation.

Sorry to hear about your troubles.

1. What's the SM App version (and bundle)?
2. Can you check from the tablet browser if you can reach WebManager? i.e. stellarmate.local:8624 does this page load up?
3. Can you share logs from SM Dashboard? stellarmate.local --> Diagnostics --> Logs --> EkosLive

I will upload an updated image for the 32/64 after latest updates, but I'd like to get your issues resolved first.
1 year 8 months ago #85258

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 0
Jasem, I have an update about my issues.

1. Somehow I decided to try previous version, downloaded apk from apkpure and 2.5.1 connects and works! It can see stellarmate, it can connect, it starts ekos and devices. So I conclude that the issue is in 2.5.2. I had only one issue with 2.5.1 when it didn't connect, but anyway it is not 3 days of struggling. I will continue testing it.
2. Yes, I did that. As I said, webmanager and VNC were accessible from the same smartphone, while the app didn't see it, same as manual IP address didn't help.
3. I can
1 year 8 months ago #85265

Please Log in or Create an account to join the conversation.

Time to create page: 0.393 seconds