×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

RasPi/Stellarmate->ethernet->win10 laptop, no connection

  • Posts: 75
  • Thank you received: 6
I simply cannot connect to Stellarmate via ethernet, I’ve managed it once but that was after some fiddling with the laptop network.
Stellarmate does register some kind of connectivity (hotspot dissappears), the laptop gets an ip address, 169.254.45.xx, but Stellarmate has 169.254.9.68 - no connection.
Anyone with a suggestion to what’s going on - I’m going out of my mind, every time I have some clear skies, I struggle with software/hardware (raspi/Stellarmate) issues spending more hours getting things working instead of taking pictures :(
2 years 1 month ago #37418

Please Log in or Create an account to join the conversation.

  • Posts: 100
  • Thank you received: 30
Did you remember to START by using the Stellarmate APP on your phone or tablet? SM needs that FIRST in order to configure networking.
TPO 8" Ritchey-Chretien Astrograph
Moonlite CS focuser with Motor Drive
RoboFocus Auto Focuser
iOptron iEQ45 Pro Mount on Tripier
Stellarrmate OS RPi 4, 4GB
ZWO ASI533MC Pro Main Camera
Meoptex Off Axis Guider
Starlight Xpress Lodestar X2 Guide Camera
Polemaster Polar Alignment Camera
2 years 1 month ago #37424

Please Log in or Create an account to join the conversation.

In StellarMate, go to Network --> Connection --> Edit Connections (Last option)

Remove all Ethernet Connections (Auto Ethernet..etc), then add a new connection. Select Ethernet.

Go to IPv4 table. Add this IP:

IP: 192.168.1.2
Subnet: 24
Gateway: 192.168.1.1
DNS: 192.168.1.1

On your PC, edit your IPv4 setting in network manager (click on ethernet adapter --> properties --> IPv4 settings) or something like that.

Select Manual, add IP information:

IP: 192.168.1.1
Subnet: 255.255.255.0
Gateway: 192.168.1.1
DNS: 192.168.1.1

After you save, you _should_ be able to ping 192.168.1.2 which is the permanent address of StellarMate now. Use this address every where.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 1 month ago #37440

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 6
Thanks Jasem, I managed to connect last night, but not a direct connection, I had to put a router between my laptop and the RasPi. Even then I had a hard time establishing a connection. I actually had both the Stellarmate hotspot and a wired connection at the same time. I even created static IP adresses in the router, that diddn’t help much, the RasPi MAC was listed twice with two different IP addresses 192.168.x.x and 10.42.x.x - I’ve never seen that before)
I’ll follow your guide tonight.
2 years 1 month ago #37443

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 6
I just tried the changes you suggested Jasem. When I ping Stellarmate, it does reply, but quite often I get a request time out.
The laptop cannot connect to the Stellarmate Web manager or Stellarmate via the kStars running on the laptop. I've disabled every network connecton but the specific ethernet connection, even the Stellarmate HotSpot.
Then I tried to open the webmanager on Stellarmate, nothing happening, Chrome keeps waiting forever. Something seems to be wrong with Stellarmate.
I updated Stellarmate to the latest release yesterday, I only have the sw release from a year back when I purchased Stellarmate (release 1.2.9) - is it possible to download later releases?
Another thing, the Stellarmate Hotspot rarely shows up when the RasPi is not connected to a netwrok, I can restart it over and over again without anything happening. Is there any "no network" timeout before it's activated?
2 years 1 month ago #37463

Please Log in or Create an account to join the conversation.

Sure, just open a ticket or email support (This email address is being protected from spambots. You need JavaScript enabled to view it.) to request an updated OS.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 1 month ago #37474

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 6
And you have mail Jasem :-)
2 years 1 month ago #37480

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
The following part where the user will find out the overall work which will be going to find out the better part for such a way where the user will provide a better way to netgears.support/blog/netgear-r6700-nighthawk-ac1750-review/
manage it in such part which will be going to provide it.
2 years 1 month ago #37483

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
Jasem,

In your instructions above you said to set the subnet to '24'. What should it be?

Bob Redding
2 years 3 weeks ago #38407

Please Log in or Create an account to join the conversation.

24 is short for 255.255.255.0

So use either format.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 3 weeks ago #38438

Please Log in or Create an account to join the conversation.

  • Posts: 328
  • Thank you received: 53
SAY WHAT? I documented this 2 weeks ago but never shared it. TWO different MAC addys? I messed with it and it went back to 1 so I had deleted this and after reading his msg - I restored to share it.

AP Mach1 / CP4 APCC & PEMpro.
EXP SCI - ED152cf APO - Celestron 11" RASA - Stellarvue 80mm
Baader F2 HS NB filters, Lodestar X2 guide camera / OAG - ZWO 290mm mini
ZWO ASI1600MM Pro / ASI174M (solar) / ASI094MC
NEXDome, CLoudwatcher, AVX mount/ASIair and Stellarmate

2 years 2 weeks ago #38620
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 6

I had two different IP addresses for the same MAC address - never seen that before.
Last edit: 2 years 2 weeks ago by DrawsACircle.
2 years 2 weeks ago #38717

Please Log in or Create an account to join the conversation.

Time to create page: 0.811 seconds