INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

HELP - EKOS mount connection for dummies

  • Posts: 14
  • Thank you received: 0

I have had my Stellarmate now for almost a month and still cannot get it to control my iOptron 120 mount. I can connect via stellarmate to every possible driver (focuer, ZWO, etc. ) but not my mount. At times I do get it to "show" it being connected to the mount, but there is no response when I try to make the mount move, slew, goto, ,etc. It shows coordinates changing, etc. but not actual movement. I am connecting from laptop via VNC connection to SM. I have tried all the wizards, etc. but nothing seems to make it connect. I am connected to SM via usb/serial from mount, and running all the connections (camera ,mount )through startech powered USB 3 hub which plugs into SM. As a test, I used the same ethernet and USB set-ups to control my mount successfully directly from my laptop so I know those USB/ethernet cable connections work when not running through SM. Based on my limited knowledge of everything I have tried, it looks to be a driver related issue and how EKOS is not recognizing the library?


1. Should settings be local or remote? How do I know what I am?
2. There are several drivers listed for iOptron mount including one that looks to be for the GOTONova (HC?). I have tried several but nothing seems to make it connect.
3. I use the serial port wizard and it maps successfully to /dev/mount, but in EKOS, it does not seem to recognize that port name. Is there something that has to be done to place the dev/mount drive into EKOS?
4. I have tried connecting from mount to SM via ethernet but that does nothing. Not even sure what IP address to use in EKOS (is it the mount, the router, or SM's IP).

We can send a man to the moon, it should'nt be that difficult to connect and make the mount respond so I would love to know how you'all are doing it.

3 years 3 months ago #37811

Please Log in or Create an account to join the conversation.

  • Posts: 1251
  • Thank you received: 219
I have a few ideas for you to look into.
1. If you are are connecting to the mount through the hand controller, then you may have to enable some form of PC Direct mode within the hand controller. (May go by another name.)
2. I found I have to have my mount connected directly to the Raspberry Pi/Stellarmate. I also have the 7 port USB hub from Startech, I love it, but for some reason I can not connect to the mount through it.
3. Just to be thorough, make sure the mount is unparked.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
3 years 3 months ago #37818

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
Thanks for the suggestions Ihoujin. I was finally able to connect my mount to stellarmate and it looks from what I can tell, the only thing that changed was to change the baud rate up to the highest setting. Perhaps the iOptron drive V3 was not connecting under the 9600 baud default but that is the only thing that I can think of that changed that made it finally connect.

Clear skys!
3 years 3 months ago #37884

Please Log in or Create an account to join the conversation.

  • Posts: 415
  • Thank you received: 73
Good to hear you got it working.
Is parking and unparking with INDI working ok for you?

How is the CEM120 going? I'm seriously considering getting this mount.
Well I've been considering it for almost 1 year :-)
Celestron C11 iOptron CEM120 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
3 years 3 months ago #37910

Please Log in or Create an account to join the conversation.

Time to create page: 0.369 seconds