×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

Install Stellarmate OS on ASI AIR pro and 12V power ports

  • Posts: 109
  • Thank you received: 0
Hi all,

This isn't technically a Stellarmate question but here it goes.

I purchased an ASI AIR as a way of remotely controlling my astrophotography rig. After playing around with it I'm really not that impressed with the UI and functionality. Looks like it was written for a 5 year old. All big buttons an limited functionality.

I have also been using KSTARS & EKOS on my Windows machine but have been having issues connecting certain devices as the INDI drivers aren't compatible.

I'm looking ata few options but one that intrigued me was the ability to purchase the Stellarmate OS and install it on a RPI# machine. Now I believe the ASI AIR is a RPI3 & so an idea formed in my head that I could install the Stellarmate OS on the ASIAIR, thereby gaining the twin advantages of using KSTARS/EKOS & remote control on my rig.

So my questions are these:
Is it possible to install the Stellarmate OS over the ASI AIR OS? If so could someone post or direct me to detailed instructions on how to do this.

If the above is not possible, I believe I can use a VM (EKOS VM I believe) on which I can run the INDI server. Would someone be so kind as to post the location of the file and detailed instructions on how to install this on a Windows 7/10 machine.

Thanks in advance.

Rene
Sky-Watcher AZ-EQ6
Sky-Watcher Esprit 100
Sky-Watcher EvoGuide 50 (guide-scope)
ZWO ASI294MC Pro
ZWO ASI120MM mini (guide cam)
Pegasus PPB
Pegasus Focus Cube v2
1 year 10 months ago #39479

Please Log in or Create an account to join the conversation.

  • Posts: 125
  • Thank you received: 24
You could remove the SD card from ASI air , install Stellarmate OS on another SD card and use that in RPI.

Steps to install is described here stellarmate.com/products/stellarmate-os.html
1 year 10 months ago #39482

Please Log in or Create an account to join the conversation.

Right, as Tarun said above, just burn the SM OS image to the SD card. Now you'd be missing one thing which is the real-time clock that comes with StellarMate controller (I don't believe ASIAIR has it).
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: starbuck3108
1 year 10 months ago #39490

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I have just attempted doing this today, what a coincidence! I was also over the asiair.

I have flashed stellarmate os and used that in the air, it's turning on and generating a hotspot fine. But It isn't being discovered in the app. Do you have an idea why this is happening? I have tried restarting everything and reconnecting to the hotspot but it just won't show. I've also tried manually connecting and using the ip address but that also gets an error.

I'm sure it will work I'm just not sure if I'm doing something wrong. I know the asiair defaults to 5ghz. Would that be the issue maybe?

Would really appreciate any ideas :)
1 year 10 months ago #39641

Please Log in or Create an account to join the conversation.

Is this on Android? Try to install this updated APK: www.dropbox.com/s/hzsckdjak8nzfjs/stellarmateapp.apk?dl=0

Can you connect to it from the PC?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 10 months ago #39642

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Thanks for your quick response Jasem, Yes it is with Android. I installed that APK and still no luck. If I want to connect over a PC I will need to use ekos correct? Or do you mean just through the web manager?
1 year 10 months ago #39645

Please Log in or Create an account to join the conversation.

Just to confirm, you flashed StellarMate OS v1.4.0 to the SD card? From PC use browser and connect to either the Web Manager (stellarmate.local:8624) or VNC (stellarmate.local:6080/vnc.html) or Ekos, they all should work.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 10 months ago #39654

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Hi Jasem,

I believe I have got it to work now, I re-installed everything and have managed to discover the device and register. I haven't tried connecting my gear yet, had to go to work but I will give it a shot when I get home. Thank you again for your help.
1 year 10 months ago #39662

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Sorry to bother you again Jasem. Thought it would be easier to reply here than start a new thread. First of all just wanted to confirm that I can get everything connected with stellarmate OS flashed to the asi air both in ekos through VNC and in the stellarmate app. However I've now encountered a new problem. When I slew to a target the alignment is off by a lot and the scope actually starts going down below the horizon. I have a solid polar alignment (use sharpcap) and I'm using eqmod so ekos knows where the scope is parked. In kstars I can see it pointing at the SCP but as soon as I select a target (I use acrux normally for focus and plate solve) it just goes almost in the opposite direction.

As far as I know everything is set up correctly. I do not have a GPS dongle but I make sure that the time and location is accurate in kstars and that kstars is set to update time and location for everything. This problem also happens when I use the stellarmate app on android. I'm really not sure what is causing the problem. I know I should include logs for any support request and I can do that and open a ticket if that is easier for you. I'm just at work right now and I thought I would get in touch and see if its an easy fix. Looking to be a clear night tonight and I'd love to get some first light with the stellarmate.

appreciate any help with this.

PS I'd just like to say thank you to you and anyone else involved in stellarmate/ekos as you are the only platform that supports cameras outside of canon/nikon and dedicated astro cams. I had given up thinking that I could get a proper astro program to control my olympus camera but once I found out about stellarmate/ekos I've never been more excited to use my scope.
1 year 10 months ago #39837

Please Log in or Create an account to join the conversation.

This indeed looks like a Time and/or location issue.

When you start up EQMod, is the driver crosshair pointed at the NCP?

Is the StellarMate time correct? Double check that.

The site management tab of EQMod driver, double check time and location.

You can also trying purging the Parking Configuration or the regular configuration in Options tab to start a new and see if that makes a difference, but I'll reserve this option to last.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 10 months ago #39851

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
Hi erverybody,

I have an ASIAIR PRO and purchased Stellarmate OS the goal was to use the APP on this device.

I confirm that it works like explain above, but the ASIAIR PRO device contains five 12V DC output very usefull for power supply camera, focuser, but with Stellarmate it seams that those power supply output are not active.

I'm little bit disappointed, somebody knows whether Is there a way to activate the power supply?
7 months 11 hours ago #59743

Please Log in or Create an account to join the conversation.

  • Posts: 62
  • Thank you received: 9

laurent.wolff wrote: Hi erverybody,

I have an ASIAIR PRO and purchased Stellarmate OS the goal was to use the APP on this device.

I confirm that it works like explain above, but the ASIAIR PRO device contains five 12V DC output very usefull for power supply camera, focuser, but with Stellarmate it seams that those power supply output are not active.

I'm little bit disappointed, somebody knows whether Is there a way to activate the power supply?


You may want to start a new thread with the DC power and ASIAIR PRO using the StellarMate OS as your subject to get a quicker reply. Have your tried to load another driver that will control DC power outputs like the "Pegasus Astro Pocket Powerbox" (BTW do this at your own risk, as I do not know if they are even in the same ballpark...) otherwise it may be a function of someone reverse engineering the DC outputs on the ASI to get them activated/access.


Cheers
Jim
Celestron CGX, QSI683 Astrodon Gen 2 E series LRGB, Ha, OIII, ES102CF, ZWO-ASI178MC, 60mm guide scope, Pegasus Focus Cube 2, Feather Touch Focuser.
Last edit: 6 months 4 weeks ago by jws_indi.
6 months 4 weeks ago #59805

Please Log in or Create an account to join the conversation.

Time to create page: 0.667 seconds