×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Trying to get Stellarmate running on Raspi4

1 month 3 days ago
bemart
Fresh Boarder
Fresh Boarder
Posts: 11
More
Topic Author
Trying to get Stellarmate running on Raspi4 #44722
I will start with saying how much Stellarmate impresses me every time I use it! WE have 3 observatories for teaching purposes - one equipped with a Paramount MX, one with a custom build GEM - each carrying large telescopes and a smaller observatory with an HEQ5 and Stellarmate used for various small refractors (SV 102, SV70 etc). Under good conditions I routinely get rms guiding errors between 0.7" - 1.1". For 50 bucks and a Raspi3 this is outstanding. You can see some of the images taken with this setup at martin.kcvs.ca/astro/course/gallery.html

I am now attempting to use a new Raspi4 (4G) but am unable to get the most current build (StellarMateOS_1.4.4_rpi3.img.xz) to run. It burns fine onto an SD card (using Etcher) but when installed in the Raspi does not boot. I have tried several sd cards with the same result. The Raspi4 is running fine under Raspbian. Anyone have experience and success with Stellarmate on the Raspi4?

Please Log in or Create an account to join the conversation.

1 month 3 days ago
Ihoujin
Platinum Boarder
Platinum Boarder
Posts: 690
Karma: 3
More
Trying to get Stellarmate running on Raspi4 #44723
Ubuntu mate, the Linux OS Stellarmate runs is not officially supported on the raspberry pi 4 yet. At this time there is a RPi4 compatible version in the works running Ubuntu server with the mate desktop installed but it is still in beta. If you obtain it from Jasem you can help test it.

INDI/KStars on Raspberry Pi 3B+
Lubuntu 16.04
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG @280mm Guide Scope
PHD2
Adafruit Motor Hat shield
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.

Please Log in or Create an account to join the conversation.

1 month 3 days ago
AstroNerd
Moderator
Moderator
Posts: 635
Karma: 1
More
Trying to get Stellarmate running on Raspi4 #44729
Try using something different to burn the SD card as I have seen this before...not sure why but sometimes it does not burn the two partitions correctly the BOOT partition is missing...

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 3 days ago
bemart
Fresh Boarder
Fresh Boarder
Posts: 11
More
Topic Author
Trying to get Stellarmate running on Raspi4 #44733
Yep - certainly seems that the boot partition is mia - thanks for the tip.

brian

Please Log in or Create an account to join the conversation.

1 month 3 days ago
khobar
Junior Boarder
Junior Boarder
Posts: 39
More
Trying to get Stellarmate running on Raspi4 #44735
Hi,

I have Stellarmate 1.4.4 running on my Rp4, so it works.

I'm curious - you say you're trying to use StellarMateOS_1.4.4_rpi3.img.xz??? That's for the pi3. I seem to recall I burned that and it didn't work on my pi4.

I've posted a bunch here regarding Stellarmate on my pi4, working through some teething issues. They seem to be mostly solved - I still have connection issues.

Oh, and I've had some trouble with SD cards - I started with a 32GB and it worked fine for a while, but I corrupted it by not gracefully shutting down. However, once I realized that, I had another problem with a replacement 64GB card whereby VNC just gave me a black screen and that was that. I burned another fresh copy and I've been up and running for a month or so I think now?

Bottom line - it works. Good luck.

Please Log in or Create an account to join the conversation.

1 month 3 days ago
bemart
Fresh Boarder
Fresh Boarder
Posts: 11
More
Topic Author
Trying to get Stellarmate running on Raspi4 #44738
Thanks! That is good news. Where did you get your build for the Raspi4?

b

Please Log in or Create an account to join the conversation.

1 month 3 days ago
Lead_weight
Gold Boarder
Gold Boarder
Posts: 232
Karma: 2
More
Trying to get Stellarmate running on Raspi4 #44743
It works for me too. If you look at the name of the file you posted above its's the RPi3 version you listed. Not the PRi4 version. There's a separate download for the RPi4. It should be in the same download area after you log into the StellarMate site.

-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
The following user(s) said Thank You AstroNerd

Please Log in or Create an account to join the conversation.

1 month 3 days ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 408
Karma: 3
More
Trying to get Stellarmate running on Raspi4 #44749
KStars definitely works under Raspbian, Ubuntu MATE and Manjaro Linux on the RPi4.

Running under Manjaro as I am writing this using ASI120MM (USB2 version) for guiding and DSLR Nikon3300 on iOptron SmartEQPro+.

bemart: The RPi3 image will not work on the RPi4.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 3 days ago
AstroNerd
Moderator
Moderator
Posts: 635
Karma: 1
More
Trying to get Stellarmate running on Raspi4 #44762
When you log onto your SM account, and go to your orders, then downloads, there will be two files, one is for rpi3 and the other rpi4, you have downloaded the incorrect version... :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

1 month 1 day ago
khobar
Junior Boarder
Junior Boarder
Posts: 39
More
Trying to get Stellarmate running on Raspi4 #44839
From the Stellarmate page. I didn't know there were two images and downloaded the wrong one first. ;)

Please Log in or Create an account to join the conversation.

1 month 1 day ago
bemart
Fresh Boarder
Fresh Boarder
Posts: 11
More
Topic Author
Trying to get Stellarmate running on Raspi4 #44852
Thanks to everyone who responded. I found the tight build and it installed fine. Only issues so far are "flaky" wireless connection and autoguiding. Likely both are "self-inflicted" problems so I will try again on the next clear night.

Brian

Please Log in or Create an account to join the conversation.

2 weeks 6 days ago
ahawkinson
Fresh Boarder
Fresh Boarder
Posts: 1
More
Trying to get Stellarmate running on Raspi4 #45264
I've been running on the RP4 for a couple of months with pretty good success overall. However, with the most recent software updates (the automatic ones you can download from the updater tool on Stellarmate desktop) I am getting the blank black screen on both of my two stellarmates. Trying to burn a fresh copy now to see if it resolves the issue, but wondering if you have had this issue come up again?

Please Log in or Create an account to join the conversation.

Time to create page: 0.527 seconds