×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Trying to get Stellarmate running on Raspi4

  • Posts: 16
  • Thank you received: 4
I will start with saying how much Stellarmate impresses me every time I use it! WE have 3 observatories for teaching purposes - one equipped with a Paramount MX, one with a custom build GEM - each carrying large telescopes and a smaller observatory with an HEQ5 and Stellarmate used for various small refractors (SV 102, SV70 etc). Under good conditions I routinely get rms guiding errors between 0.7" - 1.1". For 50 bucks and a Raspi3 this is outstanding. You can see some of the images taken with this setup at martin.kcvs.ca/astro/course/gallery.html

I am now attempting to use a new Raspi4 (4G) but am unable to get the most current build (StellarMateOS_1.4.4_rpi3.img.xz) to run. It burns fine onto an SD card (using Etcher) but when installed in the Raspi does not boot. I have tried several sd cards with the same result. The Raspi4 is running fine under Raspbian. Anyone have experience and success with Stellarmate on the Raspi4?
4 years 5 months ago #44722

Please Log in or Create an account to join the conversation.

  • Posts: 1309
  • Thank you received: 226
Ubuntu mate, the Linux OS Stellarmate runs is not officially supported on the raspberry pi 4 yet. At this time there is a RPi4 compatible version in the works running Ubuntu server with the mate desktop installed but it is still in beta. If you obtain it from Jasem you can help test it.
4 years 5 months ago #44723

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 140
Try using something different to burn the SD card as I have seen this before...not sure why but sometimes it does not burn the two partitions correctly the BOOT partition is missing...
4 years 5 months ago #44729

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Yep - certainly seems that the boot partition is mia - thanks for the tip.

brian
4 years 5 months ago #44733

Please Log in or Create an account to join the conversation.

  • Posts: 169
  • Thank you received: 3
Hi,

I have Stellarmate 1.4.4 running on my Rp4, so it works.

I'm curious - you say you're trying to use StellarMateOS_1.4.4_rpi3.img.xz??? That's for the pi3. I seem to recall I burned that and it didn't work on my pi4.

I've posted a bunch here regarding Stellarmate on my pi4, working through some teething issues. They seem to be mostly solved - I still have connection issues.

Oh, and I've had some trouble with SD cards - I started with a 32GB and it worked fine for a while, but I corrupted it by not gracefully shutting down. However, once I realized that, I had another problem with a replacement 64GB card whereby VNC just gave me a black screen and that was that. I burned another fresh copy and I've been up and running for a month or so I think now?

Bottom line - it works. Good luck.
4 years 5 months ago #44735

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Thanks! That is good news. Where did you get your build for the Raspi4?

b
4 years 5 months ago #44738

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 139
It works for me too. If you look at the name of the file you posted above its's the RPi3 version you listed. Not the PRi4 version. There's a separate download for the RPi4. It should be in the same download area after you log into the StellarMate site.
The following user(s) said Thank You: AstroNerd
4 years 5 months ago #44743

Please Log in or Create an account to join the conversation.

  • Posts: 1119
  • Thank you received: 182
KStars definitely works under Raspbian, Ubuntu MATE and Manjaro Linux on the RPi4.

Running under Manjaro as I am writing this using ASI120MM (USB2 version) for guiding and DSLR Nikon3300 on iOptron SmartEQPro+.

bemart: The RPi3 image will not work on the RPi4.
4 years 5 months ago #44749

Please Log in or Create an account to join the conversation.

  • Posts: 1067
  • Thank you received: 140
When you log onto your SM account, and go to your orders, then downloads, there will be two files, one is for rpi3 and the other rpi4, you have downloaded the incorrect version... :)
4 years 5 months ago #44762

Please Log in or Create an account to join the conversation.

  • Posts: 169
  • Thank you received: 3
From the Stellarmate page. I didn't know there were two images and downloaded the wrong one first. ;)
4 years 5 months ago #44839

Please Log in or Create an account to join the conversation.

  • Posts: 16
  • Thank you received: 4
Thanks to everyone who responded. I found the tight build and it installed fine. Only issues so far are "flaky" wireless connection and autoguiding. Likely both are "self-inflicted" problems so I will try again on the next clear night.

Brian
4 years 5 months ago #44852

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
I've been running on the RP4 for a couple of months with pretty good success overall. However, with the most recent software updates (the automatic ones you can download from the updater tool on Stellarmate desktop) I am getting the blank black screen on both of my two stellarmates. Trying to burn a fresh copy now to see if it resolves the issue, but wondering if you have had this issue come up again?
4 years 5 months ago #45264

Please Log in or Create an account to join the conversation.

Time to create page: 0.657 seconds