×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Issues or general comments of the new Raspbian Based Stellarmate 1.5.0

3 months 1 day ago
Tim Roske
Fresh Boarder
Fresh Boarder
Posts: 11
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #50433
That fixed it. Thank you.

Please Log in or Create an account to join the conversation.

3 months 1 day ago
maxthebuilder
Platinum Boarder
Platinum Boarder
Posts: 333
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #50449
Upgraded to 1.5.1
Ran a 60x240s sequence. All on RPI4 (as quoted below). Not a single problem. Really nice!

Well, there was one issue which is not RPI4 or 1.5 specific and has been there for quite a while.
Bias frames. (this was reported before).
Often, Ekos takes bias frames but they are completely empty (no signal whatsoever).
Usually this happens on the first run, when switching from Lights or Darks to Bias.
Switching back to Lights and taking a few exposures makes Bias to behave normally.
Couldn't quite figure out the exact pattern.
At least I know now that the issue exists and sort of know how to get around it.

Thanks!

maxthebuilder wrote: Last night I had a successful session with 1.5.0 (RPI4). Not a single problem.
Everything was running on RPI. VNC from Windows PC (wired) and Android tablet (wireless).
Polar Align. 3-4 stars align. Autoguiding (internal). Meridian flip (went well without any interaction).
No autofocus (I don't have an autofocuser). No scheduler, just a single 100x120s sequence.
ZWO cameras. HEQ5 mount (cable connection). Astrometry.net (offline) with sextractor.
This coming weekend I am going to travel to a dark side (from Bortle 9 to Bortle 4) and try it there.
After that I'll try to upgrade to 1.5.1.
(Jasem mentioned that it could be done from the dashboard but people complained that there were still no updates as of earlier today).


Max S.
RPI 3 B+ with ABerry and RPI 4 B (4Gb) with SMate.
Nikon D5500 H-a modified. 180 mm f/2.8 antique Nikon. Tamron AF 28-75mm f/2.8. Rokinon 135mm f/2.
AT72EDII.
ZWO ASI294MC Pro
ZWO ASI120MC-S on ZWO 30F4 MiniScope.
SW AZ-GTi.
SW HEQ5.
iOptron SkyTracker Pro.

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
hiroyuki
Fresh Boarder
Fresh Boarder
Posts: 6
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51036
It is a stellarmate application for android tablet, but it can be connected, but it takes a long time to connect. Do you have any tips for a quick connection?

Please Log in or Create an account to join the conversation.

2 months 1 week ago
rishigarrod
Expert Boarder
Expert Boarder
Posts: 86
Karma: 3
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51153
Last night I had to position my mount slightly further away from the house which meant that my wifi connection from my laptop running Kstars and INDI on the Pi was not strong.
I lost connection a few times and focussing was impossible (too long required for the download).

I had an old Airport Express (mini router/Access point) which I have now connected directly to the Pi with a cable. Seems to have solved my wireless woes.
I think the Pi wireless access point is very weak and only really seems to work if you are within a couple of metres.

WO ZS 61
Esprit 100
Skyliner 200p
Edgehd 8 with Celestron OAG
Stellarmate on RPi 4
HEQ5 with belt mod and ADM dual saddle
294 mc pro
224 guide cam
Powerbox PPB
Sesto Senso focusser
Arduino focusser
QHY5II-Mono guide camera
EOS6D - not modified

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 707
Karma: 3
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51163

rishigarrod wrote: Last night I had to position my mount slightly further away from the house which meant that my wifi connection from my laptop running Kstars and INDI on the Pi was not strong.
I lost connection a few times and focussing was impossible (too long required for the download).

I had an old Airport Express (mini router/Access point) which I have now connected directly to the Pi with a cable. Seems to have solved my wireless woes.
I think the Pi wireless access point is very weak and only really seems to work if you are within a couple of metres.


That honestly baffles me. I imaged again last night and my rig is ~60ft away from the WiFi extender I am using for coverage in my backyard. So definitely not ideal conditions, with distance, extender and all.
Nonetheless, the INTERNAL 5GHz WiFi of the Pi4 never had any trouble whatsoever with that constellation.
I get consistent connection speeds of ~ 390 Mbs, which makes for a very snappy response via VNC. I am running KStars on the Pi4 directly.
I can only wonder whether the poor connection many people here are describing is the result of either a subpar power supply that cannot pull the Amps the Pi4 needs to run at full speed, or whether it is somehow related to the OS. I am using Ubuntu 18.04 as my OS on the Pi4.
Maybe the key is the power supply. I am using the one that came with the Canakit when I originally ordered the Pi4. Rated to 3.5 Amps.

www.amazon.com/CanaKit-Raspberry-Power-S...-USB-C/dp/B07TYQRXTK

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

2 months 1 week ago 2 months 1 week ago by dmsummers. Reason: typo
dmsummers
Gold Boarder
Gold Boarder
Posts: 177
Karma: 1
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51164
@rishigarrod: Just popping prior post on issues between USB3 and Wifi at 2.4Ghz. It's not clear whether you're using the Pi4's USB3 ports, and you didn't say whether your wireless is using 2.4Ghz. If yes to both, it's most likely that you are experiencing RF interference. This has nothing to do with SM 1.5. It's solely a function of Pi4's USB3 close proximity to the internal wifi antenna. See this prior post for details and workable solutions: www.indilib.org/forum/general/6576-pi4-u...erference.html#50509
FWIW, after adding a direct ethernet cable from laptop to Pi4 (lured by speed improvement), I'd never go back to wireless now unless it was an absolute emergency ! Clear skies...

p.s. For Jo, I'll note that although power supply can be a problem (lots of prior posts on poor power issues), when it's Pi4, USB3, and wifi at 2.4Ghz, it's almost certain to be RF interference (and NOT power). Similar symptoms though, so it can be very confusing. Folks need to take note as they migrate to Pi4 with USB3 since 2.4Ghz wireless is everywhere, and people don't necessarily think to take action to switch over to 5Ghz.

RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
Megiddo
Gold Boarder
Gold Boarder
Posts: 244
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51165

dmsummers wrote: FWIW, after adding a direct ethernet cable from laptop to Pi4 (lured by speed improvement), I'd never go back to wireless now unless it was an absolute emergency ! Clear skies...


Yeah... the speed difference and reliability keeps me hardwired. I'm spoiled now. 11MB/sec vs <1-4MB/sec

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 707
Karma: 3
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #51166

dmsummers wrote: @rishigarrod: Just popping prior post on issues between USB3 and Wifi at 2.4Ghz. It's not clear whether you're using the Pi4's USB3 ports, and you didn't say whether your wireless is using 2.4Ghz. If yes to both, it's most likely that you are experiencing RF interference. This has nothing to do with SM 1.5. It's solely a function of Pi4's USB3 close proximity to the internal wifi antenna. See this prior post for details and workable solutions: www.indilib.org/forum/general/6576-pi4-u...erference.html#50509
FWIW, after adding a direct ethernet cable from laptop to Pi4 (lured by speed improvement), I'd never go back to wireless now unless it was an absolute emergency ! Clear skies...

p.s. For Jo, I'll note that although power supply can be a problem (lots of prior posts on poor power issues), when it's Pi4, USB3, and wifi at 2.4Ghz, it's almost certain to be RF interference (and NOT power). Similar symptoms though, so it can be very confusing. Folks need to take note as they migrate to Pi4 with USB3 since 2.4Ghz wireless is everywhere, and people don't necessarily think to take action to switch over to 5Ghz.


Thanks, Doug! I had forgotten about the WiFi interference problem. Never had it, since it felt natural to connect via 5 GHz only. 2.4 GHz WiFi is just too slow. About 6 times slower.
Anyway, just to let everyone know not to give up on the internal WiFi of the Pi4. It works great on 5 GHz and it is not weak at all.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 2 weeks ago by Andi.
Andi
Fresh Boarder
Fresh Boarder
Posts: 11
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #52126
what makes the difference between astroberryserver and stellarmate ? astroberry runs fast and smooth. stellarmate is laggy and slow. almost ususable.

Please Log in or Create an account to join the conversation.

1 month 1 week ago
suvowner
Senior Boarder
Senior Boarder
Posts: 62
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #52774

knro wrote: Glad to hear about it. Dashboard update is broken in 1.5, run the Package Updater or just manually upgrade:

<code>
sudo apt-get update && sudo apt-get -y dist-upgrade
</code>


still having trouble getting an update to complete.

this command didn't get it done either.

Please Log in or Create an account to join the conversation.

1 month 1 week ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1477
Karma: 7
More
Issues or general comments of the new Raspbian Based Stellarmate 1.5.0 #52775
apt-get dist-upgrade alone is not enough to update the packages on a deb based system. Try

sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y


HTH, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

Time to create page: 1.107 seconds