×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

ZWO 2600MC is not working - Crashes consistently after two subs

  • Posts: 119
  • Thank you received: 11
Well this is a massive bummer. I have a new 2600MC and haven't been able to use it due to weather for many weeks now and with the first two clear nights now Kstars is crashing consistently. I'm running full StellarMate on a 4gig Pi4 and its been working really well previously with my other zwo1600mc for ~2yrs now.

The camera is working OK too. For example I can take images for plate solving, do a run of flats using the auto-exposure settings, set continuous exposures for focusing etc etc.

Once I set auto-guiding and start an imaging run it is consistently just crashing straight after the 2nd sub is taken. This is repeatable across both Kstars 3.5.0 stable and 3.5.1 stable. Like clockwork, boom, Kstars and everything else crashes after the 2nd sub every time......

I've attached debug logs here as well.

Has anyone got the new 2600MC by chance and can use it successfully?
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
Last edit: 4 months 4 weeks ago by Craig. Reason: adding additional details
4 months 4 weeks ago #65920

Please Log in or Create an account to join the conversation.

  • Posts: 1929
  • Thank you received: 413
I have one and it is working wonderfully well. I see that you get a Debayer error. Did you enable the DSLR Image Viewer in the KStars settings in the Ekos -> Capture tab? Because I have that disabled. Maybe that's part of the cause?
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You: Craig
4 months 4 weeks ago #65923

Please Log in or Create an account to join the conversation.

I've seen this issue before, and it's related to memory. I've raised the issue here: indilib.org/forum/development/8520-manag...in-raspberry-pi.html

EDIT: If you disable FITS Viewer in Configure KStars --> Settings --> FITS --> Use FITS Viewer, then no more crashes?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Craig
Last edit: 4 months 4 weeks ago by Jasem Mutlaq.
4 months 4 weeks ago #65928

Please Log in or Create an account to join the conversation.

  • Posts: 1929
  • Thank you received: 413
I wrote DSLR Image Viewer and of course I meant FITS Viewer. Thanks for the correction Jasem!
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
4 months 4 weeks ago #65938

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 11
Thanks for these responses.

If I make one change and use my zwo1600mc VS 2600MC all this works just fine though and have been using this for two years now. Also, the first sub from the 2600MC comes back in the FITS viewer just fine as well. So its not the FITS viewer with debaying problems because this works perfectly with my other OSC camera.

This was where it got weird for me. Why does the first sub work at all????? You'd think that if there was a problem, it'd be consistent for all subs from the 2600MC in the FITS viewer. Like clock work though, that 2nd sub entirely takes down all of Kstars/EKOS.

To add to this as well, I can have the FITS viewer running view all my calibration frames. So before the crashes last night I shot 25 sky flats WITH the FITS viewer running. I messed around with building a dark frame library too, this too works with showing the FITS files as they are being shot. Both worked like normal as well. Which is another question, why is there a difference if its viewing flats/darks VS light subs?!?! I don't get this, they are all light frames per se from a FITS view perspective and all are the same file size and display in the FITS viewer, except when actually imaging because of the crashing.

Jasem to the memory question, this is on a 4gig of RAM Pi4. I was looking at the memory consumption from the web manager while this was happening (super addition BTW) and it was hovering around ~25-40% memory usage, so its not running out of physical memory if this helps. Focus/plate solving et all all work just fine here too, regardless of the binning I'm using. So 5sec 1x1 binning during focus is working a treat with the 2600mc in viewing the subs. So the inbuilt FITS viewers in focus and plate solve don't seem to be exhibiting this issue whatsoever and I thought these and the FITS viewer were the same code base.

I'll try that work around of not using the FITS viewer, but this isn't a long term solution. I hope the crash dumps help.

I also wonder what other folks are doing that are using a Pi4 with a camera like the 2600MC that I am not doing here.
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
Last edit: 4 months 4 weeks ago by Craig.
4 months 4 weeks ago #65952

Please Log in or Create an account to join the conversation.

  • Posts: 190
  • Thank you received: 16
Wouter,
I noticed that your signature mentions an ASI6200 rather than an ASI2600.
Ed
Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 4GByte under Raspberry Pi OS thanks to Astroberry
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR and ASI533MC on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian
4 months 4 weeks ago #65989

Please Log in or Create an account to join the conversation.

  • Posts: 1929
  • Thank you received: 413
Ed, it does. I have those too. Actually, the ASI2600MC is my fiancee's so that's why I didn't add it to my signature. But I, well WE, have used it on her RedCat and on our SharpStar 94EDPH. Unfortunately, due to high clouds and processing issues (no flats because I was too lazy and wrong gain/offset due to software updates) I have not posted any images taken with this camera. But I assure you that we have very successfully used the ASI2600MC on KStars (both stable and recent nightly) without any issues at all.
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
The following user(s) said Thank You: Ed Wilson
Last edit: 4 months 4 weeks ago by Wouter van Reeven.
4 months 4 weeks ago #65993

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 11
Can I pester you and ask if you have FITS viewer enabled though when using EKOS with the 2600MC though? I don't understand how this could be working for some and not others (I've had this under the current and previous version of Stellarmate OS, so that's Kstars 3.5.0 and 3.5.1 I think)

Jasem - due to clouds I've not had the chance to test this work around and will report back when I can.
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
4 months 3 weeks ago #66080

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 11
Folks here is a link to a folder with subs that were taken with the 2600MC with the crashing Kstars/EKOS problem. I hope this helps with the diagnosis.

drive.google.com/drive/folders/1H30ZsvmO...3eEUPLwf?usp=sharing
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
4 months 2 weeks ago #66450

Please Log in or Create an account to join the conversation.

I've actually pushed a fix in nightly a couple of days ago. "Adaptive Sampling" is a new option that should help reduce memory usage. Can you try with the latest KStars nightly?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Craig
4 months 2 weeks ago #66464

Please Log in or Create an account to join the conversation.

Just tested this with simulators on StellarMate OS and looks like the new patch is holding up well with theses images as well.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Craig
4 months 2 weeks ago #66466
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 11
Thanks for this Jasem, great stuff. I've had like ~2mths of clouds and not respite in sight for me in the coming week or so as well....so testing is going to be hard in the short term.

Is this patch going to make it into the main stream stable release sometime soon?
Skywatcher EQ6R / EdgeHD 8" / ZWO 1600MC / 2600MC / ZWO 290mm / 120MM-S / StellarMate
4 months 2 weeks ago #66501

Please Log in or Create an account to join the conversation.

Time to create page: 0.727 seconds