×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

Re:Re:Problem with new profile: focal length not recognized by ekos

  • Posts: 53
  • Thank you received: 4
Hi all,
I just got my new small Newton telescope, so I added a new profile in EKOS, and also added a new telescope with the right focal length (600mm). Meanwhile I have 10 telescopes in the list (with all the reducers, guiding scopes and so on)

When testing the new scope following happens: I choose the right profile, checked weather the right telescope is selected (it was) and started ekos. I pointed to Arcturus and wanted to plate solve, but plate solving was not possible. So I checked everything and realized that the focal length was wrong (1000mm, which I used the session before). Even after restart the wrong focal length was present! Until that issue it was that the focal length of the profile was taken by ekos.

Also missing was the button "Set" in the indi tab for the mount. So it was not possible to easy fix that issue.

What is going wrong here?

I'm using stellarmate with all current updates (kstars 3.5.3, indi 1.9.0).
The following user(s) said Thank You: Eric
1 month 2 weeks ago #72254

Please Log in or Create an account to join the conversation.

  • Posts: 1008
  • Thank you received: 297
Could you check what configuration is in use in the Mount module when you open your profile? That may be what the Align module is using. There may be a discrepancy there that we need to fix.

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 month 2 weeks ago #72255

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 4
Hi Eric,
thank you for the quick reply. I always use Config#1, no matter what scope I used. This was till now no problem, because the focal length from the Profile in Ekos was used.

What I've done to get the problem solved was to create a new Config#2 with the focal length 600mm. But it would be good, if the old behaviour would still exist: choose a telescope in the Profiles and everything is ok. Perhaps til now I used kstars wrong maybe ;-)
The following user(s) said Thank You: Eric
1 month 2 weeks ago #72257

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 4
Hi Eric,
I really have to apologize! I'm just out continuing testing my new scope and now I have double checked the issue I reported. I run through all the settings, and at last I checked the entry of my newton: I forgot to set the focal length and diameter So EKOS couldnt even know the values! Sorry for given a wrong alert...
1 month 2 weeks ago #72273

Please Log in or Create an account to join the conversation.

  • Posts: 1008
  • Thank you received: 297
Thanks for reporting anyway. It would be interesting to have the configuration in the Mount module follow the Profile information nonetheless (which might already be the case, I didn't double check).

-Eric
HEQ5-Pro - Atik 314E - Orion ED80T - DMK21 on Orion 50mm
DIY 3D-printed Moonlite and FWheel RGB/LPR
KStars and indiserver on two Atom 1.6GHz 1GB RAM Linux, VPN remote access
1 month 2 weeks ago #72282

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 4
From my experience thats the case. I set up the Mount module once (geographical coordinates and so on) and never touched it till the issue this weekend happens. As I wrote I have several setups with different scopes, with OAG or with guiding scope and never had problems with it. I always set the scopes / cameras / focusers in the Profile. The settings from the Profile were taken by the mount.
The only thing I do in the mount module is turning PPEC on/off.

I just checked: the profile information from the new newton were taken from the mount module, so no problems from my side anymore
The following user(s) said Thank You: Eric
1 month 2 weeks ago #72297

Please Log in or Create an account to join the conversation.

Time to create page: 0.424 seconds