×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

INDI Driver for SVBONY cameras

  • Posts: 78
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Tom,

Thanks a lot.
I don't have enaught knwolegment for to do something about it.
Then you suggest to upgrade my EEPROM? How do I proceed for do it? Of course, first I check which EEPROM version I have.

Thanks a lot again,
Pep
11 months 5 days ago #67196

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi guys,

Sorry, I was away for a long time. Family business and a lot of work...

I just bought an RPi4, to see what's going on.
It comes from china, so, it could take a while...

My first concern is to check if the SV305 and the SV305 Pro behave the same way.
In my mind, it's USB 2.0/USB 3.0 related.

Possibly, Astro-DMX acts in a way which stresses the camera less.

Best regards,

Thx8411
10 months 4 weeks ago #67507

Please Log in or Create an account to join the conversation.

  • Posts: 78
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi thx8411,

Well been back. :)
It will be an important test that you do. I will be on the lookout for what you post.:woohoo: :)
While you wait, weather permitting, I can do some testing, if you need.
I have a raspi4 with 4Gb of RAM and sv305pro connected to a USB3 powered HUB and this connected to the raspi's USB3 port.

I guess you will have seen my latest reports on some tests I have been doing and the results I have gotten. If you need me to repeat something for more information or ... you know.

If you need somthing you will tell me,

Best regards,

Pep
10 months 4 weeks ago #67511

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi folks !

Thanks for your help Pep. I just got my RPi4 today.
I also got an RPi3. I have to do extensive tests RPi3/RPi4/AMD64, SV305/SV305PRO, USB2/USB3.

I actually reproduce the issue on RPi4/SV305PRO/USB2.
The first frame is OK, but I never get the second one.

First observation, for the first frame, we get the usb bulk datas. For the second one, it never comes.

First frame usb sniffing :

d8139900 1127851687 S Ci:1:006:0 s c0 d0 0001 3000 0001 1 <
d8139900 1127852168 C Ci:1:006:0 0 1 = 08
d8139900 1127853454 S Ci:1:006:0 s c0 d6 0001 0080 0001 1 <
d8139900 1127853916 C Ci:1:006:0 0 1 = 08
d8139900 1127854089 S Ci:1:006:0 s c0 d0 0000 3000 0001 1 <
d8139900 1127854550 C Ci:1:006:0 0 1 = 08
d8139900 1128616063 S Ci:1:006:0 s c0 b9 0000 0000 0002 2 <
d8139900 1128616152 C Ci:1:006:0 0 2 = 0113
d8139900 1128816561 S Ci:1:006:0 s c0 b9 0000 0000 0002 2 <
d8139900 1128816640 C Ci:1:006:0 0 2 = 0113
d8139c00 1128974084 C Bi:1:006:2 0 4147216 = d91a3203 00000000 01000000 00000000 01000100 01000100 01000100 01000100
d8139c00 1129010255 S Bi:1:006:2 -115 4147216 <

The second frame starts the same way :

d8139900 1157854005 S Ci:1:006:0 s c0 d0 0001 3000 0001 1 <
d8139900 1157854480 C Ci:1:006:0 0 1 = 08
d8139900 1157855768 S Ci:1:006:0 s c0 d6 0001 0080 0001 1 <
d8139900 1157856224 C Ci:1:006:0 0 1 = 08
d8139900 1157856399 S Ci:1:006:0 s c0 d0 0000 3000 0001 1 <
d8139900 1157856858 C Ci:1:006:0 0 1 = 08
d8139900 1158203763 S Ci:1:006:0 s c0 b9 0000 0000 0002 2 <
d8139900 1158203849 C Ci:1:006:0 0 2 = 0113
d8139900 1158404259 S Ci:1:006:0 s c0 b9 0000 0000 0002 2 <
d8139900 1158404339 C Ci:1:006:0 0 2 = 0113

But then it loops again and again :

...
d8139900 1158604797 S Ci:1:006:0 s c0 b9 0000 0000 0002 2 <
d8139900 1158604872 C Ci:1:006:0 0 2 = 0113
...

The camera datas never seem ready.


To be continued...
10 months 1 week ago #68153

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Further tests :

RPI3/SV305PRO/USB2 : KO aswell

RPI3/SV305/USB2 : OK
RPI4/SV305/USB2 : OK

usb trace :

d8084480 421735653 S Ci:1:004:0 s c0 d0 0001 3000 0001 1 <
d8084480 421736276 C Ci:1:004:0 0 1 = 08
d80843c0 421737537 S Ci:1:004:0 s c0 d6 0001 0080 0001 1 <
d80843c0 421738157 C Ci:1:004:0 0 1 = 08
d80843c0 421738324 S Ci:1:004:0 s c0 d0 0000 3000 0001 1 <
d80843c0 421738930 C Ci:1:004:0 0 1 = 08
d8084480 422017771 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084480 422017872 C Ci:1:004:0 0 2 = 0112
d8084840 422218284 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084840 422218382 C Ci:1:004:0 0 2 = 0112
d8084900 422419177 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084900 422419277 C Ci:1:004:0 0 2 = 0112
d80849c0 422619683 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d80849c0 422619779 C Ci:1:004:0 0 2 = 0112
d8084a80 422820217 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084a80 422820316 C Ci:1:004:0 0 2 = 0112
d8084b40 423020740 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084b40 423020840 C Ci:1:004:0 0 2 = 0112
d8084cc0 423221250 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084cc0 423221352 C Ci:1:004:0 0 2 = 0112
d8084c00 423421750 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084c00 423421843 C Ci:1:004:0 0 2 = 0112
d8084d80 423622238 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084d80 423622330 C Ci:1:004:0 0 2 = 0112
d8084e40 423822784 S Ci:1:004:0 s c0 b9 0000 0000 0002 2 <
d8084e40 423822891 C Ci:1:004:0 0 2 = 0112
d8084780 423858911 C Bi:1:004:2 0 4147216 = 573cf201 00000000 03000000 00000000 5d019701 5d019201 60019a01 5501a601
d8185240 423895898 S Bi:1:004:2 -115 4147216 <
10 months 1 week ago #68157

Please Log in or Create an account to join the conversation.

  • Posts: 236
  • Thank you received: 14

Replied by Tom on topic INDI Driver for SVBONY cameras

Weird.....Mine works well with RPI4 4GB and 8GB board. No more frames stopping. Good luck.

Tom
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
10 months 1 week ago #68161

Please Log in or Create an account to join the conversation.

  • Posts: 78
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Thx8411,

You are the MASTER of the Univers B) :)

Thank you so much for continuing to insist on the issue.:cheer: In fact looking at the answer lines, I see some pattern, but I don’t know what they mean.:oops:
I insist, if I can do something, you tell me.;)
Good luck and I look forward to good news from you regarding the sv305PRO (USB3 to raspi4 4gbRam).

{The SvBony company I know that they are interested that sv305pro works on INDI-Driver. I remember that you had the contact of them, don't it?. Could be a great help}

Thanks,

Pep
10 months 1 week ago #68184

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
I've actually had some time to try out a couple of powered USB3 hubs with my RPi4 + SV305Pro.

One is an Anker 7 port with a dedicated "power" port. that has an undersized barrel jack, yet still takes 12v. With this one, I was able to power the RPi4 through the charging port as well as connect the SV305Pro. Once I fabricobbled an adapter, it worked like an absolute dream. No issues whatsoever. I'll be picking up a couple more of these to simplify moving from rig to rig.

The other was a GEKRY 7 port, that supposedly is able to do what the Anker can on its last port, on every port. However, the RPi refused to boot or connect to the wifi while being powered by the hub and having the hub connected to its USB type A port. When powering the RPi from a separate 12v-5v dc-dc converter, I was able to connect the SV305Pro through the powered hub to the RPi4. But every few frames, one would come out over-exposed, and nearly all gray. PHD2 did not like this at all, and I had issues guiding.
10 months 1 week ago #68244

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi,

@Ginger

Non consistent background noise between frames usually means power issues. The camera regulator don't have enough power to regulate the voltage.
So, the analogic/digital converter reference voltage wiggles.

@Pep

Thanks, once the issue understood, and a fix found, I will need your help for testing. But at this time, I have to figure out what's going on.
And, no, I'm not the master of the universe. I don't save lives, I just try to fix a driver ;-) But thanks for your kind words !


Ok, I sniffed AMD64/SV305PRO/USB3 (I never had issues with this combo)
It behave like the SV305

ffff943969cfe780 216190798 S Ci:4:002:0 s c0 d6 0160 0013 0001 1 <
ffff943969cfe780 216191387 C Ci:4:002:0 0 1 = 08
ffff943969cfecc0 216202281 S Ci:4:002:0 s c0 d0 0001 3000 0001 1 <
ffff943969cfecc0 216202743 C Ci:4:002:0 0 1 = 08
ffff943969cfecc0 216202797 S Ci:4:002:0 s c0 d0 0001 3002 0001 1 <
ffff943969cfecc0 216203280 C Ci:4:002:0 0 1 = 08
ffff943969cfe780 216203340 S Ci:4:002:0 s c0 d6 0001 0080 0001 1 <
ffff943969cfe780 216203841 C Ci:4:002:0 0 1 = 08
ffff943969cfe540 216203887 S Ci:4:002:0 s c0 d0 0000 3000 0001 1 <
ffff943969cfe540 216204393 C Ci:4:002:0 0 1 = 08
ffff943969cfef00 216204438 S Ci:4:002:0 s c0 d0 0000 3002 0001 1 <
ffff943969cfef00 216204943 C Ci:4:002:0 0 1 = 08
ffff943969cfef00 216204985 S Ci:4:002:0 s c0 d6 00e0 0013 0001 1 <
ffff943969cfef00 216205495 C Ci:4:002:0 0 1 = 08
ffff943969cfec00 217254835 C Bi:4:002:2 0 4147216 = adea2b04 00000000 01000000 00000000 01000100 01000100 01000100 01000200
ffff943969fbda80 217258874 S Bi:4:002:2 -115 4147216 <

I also sniffed the SV305PRO/Astro_DMX usb stream.
Astro_DMX seems to use the camera's "Streaming mode". I use the "Trigger mode". In my mind, the trigger mode is better suited for 1 - 2s exposure guide frames.

To be continued...
10 months 1 week ago #68364

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
@Tom and Pep, are you comfortable with the linux command line ? Could you try this for me :

- login as root
- start the "usbmon" usb kernel sniffer : "modprobe usbmon"
- go to "/sys/kernel/debug/usb/usbmon/"
- plug the camera and look at its usb bus number with the "dmesg" command

You should see something like this :

[ 6508.972745] usb 4-1: new SuperSpeed Gen 1 USB device number 4 using xhci_hcd
[ 6508.993494] usb 4-1: LPM exit latency is zeroed, disabling LPM.
[ 6508.994309] usb 4-1: New USB device found, idVendor=f266, idProduct=9a0a, bcdDevice= 0.00
[ 6508.994313] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 6508.994316] usb 4-1: Product: SVBONY SV305PRO
[ 6508.994318] usb 4-1: Manufacturer: SVBONY

in "4-1", 4 is the bus number

- start the SV305PRO INDI driver
- sniff the usb bus with "cat <bus number>u > /tmp/sv305_pro_dump.txt" in the "/sys/kernel/debug/usb/usbmon/" directory
- trigger some frames in INDI
- stop the "cat" command with CTRL-C
- post me the "/tmp/sv305_pro_dump.txt" file back in the forum

I looked a bit forward, sadly, it seems firmware related.
I just sent a mail to Rita at SVBony with the usb dumps.

Best regards,

Thx8411
Last edit: 10 months 1 week ago by Collin.
10 months 1 week ago #68366

Please Log in or Create an account to join the conversation.

  • Posts: 78
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Dear Thx8411,

I hope to have a moment today and be able to try it. They will be images with nothing, as it is raining today but there should be no problem, right?
When I have it I will send it to you. (I hope to know how to do it)
Best,

Pep
10 months 1 week ago #68372

Please Log in or Create an account to join the conversation.

  • Posts: 236
  • Thank you received: 14

Replied by Tom on topic INDI Driver for SVBONY cameras

Hi Thx8411,

This is my dump file. Hope it helps.

No stopping frames or lost connection during test.

Tested using RPI4 4GB and directly plug into USB3.0 port

Regards,
Tom

File Attachment:

File Name: sv305_pro_dump.txt
File Size:54 KB
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
Last edit: 10 months 1 week ago by Tom.
10 months 1 week ago #68376
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.456 seconds