×

INDI Library v1.9.4 Released (17 Jan 2022)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

INDI Driver for SVBONY cameras

  • Posts: 79
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi thx8411,
Good Morning.
I didn't know how to check the version but looking at ekos (INDI-Panel) I can tell you I have versions1.1 interface 6
Now I upgrade the lib and I have 1.6.5 version. Is to say I had just had the before one.
I hope it serves.
Thanks,
Pep
Today I'll try it and tell you what happen.
10 months 2 weeks ago #68423

Please Log in or Create an account to join the conversation.

  • Posts: 79
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Thx8411,

I just upgrade the system and works perfectly well.
In VNC mode (web access) and remotely (by Ekos (PC)). The camera is connected directly to the USB3 of the RasPi4 without Power Hub.
In both cases I try to do different exposures (from 0.001s to 60s), videos, guide and works perfect. I check if on 12bits works and works too, but have to much noise (normal, of course).
Now I only need a cloudless sky and check if works guide, in internal mode, from ekos works too.
Thanks a lot Blaise.
I attach the dump files if you will check them. <em>v1C</em> is in VNC mode and <em>v2C</em> is remotely mode.

Thanks again,
Pep

File Attachment:

File Name: sv305pro_d...s.tar.gz
File Size:700 KB
Last edit: 10 months 2 weeks ago by Pep.
10 months 2 weeks ago #68438
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi !

@Pep : Glad to know the camera is working for you now.
@Pep and Tom : Thanks for your investment !

Please let me know of you have other issues.

Have a clear sky !

Thx8411
10 months 2 weeks ago #68486

Please Log in or Create an account to join the conversation.

  • Posts: 79
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi Thx8411,

Thank you. You are a master ... (we will leave the universe for other occasions ).
Thank you so much for the work you have done and the dedication you had put into it.
(By the way, only one thing: the minimum time of the camera is 0.001s but in Ekos you have to set it manually, if you put the minimum with the arrows to go up and down the value continue only accepting 0.01s. Hey! but it do the pictures of 0.001s if you put the value manualy, therefore OK)
I insist, Thank you very much,

CLEAR and GOOD SKIES.
Pep
10 months 2 weeks ago #68499

Please Log in or Create an account to join the conversation.

  • Posts: 46
  • Thank you received: 0
HI Thx8411

Have you noticed that the frames there is 1 frame lag between when you capture using PHD2? i.e. the frame being presented by the driver after nth exposure is actually what was taken during the (n-1)th exposure?

I noticed it before after optimizing my mount to remove DE backlash the impact it has on calibration data is throwing off my guiding.

Cheers
8 months 4 weeks ago #70556

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi Rashed,

Sorry for this late, late, late answer...

Are you sure you are using the last driver ?

I had this issue with the very first SDK. (CKCameraSDK). I had to systematically drop the first frame. The first versions of the new SDK (SVBCamera) mostly fixed this issue, with sometime a junk frame.
I didn't notice this issue with last SDK anymore.

I don't use PHD2, but the Ekos internal guider. It works great for me. Did you notice the same issue with the Ekos guider ?

Best regards,

Thx8411

 
Last edit: 6 months 3 weeks ago by Collin.
6 months 3 weeks ago #72989

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
Hi folks !

SVBony just released a new camera : The SV305 Pro M, an SV305 Pro with a mono sensor.
I asked SVBony to send me the last SDK,
I wish to upgrade the indi driver to support this new camera soon.

Are any of you planning to buy this camera ? I will need some beta testers ;-)

Best regards !

Thx8411
 
The following user(s) said Thank You: giorgio
6 months 3 weeks ago #72993

Please Log in or Create an account to join the conversation.

  • Posts: 123
  • Thank you received: 19
SVBony is also working on a deep sky cooled camera, the SV405C, with an IMX533 color sensor.
If this camera has the same value for money than the SV305, I think I will buy it (and support it also ;-))

Best regards !

Thx8411
6 months 3 weeks ago #72994

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Hi,I hope I am ok posting to this thread rather than creating a new one…..I have a Pi4 running ubuntu 32-bit configured with the AstroPiMaker4 script.Connected to it is a SV305 PRO.Initially it didn’t work, but I found this very thread and upgraded libsv305 to 1.6.5 from the nightly repo.So I can connect via ekos and take pictures. However, all the pictures are greyscale and pixellated - I can reproduce this in sharpcap on a windows box by selecting one of the RAW formats.  If I select RGB24 there the pictures are in colour and fine.BUT in the ekos configuration window, I can only select Raw 12 bits or Raw 8 bits for the Frame Format. Am I overlooking a setting somewhere? Thanks!
6 months 3 weeks ago #73151

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
Hi,

I hope I am ok posting to this thread rather than creating a new one…..

I have a Pi4 running ubuntu 32-bit configured with the AstroPiMaker4 script.
Connected to it is a SV305 PRO.

Initially it didn’t work, but I found this very thread and upgraded libsv305 to 1.6.5 from the nightly repo.

So I can connect via ekos and take pictures.

However, all the pictures are greyscale and pixellated - I can reproduce this in sharpcap on a windows box by selecting one of the RAW formats. If I select RGB24 there the pictures are in colour and fine.

BUT in the ekos configuration window, I can only select Raw 12 bits or Raw 8 bits for the Frame Format.

Am I overlooking a setting somewhere?

Thanks!
6 months 3 weeks ago #73152

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
OK, I've found I need to debayer the images, so not a problem with the driver or ekos etc.

Going back to learn some more.... :)
6 months 2 weeks ago #73184

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
Hello everyone, If I've read the thread correctly, this driver is for the SV305, I own an SV105 that I would like to try as a guide camera for my widefield astrophoto setup, and was wondering if this driver could also work for me. I've tried using both the INDI webcam and V4L2 drivers via ekos in kstars, but none work, as the camera is only able to take a single exposure before not responding again. I figured this thread is the right place to ask, so if anyone has any experience with this little cam I'd be helpful for any tips !!.
5 months 2 weeks ago #74169

Please Log in or Create an account to join the conversation.

Time to create page: 0.649 seconds