×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 7
  • Thank you received: 0
Update from today's effort

I tried with purging all indi and astroberry packages and then reinstalled them (apt-get, purge, autoremove and install) with the same result as previous, the sv305 driver crashed on connection.

What I tried after that was to purge everything again and compile indi (core and drivers) from source (master branches). After that I can connect to the camera, live stream works but it always crashes when I try a capture. Log attached 

File Attachment:

File Name: sv305-2022-01-05.txt
File Size:186 KB
.

So close..., anyone with any ideas on what to try next?
8 months 2 weeks ago #79092
Attachments:

Please Log in or Create an account to join the conversation.

Can you use Ekos Debugger to debug the driver? this would give a more valuable trace back.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
8 months 2 weeks ago #79106

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Hi Jasem!

I'm new to this so I don't know all the tools yet.
I built the ekos debugger according to the instructions in this post: indilib.org/forum/ekos/7245-new-tool-eko....html?start=12#75533
and I got the attached logs by running the indiserver from the tool.

I haven't done c/c++ since my school days and I don't know the the project that well yet, so I don't know what to make of the segfault, any ideas?

Thanks!
8 months 2 weeks ago #79112
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Another update,
I flashed a fresh Raspberry buster and used the AstroPI3 script to install everything. All drivers I'm using (incl sv305) worked. What was missing was the ekos part of kstars. That was solved by installing it from the ppa.
So in short I have a setup that works, but I don't know if I'll ever dare to update it...
8 months 2 weeks ago #79232

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hello,

I tested some deep sky imaging with the SV305M Pro last night.

29 x 5 min subs, gain at 110.
SV503 70/420 + 0.8 FF
H-Alpha 12nm (Moon at 92%)



Best regards.

Thx8411
 
The following user(s) said Thank You: Jasem Mutlaq
8 months 1 week ago #79419
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 25
  • Thank you received: 2
I got the indi_sv305_ccd driver compiled (and linked) on OSX !!!
It works!
The following user(s) said Thank You: Collin
8 months 1 week ago #79450

Please Log in or Create an account to join the conversation.

  • Posts: 80
  • Thank you received: 0

Replied by Pep on topic INDI Driver for SVBONY cameras

Hi folks,

I'm using the sv305-Pro on astroberry, like a server so well. But last night I'had want to record a video from EKOS (on a PC) and told me that I haven't permision for to acces to the local directory (on PC). Then I tried to do it again but this time save the video on Raspy (astroberry) directly but gave me an error that say (someting like): Video was interrupted or acces denied.
I remmeber that if I did this process by VNC connection, works and then take the video from the raspi. But now if I want to do it by  Client-PC (KStar-EKOS) to the astroberry (Server) I can't do it. 
There are someone, could give me some ideas about how to resolve this issue?
Thanks,
Pep
Last edit: 8 months 1 week ago by Pep.
8 months 1 week ago #79554

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hello PEP,

Sorry, I don't know Astroberry well. I use Stellarmate.
Did you check the processes owners ?

Best regards,

Thx8411
7 months 18 hours ago #80849

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi folks !

I received a SV905C sample from SVBony yesterday.
I already patched the driver : github.com/thx8411/indi-3rdparty
It needs some more testing, but all basic features seem OK.

Best regards,

Blaise
 
The following user(s) said Thank You: Chris
7 months 18 hours ago #80851

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
It was great to find this thread and read it bottom to top. Amazing work Collin in development and support of these SV cameras. I have the new 905C and with luck I should be able to test it tonight as a guide camera on my simple RP4 StellarMate connected Canon DSLR/Rokinon 135mm/AZ-GTi rig because the skies are on track to be amazing, on a weekend night! 

Will "sudo apt install libsv305 indi-sv305" install your driver update for the 905 or will I need do a more involved build?

 
6 months 4 weeks ago #80914

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
I think I answered my own question that "sudo apt install libsv305 indi-sv305" did find an update but I don't believe it's the one for the 905. Starting Ekos just gave a repeated driver crashed error. So I pieced together enough info in the thread to build the driver with limited command line experience. Still no joy but I think I'm very close. 

My steps so far:
sudo apt-get install git
 
sudo apt install libindi-dev
 
sudo apt install libcfitsio-dev
 
sudo apt install -y cmake
 
git clone https://github.com/thx8411/indi-3rdparty.git
 
mkdir sv305-build
 
cd /home/stellarmate/sv305-build
 
cmake ../indi-3rdparty/indi-sv305/
 
make
 
indiserver ./indi_sv305_ccd

This returns a promising: 

stellarmate@stellarmate:~/sv305-build $ indiserver ./indi_sv305_ccd
2022-02-27T15:39:30: startup: indiserver ./indi_sv305_ccd 
2022-02-27T15:39:30: Driver ./indi_sv305_ccd: Camera(s) found

The device tab in Ekos says it's a 905, but when starting the Ekos test profile using the remote server I get:

2022-02-27T16:05:46: [ERROR] Error, open camera failed. 
2022-02-27T16:05:46: [INFO] Attempting to find the SVBONY SV305 CCD... 


I feels like I'm so close!

EDIT:

I added:
stellarmate@stellarmate:~/sv305-build $ sudo make install
[100%] Built target indi_sv305_ccd
Install the project...
-- Install configuration: ""
-- Installing: /usr/local/bin/indi_sv305_ccd
-- Installing: /usr/share/indi/indi_sv305_ccd.xml

But it had no effect. When I check the General Info tab it still says Version: 1.2
Last edit: 6 months 4 weeks ago by Chris.
6 months 4 weeks ago #80918

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 0
I see I only built one half of what was needed. I didn't do the libs. I'm up and running!

EDIT: Scratch that. Everything is on fire. I'm out of my league. I can't get it to play nice with the main CanonDSLR. Repeated Ekos crashes. I'm slowly backing away until it gets put in prod. The sky is looking too good tonight to trust dev.  
Last edit: 6 months 4 weeks ago by Chris.
6 months 4 weeks ago #80919

Please Log in or Create an account to join the conversation.

Time to create page: 0.288 seconds