John Hoogerdijk replied to the topic 'QHYSDK 4.0.1' in the forum. 7 days ago

knro wrote: There is no way to "turn on cooler" within the SDK.. I guess instead of setting manual PWM to 255, I will simply ask it to decrease temperature.


Jasem,

I think there is a mis-communication on my part from a few posts ago ... I don't want to have you turn on the actual cooler, but rather enable or disable the cooler. That is, the cooler should be disabled when the camera is first connected, and at some suitable time, I want to enable it (ie: turn it on) and then at the end of the imaging run, disable it (turn it off) so that the cooler is not constantly running when it doesn't need to be running.

So, looking at the CCD tab in EKOS, the On and Off buttons really should be enable and disable. When I enter a value into the Temperature Set box, and click the Check box next to it, if the current temperature of the chip is greater than the temperature I want, enable the cooler, and if it is less, leave it disabled. Does that make sense?

I'm assuming the actual process to control the chip temperature occurs within the camera and the TEC cooling box, and all that needs to be done is enable or disable.

Apologies for the confusion.

Regards,

jmh

Read More...

John Hoogerdijk replied to the topic 'QHYSDK 4.0.1' in the forum. 7 days ago

So more testing with my QHY9 (and QHY5):

1. When I have both QHY9 and QHY5 cameras attached, I can no longer connect to the QHY9. When I (physically) disconnect the QHY5, no issues connecting to the QHY9. Also, when both are connected, qhy_test_ccd only sees the QHY5 and not the QHY9. Not sure if it should see both or just the first one it finds.

2. With regards to cooling, with the QHY5 not connected, I can turn the cooler on and off, but when I turn it on, it is at 100% power regardless of the temperature difference.

3. The current temperature is no longer updating, except when I turn the cooler off after a time, then if the temperature is lower than the target temperature, it shows the temperature increasing, until it hits the ambient temperature in the OBS.

I presume the temperature control is done in the driver and not in the camera - is this correct? I looked at the code change that was made where CONTROL_MANUALPWN is set to 255 so I would presume that if the PWM value can be set, it is set from the QHY driver to the TEC controller, I think setting the PWM value to 255 set the power output to maximum, and it doesn't change.

Any thoughts?

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

rlancaste wrote: I do believe this discussion thread is now not about the original topic at all, but is now about several different topics at the same time.


Yup. The original topic has been addressed with the fix by Jasem, so I think this one is done.

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

Blueshawk wrote: @rlancaste

"Here is how I configure PHD2 on a raspberry Pi to not need an INDI driver for a ZWO camera"

Neat! I'll have to try that with the Odroid sometime.

@knro
I just looked at Kstars INSTALL and I think it could really use an update. I've not gotten Kstars to compile either but didn't want to bug anyone about it. (re:not a programmer :P)


After getting everything built, and I took a look at the instructions again, and they are correct. My problem was PEBCAK where I was installing bits on one VM and trying to compile on another, thinking I was on the same machine... need stronger coffee before I touch the keyboard.

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

knro wrote: This was indeed a bug. I just pushed a fix to GIT. Please test and report back.


Fixed! Works well.

Thanks!

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

wvreeven wrote: I used to get the same error when the build directory is created inside the KStars source directory. If you created it along side of it the error disappears. By the way, it isn’t stated with so much words, but the install or readme or whatever it is called does suggest to not put the build inside the source directory but I had to read it several times before I realised this.


Cheers, Wouter


Worked! When I first tried this, I had a trailing '/' on the kstars source directory - removed this and it's building!

Thanks!

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

wvreeven wrote: I used to get the same error when the build directory is created inside the KStars source directory. If you created it along side of it the error disappears. By the way, it isn’t stated with so much words, but the install or readme or whatever it is called does suggest to not put the build inside the source directory but I had to read it several times before I realised this.


Cheers, Wouter


When I first encountered this error, I removed all the bits and followed the instructions verbatim in the install, and still got the same error. I confirmed that all the packages are installed. I also tried "apt-get build-dep kstars" but don't know what to put into sources.list.

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 7 days ago

Copello wrote: Have you tried first installing all required DEB packages. There exists the simple command:

sudo apt-get build-dep kstars
which installs all required packages for building kstars on your system.


All the packages are installed as per the INSTALL files. What should be in the sources.list file for kstars?

jmh

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 1 week ago

knro wrote: This was indeed a bug. I just pushed a fix to GIT. Please test and report back.


I got a cmake error when trying to build kstars:

CMake Error at icons/CMakeLists.txt:1 (ecm_install_icons):
Unknown CMake command "ecm_install_icons".


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 3.10)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "/home/jmh/Devel/kstars/build/kstars/CMakeFiles/CMakeOutput.log".

The os is ubuntu 18.04:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

cmake version is 3.10.2

Read More...

John Hoogerdijk replied to the topic 'Re:How to disable fits viewer in EKOS' in the forum. 1 week ago

TallFurryMan wrote: Don't you still need to have it in your profile if you are using the local indiserver launched by Ekos? PHD2 still need an INDI driver, doesn't it?

-Eric


Yes PHD2 needs the indi driver. I am running indi on the RPi in the observatory and Kstars and PHD2 on my desktop.

jmh

Read More...

John Hoogerdijk replied to the topic 'How to disable fits viewer in EKOS' in the forum. 1 week ago

rlancaste wrote: In the guide module I believe you can select your guide camera as qhy and disable the receipt of guide frames from that camera


That was true in earlier releases. I'm running Kstars Build: 2018-11-08T01:19:34Z and it's a bit cleaner if you use PHD2 as the external guider - no more camera to select as this is selected within PHD2. See attached picture. Somewhere though something is starting fits viewer and sending the guide frames to it.

jmh



Read More...

John Hoogerdijk replied to the topic 'How to disable fits viewer in EKOS' in the forum. 1 week ago

DerPit wrote: Config->FITS->uncheck 'Use FITS Viewer' ?


Sadly, that didn't work. Everything is unchecked, but it still gets started in the Guiding tab.

jmh

Read More...

John Hoogerdijk created a new topic ' How to disable fits viewer in EKOS' in the forum. 1 week ago

I'm running the nightly build to help test the qhy driver bits, but I'm running into a problem with fitsviewer firing up and displaying every single guide camera image, and when the imaging camera downloads an image and attempts to display in yet another fits viewer pane and when this happens it crashes kstars... which makes it hard to test things... and I can find a way to turn it off.

Even outside if testing I never use fits viewer - I use PixInsight to look at the images and PHD2 to see the guiding bits. If it doesn't exist now, can we get a button somewhere to completely disable it?

Thanks,

jmh

Read More...

John Hoogerdijk replied to the topic 'QHYSDK 4.0.1' in the forum. 1 week ago

wvreeven wrote:

fmozza wrote: I think here is best - all the QHY driver issues in one place.


I tried just now and on my camera the cooler doesn't work at all and I am sure it did before. However, I never had to actively enable it. It would always start cooling down to 0 degrees Celsius without a problem. Now when either in the INDI Control Panel or in the CCD tab I click on the "On" button for cooling it automatically switches to off again. Logs attached.


I think this seems to indicate there is a bug. This worked find with indi-1.7.2, and I think the libqhy version was 2.0.3. Something changed after that release that broke cooling.

jmh

Read More...

John Hoogerdijk replied to the topic 'Possible qhy9 cooling control bug' in the forum. 1 week ago

wvreeven wrote: I haven't checked the cooling of the chip with my QHY9 and the latest driver and will do so tonight. So far I have only checked if the filter wheel works and it does with this driver. To be continued!


Let's move this to the QHY 4.0.1 driver discussion thread.

Read More...

John Hoogerdijk replied to the topic 'QHYSDK 4.0.1' in the forum. 1 week ago

papaf76 wrote: Can anybody test this with a normal QHY8? A friend tried a few months back but couldn't stop exposures without locking up the camera. I'm curious if QHY8 (non pro or L) is supported now.


I also have an older QHY8. The driver does not support these older camera's but but there was an alternate firmware that (sort of) works and a link was posted somewhere on this forum. QHYCCD has a new website and the firmware is no longer available from there. I've attached it if you want to try. My camera is a colour camera, and the driver treats it as a mono, and the maximum exposure time is 86.4 seconds. I've been looking for ways around it, but haven't found a solution.

jmh

Read More...

John Hoogerdijk replied to the topic 'QHYSDK 4.0.1' in the forum. 1 week ago

wvreeven wrote: I answered to the other topic that you opened. Would you like to continue there since it is more dedicated to your specific observation or continue here?


Wouter


I think here is best - all the QHY driver issues in one place.

Read More...

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!