Helge replied to the topic 'Something wrong with GPSD configuration' in the forum. 17 hours 57 minutes ago

Dear Radek,

in a way, things seem improving, at least I can see the time...but still no position data...(i.e. no fix)

Attached, please find the output when entering the command as suggested, in addition what I see on gpsmon.

One thing I still wonder about: the gpsd file stored under /etc/default : what should be included? I commented out (with #) those lines that initiate to start the GPSD daemon upon boot as well as the sentence on USB hotplugging. Is that right? Maybe this has been causing the blocking of the port?

Read More...

Helge replied to the topic 'Something wrong with GPSD configuration' in the forum. yesterday

another screenshot, with more messages

Read More...

Helge replied to the topic 'Something wrong with GPSD configuration' in the forum. yesterday

this is what I am getting...

first I entered the line as suggested, and received a couple of error messages

then checked systemctl status gpsd

Read More...

Helge replied to the topic 'Something wrong with GPSD configuration' in the forum. yesterday

to be honest, I do not really understand what it means :-(

I have been trying to find the logs, and checked a couple of websites to get my head around, including looking into syslog files, but got lost.

If I run "cgps", this is what I am getting - any other ideas on what I could try?

Read More...

Helge replied to the topic 'Something wrong with GPSD configuration' in the forum. yesterday

Hi Radek,

Thanks a lot. Tried gpsctl -n, and removed -b from the options. Unfortunately, not there yet. I also set -D4 for logging, but where do I find the log files?

Best, Helge

Read More...

Helge created a new topic ' Something wrong with GPSD configuration' in the forum. yesterday

I have a UBLOX-7 USB stick and everything used to be fine. Maybe when playing around with the baud rate settings in another context, it stopped working.

I attached some screenshots:
-GPSD file
- Output when running minicom for ttyACM0 (I am getting timestamp, but no GPS coordinates)
- gpsmon
- systemctl status

- cgps shows: (to me this looks like there is something wrong):

ospf 89 OSPFIGP # Open Shortest Path{"class":"WATCH","enable":tr
ue,"json":true,"nmea":false,"raw":0,"scaled":false,"timing":false,"split24":fals

56Z","flags":1,"native":0,"bps":9600,"parity":"N","stopbits":1,"cycle":1.00}]}
{"class":"WATCH","enable":true,"json":true,"nmea":false,"raw":0,"scaled":false,"
timing":false,"split24":false,"pps":false}


I am not sure if this could be an indicator of the problem, but when for instance entering in the terminal "stty -F /dev/ttyACM0" I am getting as response that resource is busy. Maybe this is correct because the port has already been accessed by the GPSD-daemon when boot?

Read More...

Helge replied to the topic 'Update port or baud rate' in the forum. 5 days ago

Hi Paul, it works, I am really please - thank you once again!!

Attached just a picture of the TIC825 with the HC-05 module.

Read More...

Helge thanked Paul in topic Update port or baud rate 5 days ago

Helge replied to the topic 'Update port or baud rate' in the forum. 6 days ago

One more thing - tried different things to save the configuration for the port, in my case rfcomm1. Attchached the .cpp and .h file - but that did not work.

I hardly dare to ask again Paul - but in case weather conditions are again unfavorable, could you have a look? :-)

Read More...

Helge is friends with Paul

Helge replied to the topic 'Update port or baud rate' in the forum. 7 days ago

Dear Paul, it is working now! I am really impressed, thank you very much once again for your support.

First, it did not work, then checked via the ticgui the status, and the motor needed to be re-energized (there is a button at the bottom of the GUI).

I uploaded the file in its latest version.

Best, Helge

Read More...

Helge replied to the topic 'Update port or baud rate' in the forum. 1 week ago

Hm...when capturing different values for comman[0] , such as 127, 128, 129 I see in the log file the values: 127, -128, -127, for 224 I see -32.

So it looks like any values above 127 get kind of corrupted. I was trying to figure out on google what sort of logic is behind, checking ASCII tables, but could not work out. It is like Sudoku for astronomers!

Read More...

Helge replied to the topic 'Update port or baud rate' in the forum. 1 week ago

Hi Paul, I was just trying to figure out what is happening, so I added a few lines to the code at line 75 I squeezed in the following:

IDMessage(getDeviceName(), "Command 0 %d", command[0]);
IDMessage(getDeviceName(), "Command 1 %d", command[1]);
IDMessage(getDeviceName(), "Command 2 %d", command[2]);
IDMessage(getDeviceName(), "Command 3 %d", command[3]);
IDMessage(getDeviceName(), "Command 4 %d", command[4]);
IDMessage(getDeviceName(), "Command 5 %d", command[5]);

The log file is interesting and seems to confirm your doubts, see attached log file from time stamp 2019-02-10T20:52:15.932 onwards (to the end of the file). I first set steps to 100, then back to zero, then 400 and back to zero. The command[] should in hexa decimal be 0xE0, according to the User Guide ( www.pololu.com/docs/0J71/9 ). But in the log I see -32. Maybe this is the char value of "0", as the term 0xE0 starts with 0 (???).

But how to resolve, as the tty_write command requires a char variable?

Read More...

Helge replied to the topic 'Update port or baud rate' in the forum. 1 week ago

Dear Paul, really appreciated. I just downloaded and compiled without any problems. Also, the driver immediately connects, faster than before. Just the motor is not moving, and I hope I will have some time tonight to analyze. You were already hinting, that the commands could be wrong, but why do you think they could be wrong?

BTW: the way I connected the BT module to the Tic controller is one-way only, i.e. I only send signals, but do not receive back (which so far there was no need). In case the new code needs to feedback anything from the controller, please let me know.

Thanks once again for dedicating your time to this!!

Helge

Read More...

Thibault is friends with Helge