I just updated my Raspberry Pi to the latest KSARS using the AstroPi3 script with the new StellarSolver. During testing with the simulators I kept getting failed to solve errors. I eventually realised that the reason for the failure was I had only downloaded the relevant index files for my 80mm x 500mm FL imaging setup, the default simulator scope setup at 120mm x 900mm FL would not solve as the relevant index files were not present. On the solver it would flash a warning that the index files were missing. Would it be possible to add the warning message to StellarSolver? It may help out newcomers to resolve any setup issues.

I must say once I had changed the simulator telescope settings to match those of my imaging setup, it worked flawlessly on both GSC and uploaded images, very nice work indeed.

Many Thanks