what you write is exactly what the docs are saying, but this doesn’t work.

Perfectly right, the documentation is wrong. It needs to be
sudo a2enconf weatherradio
I corrected it in the current version.

Read More...

Hm, strange. What happens if you place a symbolic link into /etc/apache2/conf-enabled and restart apache:

cd /etc/apache2/conf-enabled/
ln -s ../conf-available/weatherradio.conf .
sudo systemctl restart apache2.service


Read More...

Now it is showing up but no data and with "DHT init: false". Pin is right, typ selection too. I have a model with a resistor on the little board. ?

Could you post the section of your firmware that recognizes the DHT sensor? In the weather radio header file it looks like this:
#include "DHT.h"
DHT dht(DHTPIN, DHTTYPE);

DHTPIN and DHTTYPE are definitions from config.h

Another issue I do have with the add-on and the module activation in apache2. sudo a2enmod weatherradio fails all the time.
"ERROR: Module weatherradio does not exist!" How does a mod looks like? I do have weatherradio.conf in the right place.

Hm, seems like it is not in the right place. Did you really place it under /etc/apache2/conf-available ?

Wolfgang

Read More...

Hi Gunter,
please take a look into the Firmware Configuration section of the Readme .

I assume you are familiar with the Arduino IDE. When you open the weatherradio.ino firmware, there are several header files included. All configurations should be placed in config.h:

  1. Enable DHT sensor by removing the comments from
    //#define USE_DHT_SENSOR
  2. Set the appropriate digital PIN of your Arduino where the DHT sensor is attached to and select the DHT type:
    // DHT sensor family
    #define DHTPIN 3          // Digital pin connected to the DHT sensor
    //#define DHTTYPE DHT11   // DHT 11               - Uncomment whatever type you're using!
    #define DHTTYPE DHT22     // DHT 22  (AM2302), AM2321 - Uncomment whatever type you're using!


Read More...

Gilles, you are absolutely right, that's the reason why serial devices do not connect!

I started a new branch that should fix the problem: weatherradio V1.9

Wolfgang

Read More...

Wolfgang Reissenberger replied to the topic 'INDI with APACHE' in the forum. 2 days ago

There is indeed an option to integrate the INDI webmanager into apache.

First install the WSGI module for apache:

sudo apt install libapache2-mod-wsgi

Next copy indiweb.conf to /etc/apache2/sites-available and edit the paths inside the configuration file.

Please check also that the user configured there is the user that should run indiserver.

Now restart apache:
sudo systemctl restart apache2.service

HTH
Wolfgang

Read More...

The GEO_... stuff should be irrelevant for connecting. Nevertheless please set at least GEO_COORD_ELEV to the correct value of your location, since this value is used to calculate sea level air pressure.

Are you 100% sure that the serial device is the same as EKOS sets? Sometimes EKOS uses autodetect and changes the value.

The rest of the configuration looks reasonable...

Version 1.7 is OK, the only changes in 1.8 is that it supports multiple instances of Weather Radio. And the Arduino version does not matter.

For further analysis, try the python debugger pdb:

pdb wr_rrd_update.py

And maybe another check: are you starting wr_rrd_update.py from the same directory where wr_config.py is located?

Wolfgang

Read More...

OK, that's not that suprising. In the second log you see the INDI communication in case that a client connects to the INDI server after the INDI server has connected successfully to the Weather Radio device.

Client 0 in the second log comes from EKOS and client 5 is your other RPi connecting with the python script.

The core question: why does the python script does cannot connect successfully. Could you please take a look into the configuration wr_config.py? Maybe the device parameters INDIDEVICEMODE and NDIDEVICEPORT are set to different values than you use via EKOS.

HTH
Wolfgang

Read More...

Hm, strange. Maybe it makes sense if you increase the verbosity on the INDI server and see whether the CONNECT command is received.

If this does not help, I would recommend to step through with the python debugger pdb.

And by the way: I've grabbed a RG11 from eBay and I will try to implement this in the next weeks (or months :-/ )

Read More...

P.S. I may have a question for you on the Avalon Stargo driver regarding remote azimuth-altitude control (M-Zero OBS)


Sure, if there is some function missing in the driver, I can try to add it.

Wolfgang

Read More...

G_Gagnon wrote: Wolfgang, the home PC does not run an indiserver, it runs KStars and Ekos and connects to the indiserver running on the observatory and the one running on the mount (via driver@obsy and driver@mount instances). No slew problem whatsoever.


Gilles, sorry, but if you connect to both of the remote INDI servers with the <driver>@<host> manner, you are running another INDI server in the local mode on your PC - which is not 100% necessary. But anyway, that should not matter.

For a drilldown, I would recommend to connect KStars in the remote mode directly to your INDI server controlling the mount and check, if in this setup guiding works.

Wolfgang

Read More...