Gerry Rozema replied to the topic 'NexDome' in the forum. 5 years ago

diegocolonnello wrote: Last night i updated my Leonardo and installed the NEXDOME driver on INDI and also the NEW version on Windows...

First, when testing INDI, and after having issues with my mount, i decided to test the NEXDOME implementation, it connects to the board, i start homing the dome, the sensor stops the dome on the right place but somehow the board is not sending the message to the driver saying AT HOME!!! .


After homing the dome, if you move it by one degree using the indi control panel, does it then show 'at home' ? If that gets the dome showing 'at home', then you should be able to proceed from there. FYI, once the dome has been calibrated, doesn't matter if it was done from indi, or something else, that calibration is stored in the controller and it wont need to be re-calibrated. The 'AtHome' return is only required for start of calibration with the V1.10 dome firmware. Once it's calibrated, handling of the home sensor is internal to the controller, and it syncs itself properly when the magnet passes the sensor. There is no need to be 'athome' for any of the operattions after that.


There is another firmware update _almost_ ready that changes handling of the magnet detection on the home sensor somewhat in a way that we no longer need to start the calibration from the 'at home' position, but I cant finish testing it today because a storm has rolled in and the dome has wind locks on today

Read More...