Mikey replied to the topic 'Astroberry Server' in the forum. 4 months ago

Greetings and salutations, gang. Quick question because my forehead hurts from banging it against the wall trying to make this work...

I am attempting to connect my Raspberry Pi 3 to a Celestron Evolution 8 via astroberry. This new model does not have a working USB interface, and the comments I've seen say only WiFi is supported at this point anyway. So, I've tried two methods.

1. Edit wpa_supplicant.conf to connect to "Celestron-FE" (the SSID that the Celestron sets up) and then attempt a connection via Ekos and ip=1.2.3.4 (the default IP that Celestron's SkyQLink app recommends and which the indi-nexstarevo server creates) and port=2000 (again, default). This never connects. It's worth noting that wlan0 is assigned an IP of 1.2.3.5 by default when connecting to "Celestron-FE", not 1.2.3.4. I've changed it manually to 1.2.3.4 with no success.
2. Put the Celestron in "access mode" and have it connect to the astroberry SSID. I do this by going into the SkyQLink app on Windows and writing the following settings to the Celestron:
-- ssid = astroberry
-- password = astroberry
-- ip = 192.168.10.10 (arbitrary but static)
-- gateway = 192.168.10.255
-- netmask = 255.255.255.0
I can ping the Celestron from astroberry when done this way, so it appears to connect. However, when I go into Ekos and attempt a connection via ip=192.168.10.10 and port=2000, I still get no connection (a timeout occurs).

Has anyone got this to work? I've tried other port numbers. I've tried disabling the firewall entirely. I've rebooted all systems in order. I've ensured that the hand controller is "aligned" via a fake alignment on the sun (inside). I'm out of ideas here.

Read More...