Jasem Mutlaq thanked Juergan in topic Clear Skies 7 months ago

Juergan replied to the topic 'Trying to get a Canon 70D to work' in the forum. 7 months ago

Be nice to see what the answer is to this, I had exactly the same problem with a Nikon D3200 DSLR.

Using the bleeding edge drivers, Ubuntu Mate, the camera would only take 1s exposures. Anything above, the camera would hang and timeout.

I tried:
Set the camera to bulb mode, with mirror lock off
In Indi, turn 'Force Bulb' mode off.
Entered Sensor resolution, Pixel Pitch settings.

After this, in EKOS setting an exposure of 1s with multiple exposures, the camera ticks away quite happily. above 1s, it hangs on the first exposure and doesn't recover.

Be useful to know if you try the settings above whether you get a different result to me?

In the end, I gave up and switched to using a programmable remote which works fine, but I'd still like to get things working in EKOS if possible...

Read More...

Juergan created a new topic ' Clear Skies' in the forum. 7 months ago

Clear Skies last night, here's a shot I took of the Orion Nebula on an unmodded Nikon D3200 DSLR.

ISO 200 / Exp 17s
Stacked using Siril

[url=<blockquote class="imgur-embed-pub" lang="en" data-id="a/5KLlieA"><a href="//imgur.com/5KLlieA"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>]ISO 200 / Exp 17s[/url]

Some more post processing to finish off, but already starting to look quite good!

Read More...

Juergan created a new topic ' QHY 5L II CCD + Raspberry Pi 2' in the forum. 7 months ago

I've read lots of people talking about the QHY 5L II Guide Camera occasionally giving 'Timeout During Exposure', and have noticed the same myself. Looking into it, I've come across some useful information that I thought I'd share (who knows, it may help someone!).

Firstly, to look at the Raspberry PI 2, USB ports and their capability. Each of the 4 x USB ports are USB 2, and have a maximum data transfer rate of 480Mbps. The USB Speed and Data rates are manageable via the INDI Control panel, and the Data Rate is set at a default of 30 / 255.

The Raspberry Pi (using the default power supply) takes an Input voltage of +5V with 2.5A. However, each USB ports output power is rate limited using a polyfuse, meaning the output power of each USB port is 4.5V with 1.1Ma (See Here: Raspberry Pi2 USB Power )

Taking this a step further, and looking at the QHY 5L II FAQ's, I came across the following interesting comment from the manufacture:
How to avoid Camera Hangs

3.2 If the USB port's voltage not enough? Some computer's USB port +5V is not enough. It may cause the camera always hangs. In this condition you can use a powered USB3.0 HUB to connect camera and get the good +5V power for camera.
QHY 5L II Camera FAQ's

Putting the two together, it appears to me that connecting the QHY Camera directly to a USB port on the RPi2 means that the camera is slightly under power (-0.5V) and according the the manufacturer this can lead to the camera freezing or dropping frames. The recommendation to solve this is to ensure that the camera is connected to a USB port (such as a powered USB 3.0 Hub) that is capable of providing at least +5V power.

Again, this can be taken step further and where the QHY camera is connected directly to the RPi2 USB port along with other devices (Capture Camera, Focusser, Filter Wheel or Mount (EQMod etc) the additional power drawn by other devices may negatively impact the power being supplied the QHY camera. Thus exacerbating the problem even further!

Read More...

Juergan replied to the topic 'Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

Since I got no reply here, I simply bypassed the problem.

I already have a Viltrox Remote which lets me take exposures completely hands free without any of the hassle.
www.viltrox.com/en/index.php?m=index&a=show&cid=138&id=128

Read More...

Juergan replied to the topic 'Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

Solved!

Read More...

Juergan replied to the topic 'How to use 2 different DSLR cameras' in the forum. 7 months ago

Since you already mentioned you had been in the sqlite db, can you not manually add an entry for the second camera (using the correct sensor resolution and pixel size)?

Read More...

Juergan replied to the topic 'Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

:Bump:

Is there a way to tell Ekos to use the pre-programmed shutter release times from Nikon so that I can take exposures longer than 1 second?

Read More...

Juergan replied to the topic 'Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

I may have 'a little' progress with this.

I've checked the gphoto2 version in the Linux Mint repo
gphoto2/bionic,now 2.5.15-2 amd64 [installed]

I know it's not the latest version available, but to look at it.
I've installed Entangle to test the Nikon tethering, it works fine with entangle and the shutter will remotely release and take a frame.

Back into Kstars and, in the INDI Control Panel (Main Tab) it lists the settings for manual release including exposure times. For instance 0.0002s, 0.0003s, 0.0004s etc. It also has a setting to 'Force Bulb' which I've turned off.

In EKOS, I've selected an exposure time of 0.0002s and added 10 exposures with a delay of 1 second. Eureka!! It works.

That said, it only works with exposures below 1 second. Anything above 1 second fails with the above error and so, it seems that, when Ekos appends an extra couple of 0's to the exposure time the camera isn't able to process the shutter release.

What I mean by appending extra 0's is, the INDI shows 1.0000 whereas EKOS shows 1.000000

Read More...

Juergan replied to the topic 'Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

Hi Jasem,

Thanks for the quick reply.
SD is empty (formatted in the camera body)
Camera is in Manual mode and set to Bulb.
The only lock I can find in the camera settings is 'Slot Empty Release Lock' I've tried with both Locked and OK - both fail with same results.

gphoto.txt attached.

Read More...

Juergan created a new topic ' Nikon D3200 DSLR + Ekos Nightly' in the forum. 7 months ago

I'm sure this has been raised before, but can't seem to find a way forward with it. So, here we go ...

I'm running Kstars nightly builds on Linux Mint, and have tried both GPhoto2 as well as Indi to control my Nikon D3200. I'm running the camera prime as my main camera, with a QHY 5 II guide scope. lsusb sees the Nikon body when I connect it via USB:

lsusb
Bus 002 Device 020: ID 04b0:042c Nikon Corp.

dmesg -w
[13018.896949] usb 2-1: USB disconnect, device number 19
[13036.136798] usb 2-1: new high-speed USB device number 20 using xhci_hcd
[13036.285555] usb 2-1: New USB device found, idVendor=04b0, idProduct=042c
[13036.285561] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13036.285565] usb 2-1: Product: NIKON DSC D3200
[13036.285569] usb 2-1: Manufacturer: NIKON
[13036.285573] usb 2-1: SerialNumber: 000006245043

Also, I have a rule set up to prevent mounting the camera as a USB drive:
/lib/udev/rules.d
85-disable-dslr-automout.rules

cat /lib/udev/rules.d/85-disable-dslr-automount.rules shows:
# Nikon
SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b0", ENV{UDISKS_AUTO}="0"

So, everything seems fine, and INDI can connect to the camera, however trying to take a test 2 second exposure, I get the following error:

INDI Ctrl Panel
2019-03-14T20:13:52: [INFO] Starting 2 seconds exposure.
2019-03-14T20:13:52: [ERROR] Exposure failed to save image... Unspecified error
2019-03-14T20:13:39: [INFO] Starting 2 seconds exposure.

I've enabled CCD debugging, and see this in the logs:
Indi CCD Logs
[2019-03-14T20:16:12.174 GMT INFO ][ org.kde.kstars.ekos.capture] - "Job requires 2.000-second images, has 0/3 frames captured and will be processed."
[2019-03-14T20:16:12.178 GMT INFO ][ org.kde.kstars.ekos.capture] - "Capturing 2.000-second image..."
[2019-03-14T20:16:12.223 GMT INFO ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[INFO] Starting 2 seconds exposure. "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Starting exposure (exptime: 2 secs, mirror lock: 0) "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Mutex locked "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting radio/menu widget iso: 3 (800) "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting new configuration OK. "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting radio/menu widget imagequality: 3 (NEF (Raw)) "
[2019-03-14T20:16:12.223 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting new configuration OK. "
[2019-03-14T20:16:12.224 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Using internal bulb widget:bulb "
[2019-03-14T20:16:12.224 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting toggle widget bulb: 1 "
[2019-03-14T20:16:12.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Failed to set new configuration value (GP result: -1) "
[2019-03-14T20:16:12.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Exposure started. "
[2019-03-14T20:16:12.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Time left: 1999 ms "
[2019-03-14T20:16:14.127 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Reading exposure... "
[2019-03-14T20:16:14.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Time left: -1 ms "
[2019-03-14T20:16:14.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Closing internal shutter. "
[2019-03-14T20:16:14.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Using widget:bulb "
[2019-03-14T20:16:14.226 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Setting toggle widget bulb: 0 "
[2019-03-14T20:16:14.227 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Failed to set new configuration value (GP result: -6) "
[2019-03-14T20:16:14.227 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Exposure complete. "
[2019-03-14T20:16:15.228 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #1, retrying... "
[2019-03-14T20:16:16.229 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #2, retrying... "
[2019-03-14T20:16:17.231 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #3, retrying... "
[2019-03-14T20:16:18.232 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #4, retrying... "
[2019-03-14T20:16:19.234 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #5, retrying... "
[2019-03-14T20:16:20.234 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #6, retrying... "
[2019-03-14T20:16:21.236 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #7, retrying... "
[2019-03-14T20:16:22.237 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #8, retrying... "
[2019-03-14T20:16:23.237 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #9, retrying... "
[2019-03-14T20:16:24.238 GMT DEBG ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[DEBUG] Event timed out #10, retrying... "
[2019-03-14T20:16:24.241 GMT INFO ][ org.kde.kstars.indi] - Nikon DSLR DSC D3200 : "[ERROR] Exposure failed to save image... Unspecified error "
[2019-03-14T20:16:24.242 GMT INFO ][ org.kde.kstars.ekos.capture] - "Capture failed. Check INDI Control Panel for details."

Does anyone have an idea how I can solve this?

Read More...

It takes the right mixture of elements to make a potato, sunshine,water, soil, nutrients etc.
With patience, the right attitude and training, one...
Show more