Update: I switched from running on the RPi to running remotely on a Mac using the Pi as a server only. The Scheduler is performing as expected, with the alignment functioning image capture working fine.

This makes me wonder if I have a corrupted install or permissions issue on the RPi.

Read More...

I am having a new issue I have not seen before. When I use the individual modules everything works fine. I can track, focus, align, guide, and capture images. But when I do it through the scheduler it is tracing and focusing, but when it gets to the alignment step it does not initiate the capture. It goes straight to trying to solve the image (that does not exist). If I stop the scheduler and then go into the alignment module I can start it and it works without issue. 

Previously it had worked fine. I haven’t used the system in about a month, and setup the same way and have this issue. I’m using a Skywatcher EQ6r-Pro mount with EQMod cable, I am wondering if there is something out of sync with the mount and EKOS. 

I turned logging on for the alignment and scheduler modules but for some reason it is not saving a file. I suspect it is a permissions issue on the Raspberry Pi. 

Read More...

I’m using an EQDirect cable, but mine has always been plugged directly into the RPi. My camera s plugged into the hub, and the focuser into the camera. The focuser is my only other serial device.

Read More...

Thank you Jasem! That worked. I looked at the cpuinfo file, but it was empty. I may be looking in the wrong location.

Read More...

It’s interesting to me that we are having the problem, but it is not more widespread. Is your RPi4 an early version? Mine was purchased soon after they were available. I am wondering if there are some differences.

Read More...

@dmsummers - thank you for the suggestion. I gave it a try, unfortunately I had the same result.

My troubleshooting today consisted of going back to a fresh load, adding components one by one to the confit and starting it up. I got everything working. Then I updated again, and could no longer see the cameras. I also noticed the filter wheel connected to the camera did was not found, but the focuser was.

I went back into the updater, but when I returned to the desktop KStars was missing. I reflashed again, only this time I could not get the devices to all work. I thought maybe it was the card. I grabbed another card and went through the same steps. Everything connected, so I installed the update. Right after installation Iran KStars, befor rebooting. I was able to start all the devices. Then I did a reboot, and could not get the cameras or filter wheel to work again.

The last thing I did was to take the RPi4 out of the equation. I installed the latest KStars on my MacBook and connected directly to it. All devices came up as expected and could be controlled.

At this point there are a lot of odd things going on, and plenty of people are running fine. I do not think my setup is that unusual, ASI cameras (2), ASI EFW, focuser, and Skywatcher EQ6r Mount. Now I am wondering If it is the RPi 4 itself. It is one of the early models, and gets dragged around a lot. I’ve ordered a new one, a 4GB version (my current one is 2GB). It should be here in a couple days and I will give it another shot.

Read More...

I’m having an issue where my ASI cameras no longer start after the latest update.

I’ve been running fine for a while. I am running an RPi4 with StellarMate OS. Mount is connected to RPi USB2, USB hub connected to other Rpi USB 2. Cameras (ASI1600mm-pro and ASI120mm-s) connected to hub. The ASI1600mm has an ASI EFW and an Astromechanics Canon lens focuser attached.

To get the system working I’ve had to Run the port mapping assistant for the mount and focuser, with physical port mapping active. Once I did that I have been successfully running since April. I’ve been applying updates as they are available.

Yesterday I applied the latest update. When I started EKOS and started the INDI server I got the pop up about No ZWO camera, Power On. The lens focuser attached to the ASI1600 did start up and was controllable. I tried different ports, I re-did port mapping, but could not get it to go. Today I loaded the SD scared with the StellarMate OS 1.5.2, resetting everything. I was successfully able to map the devices and control the setup. I ran the updater, 242 updates. When done I could no longer access the cameras, same as previously.

I spent a while playing with ports. I was able to start the cameras by connecting them directly to theUSB3 ports on the RPi4, but when I did that the mount would not connect. I also tried different cables with no success.

I’m open to any ideas. I still suspect it has something to do with port mapping, but for some reason the update changes something that I am missing.

One other thing - when the cameras do not start, the camera tabs are not visible in the INDI panel, but the lens focuser is.

Read More...

Ryan replied to the topic 'Canon 600D T3i "Failed to expose" error' in the forum. 2 years ago

I’m glad you got it working. It can be finicky, but once it is going it is worth it.

On the older version I never did get it to save those settings. I needed to go in each session and make sure they were set appropriately.

Read More...

Ryan replied to the topic 'Canon 600D T3i "Failed to expose" error' in the forum. 2 years ago

Last year I had similar issues with a Canon 1Dx. I systematically tried changing settings, and my final settings are below. This was an earlier version of SM, but it is worth a try. Note that for the capture target I had SD card, the had Delete SD image checked. I still had the imaging sequence set to save to StellarMate, so no images were actually lost.

Main Control:
Mirror Lockup = 0 (It I set the mirror lockup on it would fail, and I would need to reboot the system and restart KStars on the Mac)

Options:
Force Bulb = OFF (Camera was set to Bulb mode, if I used Force Bulb it would fail)

Image Settings:
Capture Format = RAW
Transfer Format - Native
Capture Target = SD Card (I think this one was the key in the Image Settings tab)
SD Image = Delete

Read More...

Ryan replied to the topic 'Ekos Scheduler Skipping exposures' in the forum. 2 years ago

If you have “Remember Job Progress” enabled, try turning it off. I’ve had similar issues when it thought the job had already been ran.

Read More...

Thank you! It was a minor item, I just worked it into my workflow. But it will be nice to have it addressed for scheduler purposes.

Read More...

I've got the same thing on my NEQ6R. I just uncheck the disable tracking on the Horizon tab. That particular setting has never saved for me, its one I change each time I connect to the devices.

Read More...