Do you have python-dev installed? If not, do

sudo apt install python-dev

and try again.

Read More...