Nick Birkett created a new topic ' 3.6.2beta multiple issues' in the forum. 2 months ago

We are presently subject to freezing cold and high pressure so I have been using kstars for several nights after a long break.
Server: pi4 ubuntu 20.04 arm64 (focal)
Client x64 Linux mint 21 (ubunto 22 jammy)
Mount: HEQ5 EqMod.
Cameras: Main QHY294PROM , Guide QHY5III178M.
Filter: Manual.
Focuser: myFocuserPro2
Internal guider (2 second frames)

Issues encountered.
1. After polar alignment using guide train, unable to swap back to imaging train in alignment tab without disconnecting EKOS and reconnecting.
2. Astrometry alignment shows star trailing and fails when exposure > 5s (it failed most times using 8- 10 seconds with 3nm Ha filter). I tried various timeouts.
3. Focus module. Repeated error of HFR = -1 and no stars (I can see them !!). Gave up and used Bhatinov mask.
4. Guiding graphs in Setup/summary window sometimes bear no relation to those in Guide window (crazy high frequency sawtooth waves). Maybe cosmetic issue.
5. Fails to start alignment after meridian flip when sequence has already finished. Sometimes works but not reliable: I check in night and add another sequence/filter if I wake up. Last night it went crazy and started Calibrating instead of Capturing after I re-aligned it.
6. Guiding frames seem to stop while downloading image from main camera. Guide graphs then jump and restart.
I think that's enough for now ! Hopefully I can get a nights sleep as weather changing back to normal wind, rain and snow.
Nick

Read More...

Sorry you cant use a pi cam with ubuntu either. My error.
Blame raspberry pi makers for this.

Read More...

yes that makes sense. I knew that Pi OS dropped the proprietry camera drivers when it went from buster to bullseye.
This is why you have to install the old buster version for allsky software to work, and also why I was able to compile the indi_rpicam driver
on my allsky buster pi.

But you can install kstars-bleeding on pi 4 (all versions).
You need to download and burn an ubuntu desktop arm images (32 or 64 bit) and then follow the instructions
ubuntu.com/download/raspberry-pi
indilib.org/get-indi/download-ubuntu.html

This is how I use kstars on my pi4's .

Read More...

Yes it will do.
The library versions are different on buster vs bullseye so it wont work - that's why I suggested you to check if they were compatible (ie buster +armv7l) before installing.
Unfortunately I don't have the time to install bullseye or a spare pi4 to compile again (My skycam is sealed into a weatherproof box).
You can try getting a message Jasem to ask if rpicam driver can be added to stelaarmate.

Read More...

That's odd. If you can login (ssh) to your stellarmate. indi_rpicam should be located in the directory /usr/bin
pi@skycam:~ $ ls -al /usr/bin/indi_rpicam
-rwxr-xr-x 1 root root 943740 Dec 13 14:47 /usr/bin/indi_rpicam

If there is nothing there then maybe stellarmate doesn't have it.
I attach a zip file with the diver I compiled.

First check what stellarmate os is because I have no idea. Login to stelllarmate and use cat and arch as follows:
pi@skycam:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"

pi@skycam:~ $ arch
armv7l

If it says something similar (buster and armv7l) then you are probably ok.

You need to copy the zip file to stellarmate (scp from linux or (putty) pscp from windows)
Linux:
scp indi_rpicam.zip This email address is being protected from spambots. You need JavaScript enabled to view it.: indi_rpicam.zip
Windows
pscp indi_rpicam.zip This email address is being protected from spambots. You need JavaScript enabled to view it.: indi_rpicam.zip
Or failing that take the sd card out and copy the file over and re-insert it (remembering where you copied it to)

On stellarmate you need to be in the / directory

cd /
sudo unzip [path to where file is located]/indi_rpicam.zip

This should install it in /usr/bin.
Of course this may not work either since my version of pi os may differ . I dont have stellarmate so sorry.

Read More...

Hi Marc. I managed to compile the latest driver )version 1.9.9 and that seems better (astroberry tends to lag).
If this is the latest version in Stellarmate then it might work using the manual stratup like I described.
If you can login to stellarmate rpi box and type:

apt list | grep libindi-data

It will say the version eg
libindi-data/jammy,jammy,now 1.9.9

Nick

Read More...

Some sort of bug in the starting procedure, I couldnt get it to start automatically from EKOS but it does seem to work.

I managed to start indiserver manually on the allsky box and took a 1s exposure using the telescope simulator with indi-rpicam

On pi server:
indiserver -l -v -p 7624 -m 300 -r 0 indi_rpicam indi_simulator_telescope

Change the driver list to suit your setup. Eg with skywatcher eqmod and zwo camera it would be:
indiserver -l -v -p 7624 -m 300 -r 0 indi_rpicam indi_asi_ccd indi_eqmod_telescope

That's as far as I can get.
I wouldn't hold out your hope too much as the driver doesn't seem very stable and kept crashing. Not suitable fot 1000's of guiding shots unless it improves.

Read More...

What is the driver for the rpi camera ?
/usr/bin/indi_???_ccd ?
I have astroberry on the allsky cam box but cant locate a driver that loads.

I get this with RPi cam:

Failed to start profile on remote INDI Web Manager.

Read More...

I don't think the Rpi HQ camera is sensitive enough to be a guide camera.
A guide camera needs 1-4 second exposures which is probably too short to get any useful images.
The rpi camera would work as a main camera via long enough exposures (1-5 mins say). Not sure about your issue with the driver but I suspect you may have difficulties even if you had it working.
A better low cost option would be the ASI120 mini mono camera ( at about 3x price of pi HQ)/
I use an RPI HQ camera as an allsky camera
(see : github.com/thomasjacquin/allsky )
to monitor the sky and cloud during a session.
The pi camera with this setup usually runs at 60sec exposures by default which is enough to see stars and clouds.
You might consider redeploying your camera like that if you can't get it working with your current setup. Good luck.
Nick

Read More...

I am using a fixed manual narrow filter for my Primary scope, so I am using the guide scope for polar alignment.
When I swap the trains back to align the target in the main scope I find it sometimes doesn't update in the Align window but throws an error.
If I play around with the train dropdown boxes sometime it fixes it, other times I have to restart everything.
OS: Ubuntu 22 x64 server and arm64 client.
Attaching some images. In this example my main scope is 200mm@F4 and the guide scope is 30mm@F4.
Anyone else noticed this ?


Swapping in the sequence window works fine - I can take images with both cameras, but fails in align.
Nick

Read More...

I updated to 3.6.2 beta and it seems to be working now.
Maybe it was an issue with me not properly understanding how optical trains are used ?
Still not sure why it worked in local mode but not remote.
Anyhow issue resolved and case closed.
I am putting this here in case anyone else finds this post.

Read More...

Nick Birkett replied to the topic 'apt error 3.6.2 beta ?' in the forum. 3 months ago

I'm using EQmod with QHY cameras and 3.6.2 beta seems to be working ok.
Check your server and client on the same version. If not then:

In client drop down box in kstars->help-> About kstars (3.6.2 beta)

In server : apt list --installed | grep kstars-bleeding
kstars-bleeding/focal,now 6:3.6.2+202211160926~ubuntu20.04.1 amd64 [installed]

Read More...

Nick Birkett replied to the topic 'apt error 3.6.2 beta ?' in the forum. 3 months ago

I believe this was intentional. I just read a post from Jasem to say that 3.6.2 is in final check before release and beta version was uploaded to stable repo. See reply #88192:

"Can you check in KStars 3.6.2 Beta? I pushed this now to the INDI Stable channel since we are in testing period now for 2 weeks before final release." Jasem Mutlaq

Read More...