Craig thanked Ralf in topic iOptron GEM45 5 days ago

Hello Indi community,

is there any possibility to get the latest indi lib and drivers for Ubuntu 32-bit?
I did the installation as described in the...
Show more

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Hi supporters,

It works now!
As already mentioned, the rootcause for my problem was, that the existing Indi Server and drivers SW for Linux 32 bit is rather old.
So I downloaded the source code of the indi core lib from Git to my Computer and compiled and installed it based on the in instructions given in the intall file.
And what shall I say: The mount now perfectly works with the IEQ45pro driver @ 115200 baud.
PS There is no driver anymore for the GEM45 selectable

Thanks to all of you who supported me in this dark hours of life :-)

Best regards
Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Okay, then I think the root cause is found !
Is there any possibility to get the newest stable version compiled for 32 bit? Can I do that on my Computer?
To be honest, I never compiled a package on my own from the source code and installed it.
I would be very happy to get a how-to if even possible to do it.

Thank you again for your great support
Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Sorry I will take some rest now. Its rather late in Germany already.
thanks so much for now for your great support

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Would it may be possible that the newer versions are not available as 32-Bit version??? I have to use the Linux Mint 32-Bit on this old computer

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Sorry, now I have another problem: I can not get the nightly version

When I do:
sudo apt-add-repository ppa:mutlaqja/indinightly
sudo apt-get update
sudo apt-get install indi-full kstars-bleeding gsc

Then I get as result:
E: Paket indi-full kann nicht gefunden werden.
E: Paket kstars-bleeding kann nicht gefunden werden.
E: Paket gsc kann nicht gefunden werden.

==> Sorry for the German: That means all 3 packages can not be found.

Any idea why?

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

yes, I suspect as well that my problem is caused by an old library version.
I try to install the nightly build and test again.
I will come back to you

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

I created another log file with the iOptronV3 driver, but this time including the debug "verbose scope" option.
Here you can see the command ":GEP#" which is causing repetitive timeout errors at the end. This command is not described in the communication specification you linked in your answer.

INFO 718.730052 sec : Session log file /home/ralf/.indi/logs/2020-06-11/indi_ioptronv3_telescope/indi_ioptronv3_telescope_21:29:59.log
DEBUG 734.337720 sec : Toggle Debug Level -- Scope Verbose
DEBUG 735.273913 sec : Toggle Logging Level -- Scope Verbose
DEBUG 742.177754 sec : Connecting to /dev/ttyUSB0
DEBUG 742.185135 sec : Port FD 4
DEBUG 742.185214 sec : Connection successful, attempting handshake...
DEBUG 742.185285 sec : Initializing IOptron using :MountInfo# CMD...
DEBUG 742.185378 sec : CMD <:MountInfo#>
DEBUG 742.214974 sec : RES <0043>
INFO 742.215092 sec : iOptron v3 is online.
DEBUG 742.240762 sec : Configuration successfully saved for DEVICE_PORT.
DEBUG 742.243339 sec : Configuration successfully saved for DEVICE_BAUD_RATE.
DEBUG 742.249315 sec : Configuration successfully saved for CONNECTION_MODE.
DEBUG 742.255390 sec : Getting firmware data...
DEBUG 742.255436 sec : CMD <:MountInfo#>
DEBUG 742.278902 sec : RES <0043>
DEBUG 742.279073 sec : CMD <:FW1#>
DEBUG 742.310884 sec : RES <191018200113>
DEBUG 742.311006 sec : CMD <:FW2#>
DEBUG 742.342835 sec : RES <190722190722>
DEBUG 742.342979 sec : Getting guiding rate...
DEBUG 742.343004 sec : CMD <:AG#>
DEBUG 742.374791 sec : RES <5050>
DEBUG 742.374921 sec : CMD <:GUT#>
ERROR 747.376227 sec : Read Command Error: Timeout error
DEBUG 747.377197 sec : CMD <:GLS#>
DEBUG 747.402184 sec : RES <+032670500252100521>
INFO 747.402332 sec : Mount Location: Lat -82:59:50 - Long 9:04:30
DEBUG 747.403542 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
INFO 747.435104 sec : Mount is unparked.
DEBUG 747.435425 sec : InitPark Axis1 0.00 Axis2 0.00
DEBUG 747.435467 sec : Setting Default Park Axis1 to 14.88
DEBUG 747.435494 sec : Setting Default Park Axis2 to -90.00
DEBUG 747.435539 sec : CMD <:GLS#>
DEBUG 747.464960 sec : RES <+032670500252100521>
SCOPE 747.465123 sec : CMD <:GEP#>
ERROR 752.469419 sec : Read Command Error: Timeout error
DEBUG 752.470465 sec : CMD <:SUT0645183741000#>
ERROR 757.471040 sec : Read Command Error: Timeout error
DEBUG 757.471716 sec : CMD <:SG+120#>
DEBUG 757.484954 sec : RES <1>
DEBUG 757.485153 sec : CMD <:SLO+03330000#>
DEBUG 757.516935 sec : RES <1>
DEBUG 757.517055 sec : CMD <:SLA+17567892#>
DEBUG 757.548930 sec : RES <1>
INFO 757.549049 sec : Site location updated to Lat 48:47:59 - Long 9:15:00
DEBUG 757.553124 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
DEBUG 757.555690 sec : CMD <:GLS#>
DEBUG 757.581053 sec : RES <+032670500252100511>
SCOPE 757.581231 sec : CMD <:GEP#>
ERROR 762.583778 sec : Read Command Error: Timeout error
DEBUG 763.585888 sec : CMD <:GLS#>
DEBUG 763.615339 sec : RES <+032670500252100521>
SCOPE 763.615620 sec : CMD <:GEP#>
ERROR 768.618495 sec : Read Command Error: Timeout error
DEBUG 769.619793 sec : CMD <:GLS#>
DEBUG 769.648889 sec : RES <+032670500252100521>
SCOPE 769.649136 sec : CMD <:GEP#>
ERROR 774.653449 sec : Read Command Error: Timeout error
DEBUG 775.655608 sec : CMD <:GLS#>
DEBUG 775.683851 sec : RES <+032670500252100521>
SCOPE 775.684024 sec : CMD <:GEP#>
ERROR 780.689158 sec : Read Command Error: Timeout error
DEBUG 781.690959 sec : CMD <:GLS#>
DEBUG 781.717742 sec : RES <+032670500252100521>
SCOPE 781.718000 sec : CMD <:GEP#>
ERROR 786.721690 sec : Read Command Error: Timeout error
DEBUG 787.723204 sec : CMD <:GLS#>
DEBUG 787.752505 sec : RES <+032670500252100521>
SCOPE 787.752750 sec : CMD <:GEP#>
ERROR 792.757422 sec : Read Command Error: Timeout error
INFO 792.762362 sec : iOptron v3 is offline.

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Hi again, sorry for the delay. Here the protocol of the iOptronV3 driver with a different USB cable. I see basically the same timeout errors:

INFO 33.474740 sec : Session log file /home/ralf/.indi/logs/2020-06-11/indi_ioptronv3_telescope/indi_ioptronv3_telescope_21:29:59.log
DEBUG 42.901736 sec : Connecting to /dev/ttyUSB0
DEBUG 42.909591 sec : Port FD 4
DEBUG 42.909651 sec : Connection successful, attempting handshake...
DEBUG 42.909714 sec : Initializing IOptron using :MountInfo# CMD...
DEBUG 42.909766 sec : CMD <:MountInfo#>
DEBUG 42.930647 sec : RES <0043>
INFO 42.930740 sec : iOptron v3 is online.
DEBUG 42.931583 sec : Configuration successfully saved.
DEBUG 42.933087 sec : Configuration successfully saved for DEVICE_BAUD_RATE.
DEBUG 42.935338 sec : Configuration successfully saved for CONNECTION_MODE.
DEBUG 42.947621 sec : Getting firmware data...
DEBUG 42.947683 sec : CMD <:MountInfo#>
DEBUG 42.978968 sec : RES <0043>
DEBUG 42.979083 sec : CMD <:FW1#>
DEBUG 43.010722 sec : RES <191018200113>
DEBUG 43.010836 sec : CMD <:FW2#>
DEBUG 43.026720 sec : RES <190722190722>
DEBUG 43.026857 sec : Getting guiding rate...
DEBUG 43.026879 sec : CMD <:AG#>
DEBUG 43.058645 sec : RES <5050>
DEBUG 43.058770 sec : CMD <:GUT#>
ERROR 48.061629 sec : Read Command Error: Timeout error
DEBUG 48.062702 sec : CMD <:GLS#>
DEBUG 48.084769 sec : RES <+032670500252100521>
INFO 48.084901 sec : Mount Location: Lat -82:59:50 - Long 9:04:30
DEBUG 48.086945 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
INFO 48.087162 sec : InitPark: No Park data in file /home/ralf/.indi/ParkData.xml: No such file or directory
INFO 48.087315 sec : Mount is unparked.
DEBUG 48.087694 sec : Setting Park Axis1 to 14.88
DEBUG 48.088003 sec : Setting Park Axis2 to -90.00
DEBUG 48.088045 sec : Setting Default Park Axis1 to 14.88
DEBUG 48.088070 sec : Setting Default Park Axis2 to -90.00
DEBUG 48.088110 sec : CMD <:GLS#>
DEBUG 48.116150 sec : RES <+032670500252100521>
ERROR 53.118508 sec : Read Command Error: Timeout error
DEBUG 53.119897 sec : CMD <:SUT0645183041999#>
ERROR 58.121465 sec : Read Command Error: Timeout error
DEBUG 58.122482 sec : CMD <:SG+120#>
DEBUG 58.135896 sec : RES <1>
DEBUG 58.136085 sec : CMD <:SLO+03330000#>
DEBUG 58.168138 sec : RES <1>
DEBUG 58.168255 sec : CMD <:SLA+17567892#>
DEBUG 58.199875 sec : RES <1>
INFO 58.199991 sec : Site location updated to Lat 48:47:59 - Long 9:15:00
DEBUG 58.209456 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
DEBUG 58.209917 sec : CMD <:GLS#>
DEBUG 58.231976 sec : RES <+032670500252100511>
ERROR 63.235809 sec : Read Command Error: Timeout error
DEBUG 64.237704 sec : CMD <:GLS#>
DEBUG 64.267009 sec : RES <+032670500252100521>
ERROR 69.272739 sec : Read Command Error: Timeout error
DEBUG 70.273404 sec : CMD <:GLS#>
DEBUG 70.300891 sec : RES <+032670500252100521>
ERROR 75.305410 sec : Read Command Error: Timeout error
DEBUG 76.306676 sec : CMD <:GLS#>
DEBUG 76.334666 sec : RES <+032670500252100521>
ERROR 81.337987 sec : Read Command Error: Timeout error
DEBUG 82.339198 sec : CMD <:GLS#>
DEBUG 82.369637 sec : RES <+032670500252100521>
ERROR 87.375265 sec : Read Command Error: Timeout error
DEBUG 88.376473 sec : CMD <:GLS#>
DEBUG 88.403837 sec : RES <+032670500252100521>
ERROR 93.409522 sec : Read Command Error: Timeout error
DEBUG 94.409986 sec : CMD <:GLS#>
DEBUG 94.437430 sec : RES <+032670500252100521>
ERROR 99.438339 sec : Read Command Error: Timeout error
DEBUG 100.439562 sec : CMD <:GLS#>
DEBUG 100.472708 sec : RES <+032670500252100521>
ERROR 105.476092 sec : Read Command Error: Timeout error
DEBUG 106.476931 sec : CMD <:GLS#>
DEBUG 106.506602 sec : RES <+032670500252100521>
ERROR 111.509331 sec : Read Command Error: Timeout error
DEBUG 112.510628 sec : CMD <:GLS#>
DEBUG 112.540085 sec : RES <+032670500252100521>
ERROR 117.542463 sec : Read Command Error: Timeout error
DEBUG 118.543696 sec : CMD <:GLS#>
DEBUG 118.559010 sec : RES <+032670500252100521>
ERROR 123.559598 sec : Read Command Error: Timeout error
DEBUG 124.560842 sec : CMD <:GLS#>
DEBUG 124.593254 sec : RES <+032670500252100521>
ERROR 129.599004 sec : Read Command Error: Timeout error
DEBUG 130.600282 sec : CMD <:GLS#>
DEBUG 130.626848 sec : RES <+032670500252100521>
ERROR 135.630536 sec : Read Command Error: Timeout error
DEBUG 136.631785 sec : CMD <:GLS#>
DEBUG 136.661757 sec : RES <+032670500252100521>
ERROR 141.665754 sec : Read Command Error: Timeout error
DEBUG 142.667607 sec : CMD <:GLS#>
DEBUG 142.697975 sec : RES <+032670500252100521>
ERROR 147.703244 sec : Read Command Error: Timeout error
DEBUG 148.705136 sec : CMD <:GLS#>
DEBUG 148.730840 sec : RES <+032670500252100521>
ERROR 153.733406 sec : Read Command Error: Timeout error
DEBUG 154.734604 sec : CMD <:GLS#>
DEBUG 154.764399 sec : RES <+032670500252100521>
ERROR 159.769741 sec : Read Command Error: Timeout error
DEBUG 160.771778 sec : CMD <:GLS#>
DEBUG 160.798341 sec : RES <+032670500252100521>
ERROR 165.803645 sec : Read Command Error: Timeout error
INFO 165.808538 sec : iOptron v3 is offline.

The dmesg -T comand does not show any additional problems after above log was created:

[Do Jun 11 23:29:20 2020] usb 2-1: new full-speed USB device number 11 using uhci_hcd
[Do Jun 11 23:29:20 2020] usb 2-1: New USB device found, idVendor=0403, idProduct=6015
[Do Jun 11 23:29:20 2020] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[Do Jun 11 23:29:20 2020] usb 2-1: Product: FT230X Basic UART
[Do Jun 11 23:29:20 2020] usb 2-1: Manufacturer: FTDI
[Do Jun 11 23:29:20 2020] usb 2-1: SerialNumber: D306SGN1
[Do Jun 11 23:29:20 2020] ftdi_sio 2-1:1.0: FTDI USB Serial Device converter detected
[Do Jun 11 23:29:20 2020] usb 2-1: Detected FT-X
[Do Jun 11 23:29:20 2020] usb 2-1: FTDI USB Serial Device converter now attached to ttyUSB0

In my case the indiserver comand shows a rather old version!

2020-06-11T21:38:40: startup: indiserver
Usage: indiserver [options] driver [driver ...]
Purpose: server for local and remote INDI drivers
INDI Library: 1.7.6
Code 1.7.6-tgz. Protocol 1.7.

How can I update to 1.8.6? My version 1.7.6 comes with the Ubuntu stable version installation.

Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

I am not sure, but the INDI Lib which was installed on my computer is rather old?
libindi1 Version (1.7.6~201812191814~ubuntu16.04.1

May this could cause the trouble? The drivers are too old?
How can I upgrade to the latest version if required?

Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

In comparison here the debug result using the iOptronV3 driver @ 115200 baud:

INFO 11.212734 sec : Session log file /home/ralf/.indi/logs/2020-06-11/indi_ioptronv3_telescope/indi_ioptronv3_telescope_19:31:06.log
DEBUG 23.128309 sec : Connecting to /dev/ttyUSB0
DEBUG 23.134908 sec : Port FD 8
DEBUG 23.134972 sec : Connection successful, attempting handshake...
DEBUG 23.135036 sec : Initializing IOptron using :MountInfo# CMD...
DEBUG 23.135089 sec : CMD <:MountInfo#>
DEBUG 23.158937 sec : RES <0043>
INFO 23.159009 sec : iOptron v3 is online.
DEBUG 23.162370 sec : Configuration successfully saved for DEVICE_PORT.
DEBUG 23.172811 sec : Configuration successfully saved for DEVICE_BAUD_RATE.
DEBUG 23.174146 sec : Configuration successfully saved for CONNECTION_MODE.
DEBUG 23.180969 sec : Getting firmware data...
DEBUG 23.181028 sec : CMD <:MountInfo#>
DEBUG 23.207706 sec : RES <0043>
DEBUG 23.207827 sec : CMD <:FW1#>
DEBUG 23.239045 sec : RES <191018200113>
DEBUG 23.239154 sec : CMD <:FW2#>
DEBUG 23.270992 sec : RES <190722190722>
DEBUG 23.271120 sec : Getting guiding rate...
DEBUG 23.271142 sec : CMD <:AG#>
DEBUG 23.304032 sec : RES <5050>
DEBUG 23.304150 sec : CMD <:GUT#>
ERROR 28.307966 sec : Read Command Error: Timeout error
DEBUG 28.308881 sec : CMD <:GLS#>
DEBUG 28.346113 sec : RES <+032670500252210521>
INFO 28.346330 sec : Mount Location: Lat -82:59:39 - Long 9:04:30
DEBUG 28.354841 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
INFO 28.357057 sec : Mount is unparked.
DEBUG 28.360207 sec : InitPark Axis1 0.00 Axis2 0.00
DEBUG 28.363965 sec : Setting Default Park Axis1 to 13.51
DEBUG 28.364195 sec : Setting Default Park Axis2 to -90.00
DEBUG 28.364641 sec : CMD <:GLS#>
DEBUG 28.394134 sec : RES <+032670500252210521>
ERROR 33.395948 sec : Read Command Error: Timeout error
DEBUG 33.396937 sec : CMD <:SUT0645175889000#>
ERROR 38.400156 sec : Read Command Error: Timeout error
DEBUG 38.400846 sec : CMD <:SG+120#>
DEBUG 38.431143 sec : RES <1>
DEBUG 38.431354 sec : CMD <:SLO+03330000#>
DEBUG 38.463479 sec : RES <1>
DEBUG 38.463617 sec : CMD <:SLA+17567892#>
DEBUG 38.479150 sec : RES <1>
INFO 38.479264 sec : Site location updated to Lat 48:47:59 - Long 9:15:00
DEBUG 38.482513 sec : Configuration successfully saved for GEOGRAPHIC_COORD.
DEBUG 38.483495 sec : CMD <:GLS#>
DEBUG 38.511236 sec : RES <+032670500252210511>
ERROR 43.516537 sec : Read Command Error: Timeout error
DEBUG 44.518520 sec : CMD <:GLS#>
DEBUG 44.547274 sec : RES <+032670500252210521>
ERROR 49.549844 sec : Read Command Error: Timeout error
DEBUG 50.551140 sec : CMD <:GLS#>
DEBUG 50.582085 sec : RES <+032670500252210521>
ERROR 55.583995 sec : Read Command Error: Timeout error
DEBUG 56.585207 sec : CMD <:GLS#>
DEBUG 56.616851 sec : RES <+032670500252210521>
ERROR 61.622151 sec : Read Command Error: Timeout error
DEBUG 62.623729 sec : CMD <:GLS#>
DEBUG 62.652939 sec : RES <+032670500252210521>
ERROR 67.658307 sec : Read Command Error: Timeout error
DEBUG 68.659624 sec : CMD <:GLS#>
DEBUG 68.687704 sec : RES <+032670500252210521>
ERROR 73.692976 sec : Read Command Error: Timeout error
DEBUG 74.694223 sec : CMD <:GLS#>
DEBUG 74.722693 sec : RES <+032670500252210521>
ERROR 79.724102 sec : Read Command Error: Timeout error
DEBUG 80.725693 sec : CMD <:GLS#>
DEBUG 80.758742 sec : RES <+032670500252210521>
ERROR 85.764088 sec : Read Command Error: Timeout error
INFO 86.296688 sec : iOptron v3 is offline.

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

you are really great, thanks!

I enabled the debug option in kStars. This is what it returns using the GEM45 driver @115200 baud:

INFO 119.164343 sec : Session log file /home/ralf/.indi/logs/2020-06-11/indi_ieq_telescope/indi_ieq_telescope_19:15:17.log
DEBUG 158.159514 sec : Toggle Logging Level -- Driver Debug
DEBUG 164.631008 sec : Connecting to /dev/ttyUSB0
DEBUG 164.633291 sec : Port FD 8
DEBUG 164.633347 sec : Connection successful, attempting handshake...
DEBUG 164.633406 sec : Initializing IOptron using :V# CMD...
ERROR 169.638942 sec : Timeout error
ERROR 174.694684 sec : Timeout error
DEBUG 174.745432 sec : Handshake failed.
WARNING 174.745537 sec : Communication with /dev/ttyUSB0 @ 115200 failed. Starting Auto Search...
DEBUG 174.745602 sec : Trying connection to /dev/ttyUSB0 @ 115200 ...
DEBUG 174.745646 sec : Connecting to /dev/ttyUSB0
DEBUG 174.750161 sec : Port FD 9
DEBUG 174.750269 sec : Connection successful, attempting handshake...
DEBUG 174.750319 sec : Initializing IOptron using :V# CMD...
ERROR 179.755469 sec : Timeout error
ERROR 184.810815 sec : Timeout error
DEBUG 184.861015 sec : Handshake failed.

this is the result of dmesg:

[ 648.848074] usb 2-1: new full-speed USB device number 7 using uhci_hcd
[ 649.069245] usb 2-1: New USB device found, idVendor=0403, idProduct=6015
[ 649.069255] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 649.069262] usb 2-1: Product: FT230X Basic UART
[ 649.069269] usb 2-1: Manufacturer: FTDI
[ 649.069275] usb 2-1: SerialNumber: D306SGN1
[ 649.076333] ftdi_sio 2-1:1.0: FTDI USB Serial Device converter detected
[ 649.076425] usb 2-1: Detected FT-X
[ 649.078357] usb 2-1: FTDI USB Serial Device converter now attached to ttyUSB0

Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Hello DZeek,

I did the test with the :MountInfo# comand and it worked.
The Mount returns 0043.

So the connection seems to be ok.

Ralf

Read More...

Ralf replied to the topic 'iOptron GEM45' in the forum. 2 months ago

Hello DZeek,

thanks a lot for your fast reply and your support as well.
I tried also the nightly-build version (installation like described in the download section for Ubuntu), but there was no difference compared to the stable version. So I returned to the stable version after this test.
I will do the test you described:
"Connect with 115200 Baud 8N1 and send "MountInfo#". The mount should return with its 4 digit model number. GEM45 -> "0043" GEM45EC -> "0044"
Hope I will manage that in Linux, because I am no expert on this OS up to now.
I will give you the result as feedback here.

Best Regards
Ralf

Read More...