Scope in remote observatory, connection via RDP, I need to confirm before making changes.

We use the following configuration in Astroberry,
-Astroberry 2.0.4 on raspberry 4B 8Gb
-Kstars 3.5.8 stable
-LX200 classic in polar mode mount
-Moravian Main Chamber
-Guided Camera ASI290MM

Geographic coordinates of the observatory:
-Lat: 42º 13” N
-Length: 06º 59” W
-The Raspberry and LX200 are set to UTC.
-The location configuration of the handpad LX200 Classic, is done as indicated in the documentation, to the west, LAT: +42º 13" LONG: 6º 59”.

Documentation Manual LX200 classic:
“It is important to note that the longitude standard used in the LX200 starts at 0 degrees in Greenwich U.K. and increases Westerly only to 359 degrees 59 minutes. Many maps will show Easterly longitudes which cannot be entered into the keypad display. As an example, if your map indicates that you are at an Easterly longitude of 18 degrees 27 minutes, then you would enter 341 degrees 33 minutes.”

The Kstars is configured so that INDI updates all devices

It happens to us that it gives us an error of:
2022-05-17T01:48:52: [ERROR] Object below the minimum elevation limit.
2022-05-17T01:48:52: [ERROR] Error Slewing to JNow RA 17:24:23 - DEC -12:49:27

And if we look at the LX200 classic handpad the LONG setting has changed.

It seems that the Kstars-INDI sends and configures the geographical coordinates directly to the mount without doing the cartographic correction that the LX200 Classic needs.
How can we avoid this?
Would we avoid this problem by unchecking the position box in the Kstars INDI update time and position settings?