Thanks Kevin, you solved my problem. The issue comes from the custom setting fn. 10 (shutter/AE lock button) to 1 (AE lock/AF). I had never really cared about this setting, i remember picking it up from somewhere on a forum.

About the M mode, i always set it to Manual.

Thanks again

Clear skies