Hmm, so I can get the network-manager back on. But then the country code resets (according to raspi-configure) to "not set". But it is still set in the wpa_supplicant.conf file. Regardless, that didn't seem to fix the connectivity issue through the browser.

A few other configurations to test. But so far, I haven't been plugging/unplugging any USB cables. some of the troubleshooting has been done with just the rpi4 to power and nothing else, so I don't think USB or HDMI interference are the root cause here (but sounds like a problem I might have in the future ;)).


Thanks for the useful suggestions everyone. I haven't had a chance to go back and troubleshoot too much this past week but hope to have some time this weekend.

One thing that I noticed when looking back at the WiFi settings (when that was suggested) was that the country code resets (or doesn't set in the first place?) when set through the raspberry pi configuration (the prompt that opens during first boot up).

On reset, it goes back to "no country selected" (or similar). I had read elsewhere (can't find it now) that a lot of the connectivity is disabled until the country code is selected. So I think the country code not saving/being set could be the culprit (or at least something that isn't helping).

I found this thread on the github page for astroberry:

I started with a "sudo -i", then followed the same commands they did (substituting my country code for PL):

echo "options cfg80211 ieee80211_regdom=PL" > /etc/modprobe.d/cfg80211.conf
systemctl stop network-manager.service
systemctl disable network-manager.service
cp /etc/wpa_supplicant/wpa_supplicant.conf.bak /etc/wpa_supplicant/wpa_supplicant.conf
edit /etc/wpa_supplicant/wpa_supplicant.conf
and reboot

That seems to have fixed the country code (1. actually gets written to wpa_supplicant.conf unlike through raspberry pi configure 2. stays the same through reboot), but then I couldn't figure out how to turn the network-manager back on... I tried all sorts of start, enable, and restart commands, as well as rebooting. Googled solutions didn't seem to turn it back on, and I hadn't had a chance to tinker with it more past that. So in it's current state, it has the right country code but the network-manager never turns on, so I can't test if that was the issue or not.


Hi everyone, I'm new to astroberry. Looks like a fun tool, but I've run into a snag that I can't quite work out. I'm sure I'm over looking something simple, but a point in the right direction would be appreciated.

Equipment: Astroberry 2.0.3 flashed (with etcher) onto a formatted (FAT32) 32GB microSD on a rpi4 4GB.

Problem: "Failed to connect to server" banner when trying to connect through the browser with rpi4 on home wifi (figure 1). When connecting to "astroberry.local/desktop/" or "astroberry.local/desktop/" or "", I get an error that the site cannot be reached (figure 2). I have to connect to the new address on my router ( to make it as far as figure 1. VNC does work, the hotspot does work (with browser connection), as does hdmi to a monitor (hdmi unplugged for most troubleshooting because I read the rpi4 hdmi connected to a 4k 60hz monitor can interfere with the wifi, although I haven't observed this). But I would like to get it working over the browser, as that's my preferred way to connect and it provides simpler access to the INDIserver.


Figure 1

Figure 2

After first boot up, I've run "sudo apt upgrade && sudo apt install && sudo apt dis-upgrade". But the "Failed to connect to server" occurs both before and after these commands are run (tried reflashing and starting fresh a couple times).

Troubleshooting tried so far: After searching through the forums, I have tried reflashing my microSD card a few times, including redownloading the img, both from the main site and from the mirror site. 

Because the problem was persisting through redownloading, reflashing, and before/after "sudo apt update etc.", I thought maybe it was a browser or WiFi/router issue. So I've tried connecting from different browsers, including chrome, firefox, IE (on win 10), chrome and samsung (on android), and safari (on ipad). The same error occurs, so I now figure it isn't a browser/os issue on that end. (I have also tried clearing cookies and cache).

Maybe a router issue? I've confirmed that astroberry is on my network. It has internet access and I can see it as a client on my router page (figure 3) I've tried turning off my router's firewall and WPS, but no change. Are there other router settings people have needed to change to get it working?

Figure 3

Now I'm back to thinking it's something with the astroberry? I don't think it's hardware related, because I can connect via the hotspot through a browser. Looking more at the forums, there were some more sudo commands to try.

I thought maybe rerunning the updates would help, but that just got this (figure 4):

Figure 4

running "sudo apt autoremove" returns "0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded."

I also tried running "sudo apt-get -o Dpkg::Options::="--force-overwrite" -f install", because on one forum page that fixed a "common" install problem. I did notice a couple warnings with Dpkg when updating, but I don't think it's related to this (that's for gps?). No change in behavior.

At this point, I'm just following steps that others have followed when their problem seemed similar to mine (

I tried checking the status of indiwebmanager.service, and I think that looks fine?

Figure 5

I tried checking the VNC service (figure 6):

Figure 6

I'm back to thinking something went wrong with my flash now, but I have tried reflashing a few times. ssagerian eventually solved the problem by changing a setting in etcher, but I've no idea how they got to the setting page they showed. Does etcher not work anymore? Is there a better way to flash the microSD card? 

Again, any pointers would be appreciated.