For the past couple of nights I have been unable to use the internal guider and had to rely on PHD2 for guiding when it use to work flawlessly a few nights ago..

I'm calibrating near the equator and meridian like I normally would, but for some reason calibration is now running away in RA without ever coming back. I can event get to calibrating DEC anymore on a brand new EQ6-R.
It is all working fine in PHD2 through Ekos and calibrates perfectly. I've tried different steps and iterations in Ekos guide module options, but the same result every-time... I previously successfully calibrated Ekos guide module many times before using the recommended number given to me by PHD2 for my location, focal length, pixel size and pointing at the meridian/equator and that gives me 1100ms pulse. I had it on 7 iterations and it always looked perfectly perpendicular with very little backlash... guiding at 0.5... but now my calibration plot looks like a complete mess (attached pic)

I have cleared previous calibration many times, my polar alignment is good. the mount is balanced with no snags.. all cable managed
Any idea how I could fix this issue?

I've included a screen shot of what happens in the calibration in Ekos. I have also included the guider assistant result from last night from PHD2 in case that helps.

Also I'm sure if this could be related but I have had intermittent issue with my EQ6-R usb version crashing Ekos as soon as it would connect to the mount. Deleting all my profiles and creating a fresh one my all the same gear would also result in the exact same issue, ekos crashing instantly when connecting to the mount. I had to first create a profile with a Simulator CCD and EqMod only for it to not crash when connecting to the mount and THEN modify that profile with my gear (canon eosm100 and a Zwo ASI 120mm)... I'm not sure what that is

On another note, when I got it working in the past, I have noticed that if I did my calibration using a binning of 1x with my guide camera and then switch to bin 2x when guiding, my guiding was instantly 40% better guiding in between 0.4 to 0.5 rms... Calibration on bin 2x and guiding at bin 2x does not yield the same results and i'm around 0.8 to 0.9... that seems odd to me as I shouldn't be doing my calibration at a different bin than my guiding....? PHD2 actually brings up an error message when trying to do that I believe.

I would appreciate any help on this!

Thanks

Read More...

Well I calibrated last night near the meridian and equator and I was getting 0.5rms all night… so I guess that’s pretty good!

Read More...

Thanks guys. So if I understand this correctly, for me being in the southern hemisphere, I would point the scope North and set DEC to zero or close to it right?
I just did a quick simulation in Kstars... and based on my understanding if I picked these coordinates that should give me good calibration:
RA: 05h 12m 00.00s. DEC: 00.32.30.48. Azimuth 359 37 25. Altitude 51 31 51
Do I get this right?

Read More...

In PHD2 it is recommended to calibrate near the meridian with dec=0 and then re-use that calibration for guiding when slewing toward the imaging target for the night. 
When using the Ekos internal guider does the same principle applies for calibration? So far I have been doing my calibration on my target for the night and recalibrate every time i move to a new target...
I'm just wondering if my guiding accuracy would improve by calibrating near the meridian with dec at zero.



 

Read More...

For those of you with a Canon EOS M100 having the same issue, here is a work around. Jasem has been kind enough to remote in into my system and tried everything he could, tweaking the gphoto drivers etc... without success unfortunately.

However there is a work around that works well so far:

1) Set your mirror lock to the value of 10: The camera will lock up for 10s before the exposure starts
2) Set the capture format to NATIVE. This is very important. If you set it to FITS the camera sensor won't be illuminated and your picture will look like a dark frames... strange but that's the behaviour.
3) You can now exposures as long as you want without issues that fully illuminate the sensor

Note: updating the camera firmware has no effect... so don't waste your time here. You will now get CR2 pictures opening in the FITS viewer. Those won't be stretched properly and will look strange compared to pictures taken in FITS (at least for me...!). However they look identical to fits in other processing software like Astro Pixel Processor, Photoshop etc... so don't be alarmed... what I do is take a 180s exposure in FITS at 800 iso to make sure everything looks good (that exposure length doesn't not shutdown the camera when downloading) then proportionally adjust the ISO and longer exposure length and quickly import the first exposure into APP to double check.

Why bother with a M100 anyway...? well its really cheap on the second hand market, I got mine for $100, with astro modification it ended up cost me all up about $350 which is pretty great. It has the same ASP-C sensor found in the Canon D80, which is a new generation low noise sensor. It's very light compared to regular DSLRs. Downside? Does not support tethering natively, unless you use Ekos, Gphoto2 or Cascable which are 3rd party applications.

Read More...

Thanks Kevin. Yes power saving features are turned off

Read More...

while I'm at it I have attached all Indie report for the camera if that helps..

Read More...

Thanks for chiming in Jasem. This is what I see. Pic attached

Read More...

There has been a thread about this in the past, but this is still an ongoing issue.

In short with a Canon EOS M100 running Ekos using either the Canon DSLR and Gphoto drivers if you take an exposure longer than 300s the camera shutdown when downloading.
Anything bellow 300s no problem.
In a previous thread someone mentioned that setting the mirror lock to 10s solved the issue which is not true.
While this is true that the camera will no longer shutdown for any exposure length, the exposure is locked out and no pixel are illuminated... even though the shutter is working correctly (I checked). I saw a post from the gentleman who thought he found the fix on facebook stating that he was still having the issue to this day...

I'm really hoping there could be a solution. Gphoto works perfectly with the camera at any exposure length. Another app called Cascade also works perfectly., so  the issue seems to be with Ekos implementation of the Gphoto drivers. (I'm running Kstars on a RPI4 with Stellarmate OS 1.5.9)

I'm tried different USB hubs, no hub at all, different camera USB cable, different USB power supply, battery only= ... with the same result

I would really love to solve this issue. I'm not expecting a straight up solution but if any of you have any idea about the type of parameters or troubleshooting method I could play with in Ekos to get to the bottom of this that would be very much appreciated!

Read More...

Hi AllI have recently setup up Stellarmate OS 1.5.8 with a raspberry pi 4 4gb and I'm having some issues getting my Canon EOSM100 to consistently work with KStarHere is a breakdown of the issues I'm encountering in the hope that some of you may know a solution to my problems.First I'm running Kstar directly on my raspberry pi and remoting in using VNC. I have my raspberry pi running on an SSD (Corsair GTX), all connected to a powered Mbeat USB3 powered USB hub where I I have my AZ GTI running in EQmod through a Linx astro cable, and ASI 120mm mini, a GPS and my Canon EOSM100. Everything connects and works great aside from the Canon which can be have some intermittent connection issues.When I first connect to all the devices with Ekos, everything works fine using the Canon DSLR drivers and it sees my camera just fine. I can take preview picture at any exposure length with no issues.Then I go through my routine of polar alignment, regular alignment , slewing to my target and star the auto guiding process no problem. Then 1/2 the time when I want to start my capture with my DSLR it start taking pictures it is not taking any pics whatever and keeps on restarting the same exposure (can’t hear the shutter working)… which then forces me to shutdown KStar, reconnect everything and restart the whole process from scratch again. 1/2 the time it works…I understand that since the Canon driver can only deal with one camera at the time and remap the USB port every time it launches this is normal behaviour… So I started using the GPhoto driver instead on the canon one in the hope that I would only have to disconnect and reconnect the camera from the Indi Control panel instead. Problem is 90% of the time I try that I get: INDI Driver indi_gphoto_ccd Crashed restart? And if I click on OK Star crashes and restart.I have tried to bypass the camera from the USB hub to see if this was the issue… but same problem.Some other odd behaviour I have noticed is that after using live view (which works fine) and trying to take a regular exposure I get:Exposure failed to save image… Unspecified error and I have to restart Kstar... pretty much can’t use live view before taking any exposures. Also sometime I can disconnect and reconnect the Photo CCD without the Gphoto driver crashing from the Indi control panel and I notice that in the image info tab “Bits per pixel” changes from 8 to 16bitI would like to mention that these problems occurred in the same way before I upgraded to an SSD and was running off the SD card on my Pi.Autopower off is dibbled in my camera alsoAny ideas on things I could try to fix the issue?

Read More...

Hi AllI have recently setup up Stellarmate OS 1.5.8 with a raspberry pi 4 4gb and I'm having some issues getting my Canon EOSM100 to consistently work with KStarHere is a breakdown of the issues I'm encountering in the hope that some of you may know a solution to my problems.First I'm running Kstar directly on my raspberry pi and remoting in using VNC. I have my raspberry pi running on an SSD (Corsair GTX), all connected to a powered Mbeat USB3 powered USB hub where I I have my AZ GTI running in EQmod through a Linx astro cable, and ASI 120mm mini, a GPS and my Canon EOSM100. Everything connects and works great aside from the Canon which can be have some intermittent connection issues.When I first connect to all the devices with Ekos, everything works fine using the Canon DSLR drivers and it sees my camera just fine. I can take preview picture at any exposure length with no issues.Then I go through my routine of polar alignment, regular alignment , slewing to my target and star the auto guiding process no problem. Then 1/2 the time when I want to start my capture with my DSLR it start taking pictures it is not taking any pics whatever and keeps on restarting the same exposure (can’t hear the shutter working)… which then forces me to shutdown KStar, reconnect everything and restart the whole process from scratch again. 1/2 the time it works…I understand that since the Canon driver can only deal with one camera at the time and remap the USB port every time it launches this is normal behaviour… So I started using the GPhoto driver instead on the canon one in the hope that I would only have to disconnect and reconnect the camera from the Indi Control panel instead. Problem is 90% of the time I try that I get: INDI Driver indi_gphoto_ccd Crashed restart? And if I click on OK Star crashes and restart.I have tried to bypass the camera from the USB hub to see if this was the issue… but same problem.Some other odd behaviour I have noticed is that after using live view (which works fine) and trying to take a regular exposure I get:Exposure failed to save image… Unspecified error and I have to restart Kstar... pretty much can’t use live view before taking any exposures. Also sometime I can disconnect and reconnect the Photo CCD without the Gphoto driver crashing from the Indi control panel and I notice that in the image info tab “Bits per pixel” changes from 8 to 16bitI would like to mention that these problems occurred in the same way before I upgraded to an SSD and was running off the SD card on my Pi.Autopower off is dibbled in my camera alsoAny ideas on things I could try to fix the issue?

Read More...