Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Atik GP: Exposure not terminating

Atik GP: Exposure not terminating <Solved> 3 months 2 weeks ago #22838

  • skyborg
  • skyborg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hello out there,

I'm relatively new to INDI and Ekos, and trying to get my setup running. I have an Atik One 6.0 OAG and Kubuntu 17.10 (i386). After installing the Atik INDI drivers (atikccd-1.26-i386.deb), and in addition the libnova-0.14 package, the "main" Atik CCD works fine in Ekos, including image capture, temperature setting and filter wheel. The OAG camera which is an Atik GP shows up as connected, but all exposures (when selected in the capture module or in the guide module) run into a timeout and never return any image data. I have tried only to connect to this camera, have used a direct USB connection to my laptop (without going through the Atik One build in USB hub) and I also have played with the buffer sizes in the camera options. Nothing solved the problem and I'm running out of ideas right now.

Has anybody run into similar problems or any other ideas how to solve the problem? My only last idea which I haven't tried so far is a complete reinstallation back to Kubuntu 16.04...

Best regards,
Frank

Please Log in or Create an account to join the conversation.

Last Edit: by skyborg.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22857

Hi, I tried it and it seems to work. I suspect, that the problem is, that not every exposure time is actually supported by the camera (max exposure is 0.5s). It is actually IIDC camera and INDI driver uses video mode/format 2/2 (or 5/0 for binning 2x2) so it is limitation of available frame rates. If you want to use longer exposure time you need real IIDC driver which can use mode 7. As far as I know there is no such INDI driver, but you may try INDIGO IIDC driver .

Peter
Attachments:
The following user(s) said Thank You: knro, skyborg

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22859

  • skyborg
  • skyborg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi Peter,

Thank you for your reply. You are right, in the last days I have only tried longer exposures but never ones shorter than 1s. It works as you described, using 0.5s returns image data. I haven't exactly understood this limitation, as I am using 3s exposures on my Windows / ASCOM / PHD2 setup with this camera (following PHD's recommendation to use longer exposures to average out seeing effects).

So at least I know now that it's not a problem related to some settings in my installation.

Frank

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22862

Hi Frank, yes, this camera in mode 7 supports longer exposure time. It is limitation of SDK used by INDI driver. The easiest way how to add full support is to use libdc1394, but it was out of scope of Atik SDK. Peter

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22876

  • skyborg
  • skyborg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi Petr,

I tried the INDIGO IIDC driver and exposures > 0.5s work! I am using indigo_server from Ekos, starting the server from the shell with
indigo_server --indi-driver /usr/bin/indi_eqmod_telescope indigo_ccd_atik indigo_ccd_iidc

Thank again!
Frank

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22892

Hi Frank, great! Thank you for testing it! Peter

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22904

  • skyborg
  • skyborg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi Petr, just another quick question: The Atik GP shows up as a "Chameleon CMLN-13S2M" device but with pixel size set to zero. Will this be a problem using it in the Ekos guiding module (I'm afraid it will)? If yes, is there any way to configure the correct pixel size?

Frank

frank@kapella:~$ indigo_prop_tool list "Chameleon CMLN-13S2M.CCD_INFO"
Chameleon CMLN-13S2M.CCD_INFO.WIDTH = 1296.000000
Chameleon CMLN-13S2M.CCD_INFO.HEIGHT = 964.000000
Chameleon CMLN-13S2M.CCD_INFO.MAX_HORIZONTAL_BIN = 1.000000
Chameleon CMLN-13S2M.CCD_INFO.MAX_VERTICAL_BIN = 1.000000
Chameleon CMLN-13S2M.CCD_INFO.PIXEL_SIZE = 0.000000
Chameleon CMLN-13S2M.CCD_INFO.PIXEL_WIDTH = 0.000000
Chameleon CMLN-13S2M.CCD_INFO.PIXEL_HEIGHT = 0.000000
Chameleon CMLN-13S2M.CCD_INFO.BITS_PER_PIXEL = 16.000000

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22906

Hi Frank, Atik GP really is PointGrey Chameleon, it is OEM product.

Pixel size is a problem, because this information is not provided by the camera and generally by DC1394 specs. Is it really needed? The same problem is with V4L2 cameras, am I right Jasem?

If it will help, I can set the size to 1x1 instead of 0x0, but real pixel size can't be determined.

Peter

Please Log in or Create an account to join the conversation.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22915

  • skyborg
  • skyborg's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
OK, the first thing that came to my mind was to make the CCD_INFO property configurable. But I know too little about the indigo architecture if this is possible or makes sense at all...

I did the following:
- downloaded indigo from github
- added the following in indigo_ccd_iidc.c, line 258:
CCD_INFO_PIXEL_SIZE_ITEM->number.value = CCD_INFO_PIXEL_WIDTH_ITEM->number.value = CCD_INFO_PIXEL_HEIGHT_ITEM->number.value = 3.75;
- compiled everything

This seems to work, I know that this is a personal hack and not a general solution ;-)

Best regards,
Frank

Please Log in or Create an account to join the conversation.

Last Edit: by skyborg.

Atik GP: Exposure not terminating 3 months 2 weeks ago #22917

Yes, that's correct. As a general solution I'll set it to 4 microns what is +/- what can be expected from video camera. Peter

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.151 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica