Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Client File Copy

Client File Copy 7 months 1 week ago #16116

I am curious -- how is the INDI Server performing the file copy to the Ekos client when you have it set to store the files on your client? I recently installed and set up a 5G WiFi card on my Pi, which is working well, and about twice as fast as the built-in networking adapter. The problem I have is, there was no improvement in the time it takes for the file to transfer from INDI to my client. Other file copy tests (with the same FITS images from the camera) move much faster on my network, but for some reason the INDI ones don't.

EDIT: Disabling IPv6 on the Pi, and rebooting the device and my router as well, solved the problem. I now get about 8 second downloads with the large frames of the ASI 1600 (32MB files) and I tested my camera that is on order (QSI690) with the simulator and it looks like I will get 3-4 second downloads with that. Perfect.

Please Log in or Create an account to join the conversation.

Last Edit: by rockstarbill.

Client File Copy 7 months 1 week ago #16120

Disabling IPv6 on the PI? How is that related? and how did you do that?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Client File Copy 7 months 1 week ago #16123

Apparently it causes problems for WiFi on the Pi.

sudo -s
sudo echo "net.ipv6.conf.all.disable_ipv6 = 1" >> /etc/sysctl.conf
sudo echo "net.ipv6.conf.default.disable_ipv6 = 1" >> /etc/sysctl.conf
sudo echo "net.ipv6.conf.lo.disable_ipv6 = 1" >> /etc/sysctl.conf

My driver had power management already disabled, but if you don't have that turned off, you want to turn that off as well.

sudo echo "post-up iwconfig wlan0 power off" >> /etc/network/interfaces

Please Log in or Create an account to join the conversation.

Last Edit: by rockstarbill.
  • Page:
  • 1
Time to create page: 0.152 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica