Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: E: Unable to locate package kstars-bleeding [SOLVED]

E: Unable to locate package kstars-bleeding [SOLVED] 6 months 3 weeks ago #16854

I'm running Mint Serena on my laptop:
Linux homer 4.4.0-53-generic #74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
and added the PPA repository: ppa.launchpad.net/mutlaqja/ppa/ubuntu xenial InRelease

Today after update/upgrade, Ekos was crashing due to a segfault in libqt5quick5. as a first solution I tried to remove and install kstars-bleeding again, but:
ferrante@homer ~ $ sudo apt-get install kstars-bleeding
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package kstars-bleeding

But the repository is ok: I can install kstars, indi etc.
Any thoughts?

Please Log in or Create an account to join the conversation.

Last Edit: by fenriques.

E: Unable to locate package kstars-bleeding 6 months 3 weeks ago #16861

I just got same with ubuntu 16.10, unable to locate kstars-bleeding. Seems a fix is required in latest updates.

Please Log in or Create an account to join the conversation.

E: Unable to locate package kstars-bleeding 6 months 3 weeks ago #16863

Working on it. Hopefully in an hour or two it will be fine again.
The following user(s) said Thank You: MiHell, fenriques

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Last Edit: by knro.

E: Unable to locate package kstars-bleeding 6 months 3 weeks ago #16865

tested right now and it works.
Thank you Jasem for this and all your great job on INDI/Ekos in these years.


Apt history log:
Start-Date: 2017-05-20  09:03:19
Commandline: apt-get install kstars-bleeding
Requested-By: ferrante (1000)
Install: libkf5notifications-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5kiowidgets5:amd64 (5.18.0-0ubuntu1.1, automatic), libkf5config-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5attica5:amd64 (5.18.0-0ubuntu1, automatic), kinit:amd64 (5.18.0-0ubuntu1.1, automatic), qml-module-qtquick-window2:amd64 (5.5.1-2ubuntu6, automatic), libkf5i18n-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5coreaddons-data:amd64 (5.18.0-0ubuntu1, automatic), libdbusmenu-qt5:amd64 (0.9.3+16.04.20160218-0ubuntu1, automatic), libkf5itemviews5:amd64 (5.18.0-0ubuntu1, automatic), libkwalletbackend5-5:amd64 (5.18.0a-0ubuntu1, automatic), oxygen-icon-theme:amd64 (5:5.18.0-0ubuntu1, automatic), qml-module-qtquick2:amd64 (5.5.1-2ubuntu6, automatic), libkf5codecs5:amd64 (5.18.0-0ubuntu1, automatic), libkf5globalaccel5:amd64 (5.18.0-0ubuntu1, automatic), libkf5dbusaddons5:amd64 (5.18.0-0ubuntu1, automatic), libkf5configwidgets-data:amd64 (5.18.0-0ubuntu1, automatic), qml-module-qtquick-controls:amd64 (5.5.1-1ubuntu1, automatic), libkf5service-bin:amd64 (5.18.0-0ubuntu1, automatic), libkf5codecs-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5widgetsaddons-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5configcore5:amd64 (5.18.0-0ubuntu1, automatic), libkf5notifyconfig-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5jobwidgets5:amd64 (5.18.0-0ubuntu1, automatic), libkf5wallet-bin:amd64 (5.18.0a-0ubuntu1, automatic), qml-module-qtquick-layouts:amd64 (5.5.1-1ubuntu1, automatic), kded5:amd64 (5.18.0-0ubuntu1, automatic), libpolkit-qt5-1-1:amd64 (0.112.0-4, automatic), libkf5coreaddons5:amd64 (5.18.0-0ubuntu1, automatic), libkf5globalaccel-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5textwidgets-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5plotting5:amd64 (5.18.0-0ubuntu1, automatic), kio:amd64 (5.18.0-0ubuntu1.1, automatic), libkf5notifyconfig5:amd64 (5.18.0-0ubuntu1, automatic), libkf5configwidgets5:amd64 (5.18.0-0ubuntu1, automatic), libkf5configgui5:amd64 (5.18.0-0ubuntu1, automatic), libkf5service5:amd64 (5.18.0-0ubuntu1, automatic), libkf5completion5:amd64 (5.18.0-0ubuntu1, automatic), libkf5completion-data:amd64 (5.18.0-0ubuntu1, automatic), libqt5concurrent5:amd64 (5.5.1+dfsg-16ubuntu7.2, automatic), libkf5wallet-data:amd64 (5.18.0a-0ubuntu1, automatic), libkf5newstuff5:amd64 (5.18.0-0ubuntu1, automatic), libkf5dbusaddons-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5wallet5:amd64 (5.18.0a-0ubuntu1, automatic), libkf5newstuff-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5xmlgui5:amd64 (5.18.0-0ubuntu1, automatic), libkf5textwidgets5:amd64 (5.18.0-0ubuntu1, automatic), libkf5guiaddons5:amd64 (5.18.0-0ubuntu1, automatic), kstars-bleeding:amd64 (5:17.04+201705192251~ubuntu16.04.1), libkf5solid5-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5sonnetcore5:amd64 (5.18.0-0ubuntu1, automatic), kstars-bleeding-data:amd64 (5:17.04+201705192251~ubuntu16.04.1, automatic), libkf5kiontlm5:amd64 (5.18.0-0ubuntu1.1, automatic), libkf5windowsystem5:amd64 (5.18.0-0ubuntu1, automatic), libfam0:amd64 (2.7.0-17.1, automatic), libkf5service-data:amd64 (5.18.0-0ubuntu1, automatic), libphonon4qt5-4:amd64 (4:4.8.3-0ubuntu3, automatic), libkf5iconthemes-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5jobwidgets-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5widgetsaddons5:amd64 (5.18.0-0ubuntu1, automatic), breeze-icon-theme:amd64 (4:5.18.0-0ubuntu1, automatic), libkf5sonnetui5:amd64 (5.18.0-0ubuntu1, automatic), libkf5auth-data:amd64 (5.18.0-0ubuntu2, automatic), libkf5itemviews-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5iconthemes5:amd64 (5.18.0-0ubuntu1, automatic), libkf5auth5:amd64 (5.18.0-0ubuntu2, automatic), libkf5windowsystem-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5xmlgui-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5solid5:amd64 (5.18.0-0ubuntu1, automatic), oxygen5-icon-theme:amd64 (5.18.0-0ubuntu1, automatic), libkf5gpgmepp5:amd64 (15.12.3-0ubuntu1, automatic), kstars-bleeding-dbg:amd64 (5:17.04+201705192251~ubuntu16.04.1, automatic), libkf5crash5:amd64 (5.18.0-0ubuntu1, automatic), libkf5kiocore5:amd64 (5.18.0-0ubuntu1.1, automatic), libkf5archive5:amd64 (5.18.0-0ubuntu1, automatic), libkf5notifications5:amd64 (5.18.0-0ubuntu1, automatic), libkf5sonnet5-data:amd64 (5.18.0-0ubuntu1, automatic), libkf5i18n5:amd64 (5.18.0-0ubuntu1, automatic)
End-Date: 2017-05-20  09:03:47

Please Log in or Create an account to join the conversation.

E: Unable to locate package kstars-bleeding 6 months 3 weeks ago #16881

tested with Ubuntu 16.10, Kstars runs but I still see a dependency error libindi1, not sure if it's my setup or more generic:-

sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
libindi1
The following NEW packages will be installed
libindi1
0 to upgrade, 1 to newly install, 0 to remove and 9 not to upgrade.
24 not fully installed or removed.
Need to get 0 B/254 kB of archives.
After this operation, 903 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 449237 files and directories currently installed.)
Preparing to unpack .../libindi1_1.4.1+r3089~201705200923~ubuntu16.10.1_amd64.deb ...
Unpacking libindi1:amd64 (1.4.1+r3089~201705200923~ubuntu16.10.1) ...
dpkg: error processing archive /var/cache/apt/archives/libindi1_1.4.1+r3089~201705200923~ubuntu16.10.1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libindidriver.so.1', which is also in package libindidriver1:amd64 1.2.0-2~ubuntu2
Errors were encountered while processing:
/var/cache/apt/archives/libindi1_1.4.1+r3089~201705200923~ubuntu16.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please Log in or Create an account to join the conversation.

E: Unable to locate package kstars-bleeding 6 months 3 weeks ago #16882

You still have INDI stuff from stock Ubuntu.
sudo apt-get purge libindi1 indi-bin libindidriver1
sudo apt-get install kstars-bleeding indi-full libindi1

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

E: Unable to locate package kstars-bleeding 6 months 2 weeks ago #16900

hi jasem, i tried all purges including your combination and with synaptic package manager but still get a loop, which made me think it was still an issue rather then my linux skills. I still get a conflict between libindi1 and libindidriver

sudo apt-get purge libindi1 indi-bin libindidriver1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'libindi1' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
indi-aagcloudwatcher : Depends: libindi1 but it is not going to be installed
indi-apogee : Depends: libindi1 but it is not going to be installed
indi-asi : Depends: libindi1 but it is not going to be installed
indi-dsi : Depends: libindi1 but it is not going to be installed
indi-duino : Depends: libindi1 but it is not going to be installed
indi-eqmod : Depends: libindi1 but it is not going to be installed
indi-ffmv : Depends: libindi1 but it is not going to be installed
indi-fishcamp : Depends: libindi1 but it is not going to be installed
indi-fli : Depends: libindi1 but it is not going to be installed
indi-full : Depends: libindi1 (>= 1.2) but it is not going to be installed
Depends: indi-bin (>= 1.2) but it is not going to be installed
indi-gphoto : Depends: libindi1 but it is not going to be installed
indi-gpsd : Depends: libindi1 but it is not going to be installed
indi-maxdomeii : Depends: libindi1 but it is not going to be installed
indi-mi : Depends: libindi1 but it is not going to be installed
indi-nexstarevo : Depends: libindi1 but it is not going to be installed
indi-qhy : Depends: libindi1 but it is not going to be installed
indi-qsi : Depends: libindi1 but it is not going to be installed
indi-sbig : Depends: libindi1 but it is not going to be installed
indi-sx : Depends: libindi1 but it is not going to be installed
kstars-bleeding : Depends: libindi1 but it is not going to be installed
Depends: indi-bin but it is not going to be installed
libindi-dev : Depends: libindi1 (= 1.4.1+r3089~201705200923~ubuntu16.10.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (

Please Log in or Create an account to join the conversation.

E: Unable to locate package kstars-bleeding 6 months 2 weeks ago #16901

solved in the end by forcing overwrite

dpkg -i --force-overwrite /var/cache/apt/archives/libindi1_1.4.1+r3091~201705210923~ubuntu16.10.1_amd64.deb

thanks oir support and development

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.130 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica