Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Reporting from Starfest- issues

Reporting from Starfest- issues 4 days 2 hours ago #28479

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
Last night in the middle of an open field in the country I had a few issues...

1) GPS does not work
2) solver wil not converge. I have an update to this post : www.indilib.org/forum/ekos/3717-solver-will-not-converge.html

It’s works in the west sky but not in the east. It actually diverges we pointed east.

Also I was almost at zeneth and tried « slew to target «  and the scope was driven nearly upside down. My lat/Lon here is approx. -80/45 dégrées. Using Kstars 2.9.7 and stellarmate 1.3

So this looks a lot like the problem that the synscan driver had with negative longitudes.


I don’t have logs from last night but will try tonight.
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Reporting from Starfest- issues 4 days 40 minutes ago #28481

That's awful, sorry it didn't work out for you.

1. You can fallback to INDI GPS NMEA driver, it works from GPS on your phone.You said that cgps and gpsmon were not working, so there is probably an issue communication with the device. Did you run the StellarMate Port Mapper after you reinstalled v1.3.0 again?
2. Ok logs might shed some light on this. What's the reason for not using EQMod? no EQDirect cable?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Reporting from Starfest- issues 3 days 21 hours ago #28484

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
I’ll have to check the device when I get home. I had used port mapper and had everything working before going out last week but then things acted up again.

I was using EQMOD last night. I was referring to some similar behaviour I’d seen with synscan a while back. There was an issue with negative longitude. The problem last night looks similar

The link points to the original issue post that has logs. I haven’t heard any updates. But I wanted to give some more info that might help

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Reporting from Starfest- issues 3 days 12 hours ago #28490

Negative longitude? Are you entering the longitude manually in INDI control panel?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Reporting from Starfest- issues 3 days 2 hours ago #28506

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
I use the geography dialog to enter custom city and lat/long. The dialog accepted the format I entered with negative long instead of say 80 deg west

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Reporting from Starfest- issues 2 days 5 hours ago #28553

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
About the GPS. Yes, the device is working. As mentioned it has a flashing led when it has a fix so I know it has a fix. Here is the screenshot of GPSUtility for Mac - I note that the baud rate is 4800. I sure hope GPSD can figure that out. Its pretty basic:

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Reporting from Starfest- issues 2 days 5 hours ago #28554

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
About the GPS. Yes, the device is working. As mentioned it has a flashing led when it has a fix so I know it has a fix. Here is the screenshot of GPSUtility for Mac - I note that the baud rate is 4800. I sure hope GPSD can figure that out. Its pretty basic:

Attachments:

Please Log in or Create an account to join the conversation.

Reporting from Starfest- issues 2 days 3 hours ago #28559

I think this is it. I just remember setting this before. Was it on your StellarMate? I have terrible memory. But it must have been cleared when you reflashed your image. So you need to edit /etc/rc.local and then add this before the line that says exist 0
sudoedit /etc/rc.local

then add this

stty -F /dev/gps 4800

Of course, assuming you used the port mapper to map the GPS.
The following user(s) said Thank You: gbeaton

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last Edit: by knro.

Reporting from Starfest- issues 2 days 2 hours ago #28562

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
This is good news but is it possible to have auto baud rate detection? As it is it’s not user friendly. My memory is bad too so I couldn’t remember if I had to set the baud rate or if in the end it was automatic.

I don’t think a user should ever have to go outside of Kstars for any setup. At the very least Kstars should ask for the baud rate but surely Kstars could easily figure is out if it’s not done in gpsd.

Please Log in or Create an account to join the conversation.

Reporting from Starfest- issues 2 days 2 hours ago #28564

This is a system-level setting. I suppose I can update the port mapper to force a specific baud rate so it's done in 1 step.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Reporting from Starfest- issues 2 days 1 hour ago #28566

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 254
  • Karma: 1
  • Thank you received: 23
I saw your presentation on the Astro channel on YouTube. You noted that some people just want things to work. That would be me ;-) I bought StellarMate for that reason. So whatever it takes to make it plug and play would be appreciated by any user.

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.
  • Page:
  • 1
Time to create page: 0.330 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica