Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Connecting indi via Bluetooth to a compuer

Connecting indi via Bluetooth to a compuer 5 months 1 week ago #17268

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 35
  • Thank you received: 4
Hi tseckler thanks for your response regarding auto binding a shoestring bt adapter.

I tried your solution on my rpi3. But when I then start kstars and do the connection with ekos I get the same error as I was initially getting (see my post #16099).

The only difference this time is the red led on the shoestring adapter now stays on (its not flashing) which means it is still connected.

I'll keep tinkering to see if I can cracking it.

Regards

Please Log in or Create an account to join the conversation.

Telescope - Takahashi FC-100DF
Mount - HEQ5 Pro
Guiding - Orion 50mm guide scope with ZWO ASI 120MC

Connecting indi via Bluetooth to a compuer 5 months 1 week ago #17269

You may want to make sure /usr/bin/rfcomm0.sh is executable.
sudo chmod +x /usr/bin/rfcomm0.sh.

Please Log in or Create an account to join the conversation.

Connecting indi via Bluetooth to a computer 5 months 1 week ago #17272

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 35
  • Thank you received: 4
Hi tseckler, I just checked to make sure the service for enabled, it was. Still the same issue. The port auto binds but when i try connecting to it in ekos, the port is unresponsive. I checked on my server to make sure the bt was connected and the bt manager shows a perfect connection??? Very weird.

Could it have anything to do with my auto indi server startup? Could it be an issue with the order in which things start up? To start up my indiserver automatically i did this:

Set up Rpi3 to Automatically Start indiserver

Connect all equipment to the rpi3 (heq5, guider, ccd, focuser etc etc) and power up rpi3. You will notice that the BT adapter’s red LED flashes which means it is NOT connected to the rpi3 yet.

To start indiserver automatically, open a terminal and type:

sudo pluma /lib/systemd/system/indi.service

and add the following to the file:

[Unit]
Description=Start INDI server at startup.
[Service]
User=username
Group=usergroup
Type=simple
Restart=always
ExecStart=/usr/bin/indiserver indi_eqmod_telescope indi_asci_ccd indi_gphoto_ccd indi_joystick
[Install]
WantedBy=graphical.target
WantedBy=multi-user.target

and save the file and then activate is via

sudo systemctl enable indi.service

Please Log in or Create an account to join the conversation.

Telescope - Takahashi FC-100DF
Mount - HEQ5 Pro
Guiding - Orion 50mm guide scope with ZWO ASI 120MC

Connecting indi via Bluetooth to a compuer 4 months 1 week ago #17880

Thanks, but this is basically a nightmare for new users who have no background in LInux, there is no easy way for this?

Pair and connect BT Adapter
To the file /etc/rc.local add this line of code.
Don't miss the trailing & in this code and sub XX's for adapter MAC address.
rfcomm bind hci0 XX:XX:XX:XX:XX:XX 1 &

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.130 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica