Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: iOptron SmartEQ pro-Error setting local date/UTC Offset.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23852

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1
Good afternoon,

Details:
iOptron SmartEQ Pro (Go2Nova 8408).
gpsd: 3.15 (revision 3.15-2build1).
Ubuntu 16.04 LTS (Kernel 4.13.0-36-generic).
Kstars Version 2.9.3
indi version 1.6.0
ekos version ??

I am running into an issue with setting the time and date on the HC using ekos and GPSD. GPSD is functioning properly in ekos which is great. I have built a GPS reciever using the MTK3339 chipset. I have used this chipset in other projects and have had no issues with it. In my case here, i can say with a great level of confidence that the GPS is functioning properly.

The trouble I am having is that when I connect to the mount in ekos, the time and date on the HC change to "2096-29-04 00:01:00". The functionality of the mount appers to be working properly, I can slew, etc. I have briefly visited indi's github page in an attempt to troubleshoot the issue myself because I believe the issue may only a simple time/date format issue. At least upon initial thoughts on the matter. I have been attempting to find a mount driver that updates the HC time/date properly but have been unable (including the iOptron SmartEQ, the GotoNova 8400 kit, and the lx200_zeq). I have visited the indi Github page in an attempt to diff a working driver but have this issue no matter what I select for the mount.

My first question is: Has anyone else run into this issue with the iOptron Smarteq Pro with 8408 HC? I believe the only difference between the SmartEQ and the Pro is the material the internal gears are manufactured with (metal vs. plastic). I may however be incorrect on this point as well.

Second question: Is the lx200_zeq25 the proper selection? Based on a post I read a while back, I have been led to believe that several selections are the same, if not, very similar.

Attached is a log file I dumped earlier today in an attempt to resolve the issue on my own. I am hoping for a nudge in the right direction. Any suggestions are appreciated. Thank you in advance.

Kindly,
cl330b

edit:

Here is where I believe I am having an issue but I am not sure what the iOptron SmartEQ pro mount is looking for.
SCOPE	116.997126 sec	: <setCalenderDate>
SCOPE	116.997130 sec	: CMD <:SC 03/04/18#>
SCOPE	127.037081 sec	: Unable to parse response
ERROR	127.037102 sec	: Error setting local date.
    if (setCalenderDate(PortFD, ltm.days, ltm.months, ltm.years) < 0)
    {
        DEBUG(INDI::Logger::DBG_ERROR, "Error setting local date.");
        return false;
    }

EDIT:

It appears that I was able to locate a post where a user has success with the iOptron SmartEQ Pro with 8408 HC.

Here

Based on this post, I located some information on the indi github page that I believe will help. I will test and report back.
        <device label="iOptron iEQ45 Pro">
                <driver name="iEQ">indi_ieq_telescope</driver>
                <version>1.5</version>
        </device>
        <device label="iOptron CEM60">
                <driver name="iEQ">indi_ieq_telescope</driver>
                <version>1.5</version>
        </device>
        <device label="iOptron CEM25">
                <driver name="iEQ">indi_ieq_telescope</driver>
                <version>1.5</version>
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by cl330b. Reason: Modify title

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23862

Can you use minicom or Cutecom to send the command directly the HC and see what its response is? i.e. send it

:SC 03/04/18#

There are many IOptron and I am confused about the different models as well. If there is a correction to be made to INDI drivers list, please let me know.
The following user(s) said Thank You: cl330b

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23922

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1
Hello knro,

I found in my testing that the issue is formatting of the time/date. For example, I receive a response of "1" when I send command (using proper date)
:SCYYMMDD#
to the mount, which is the proper response. There is no response when I send
:SC 03/04/18#
.

Here is the output of my serial session:
:V#
v1.00#
:MountInfo#
0011
:SC180306#
1
:FW1#
170518170518#
:FW2#
161028161028#

I was able to locate an iOptron® Mount RS-232 Command Language document from 2014. It doesn't apply to the iOptron SmartEQ/pro, but the command format is correct. All commands I tested (which wasn't all of them) provided the proper response from the mount and the changes were reflected on the HC. I'm certain you are familiar with this document so I haven't included it.

I host my own Gitlab server so I am familiar with git, I would offer to make the changes myself but have limited time right now. I would however LOVE to contribute in the near future. Is there any other info I can provide at this time?

Thank you kindly,
cl330b

Please Log in or Create an account to join the conversation.

Last Edit: by cl330b. Reason: Clarification on command

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23923

Is this the only command that simply removes the space or all other commands for the iOptron SmartEQ/Pro are "spaceless"? Is this the only difference that distinguishes the command set from the official iOptron Mount RS-232 document?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23924

In case it helps: I was in contact with Ioptron support yesterday, asking about their support of ASCOM/INDI for their CEM120 range. The answer I got was that ASCOM was supported but not INDI, but they were willing to give the command set to a INDI developer. Has anyone tried reaching out to them for this type of documentation?

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23925

Given the number of IOptron users using INDI drivers, maybe they should pressure iOptron for more support?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23926

I agree with you. If anyone reading this is in this category, I suggest sending an email to This email address is being protected from spambots. You need JavaScript enabled to view it. to politely request INDI support for your mount. While you are likely to get a response back similar to what I received, perhaps the volume of requests might sway their thinking to helping more.
The following user(s) said Thank You: knro, dokeeffe, El Corazon

Please Log in or Create an account to join the conversation.

Last Edit: by lazjen.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 2 weeks ago #23931

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1
I will send them a request. Hopefully they will at the very least provide the rs232 command language document for the iOptron smarteq/pro mount.

On a side note, I tested the "cem60" driver, which is actually "indi_ieq_telescope" to the best of my knowledge. And I can say with certainty that the time, date, and coordinates are being updated properly on the HC 8408. I wasn't able to locate the source code for this driver in the indi repo though.

I will be able to perform more in-depth testing this weekend and provide knro a more detailed list of what is working and what is not. To directly answer your question though, another item I observed not working properly is the UTC Offset and local time. Formats below:
:SLHHMMSS# (local time) 
:SGsMMM# (UTC Offset. i.e. -480)

Both commands should return "1".


Kindly,
cl330b

Please Log in or Create an account to join the conversation.

Last Edit: by cl330b. Reason: adding additional information

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 1 week ago #24001

So if you use indi_ieq_telescope driver with your mount, everything works? The driver is available here

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 1 week ago #24029

I posted about a similar problem with my SmartEQ Pro before. I am just using the CEM60 driver, I can control the mount fine with that one for all practical purposes, except for parking. That needs to be done manually by telling the mount to go Home, not Park. Another problem is that if you try to change the guide tracking speed to 0.5 x sidereal, the mount will set it to 0.05 and all guiding will fall apart then. Otherwise, no problem. Just use the CEM60 driver.

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 1 week ago #24041

So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 3 months 1 week ago #24061

knro wrote: So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?


I can confirm the aberrant behavior re date setting under the iOptron SmartEQ driver. However, as far as I understand it, the iOptron drivers are not controlling the mount, they are programming and controlling the handset. I cannot directly connect the serial cable to the mount, only through the handset, and that is then being reprogrammed during startup by Ekos. So, the handset # is the critical piece of information which driver to use, not the mount. For the iOptron SmartEQs, at least those acquired during the last year, that seems to be #8408.
HC #8408 responds (almost) flawlessly to the iOptron CEM60 driver. No problem with date there, only two minor issues I found for which there are workarounds:
It is not possible to 'Park' the mount, i.e. it slews fine to the Home position, but remains in the Unparked state. Not a major issue as far as I am concerned.
The second concerns sidereal guiding rate. I already pointed that out a few weeks ago. See attached screenshot. The default set of the x sidereal guiding rate is 50.5, obviously way off. However, if you now set it to the proper value of 0.5 using the set button on the right, Indi Control Panel will show the rate as 0.5x, however, the handset will have been reprogrammed to 0.05x, so one power of 10 off, but in RA only, NOT in DEC.
Again, not a major problem for practical purposes, as long as one is aware of it and checks the guiding rate on the HC before starting the night session. Still, it would be nice if that could be fixed, others using iOptron mounts may not notice why their guiding is way off.
Jo
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.190 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!
´╗┐

Gallery

Replica

Why INDI

Replica