Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

oleg wrote: Now, you can try install and run synaptic for visual installation and control.

sudo apt-get install synaptic

sudo synaptic


All working again. I gave up and did a full reinstall of 16.04. Fortunately, a Linux reinstall is just a fairly quick thing to do - unlike Windows where you need to clear out a whole day to fix! :-)

Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

oleg wrote: sudo apt-get remove libindi1


Tried that too. It's just stuck in there and can't uninstall.
tegwilym@Tom-Ubuntu:~$ sudo apt-get remove libindi1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 indi-aagcloudwatcher : Depends: libindi1 but it is not going to be installed
 indi-apogee : Depends: libindi1 but it is not going to be installed
 indi-asi : Depends: libindi1 but it is not going to be installed
 indi-bin : Depends: libindi1 but it is not going to be installed
 indi-dsi : Depends: libindi1 but it is not going to be installed
 indi-duino : Depends: libindi1 but it is not going to be installed
 indi-eqmod : Depends: libindi1 but it is not going to be installed
 indi-ffmv : Depends: libindi1 but it is not going to be installed
 indi-fishcamp : Depends: libindi1 but it is not going to be installed
 indi-fli : Depends: libindi1 but it is not going to be installed
 indi-full : Depends: libindi1 (>= 1.2) but it is not going to be installed
 indi-gphoto : Depends: libindi1 but it is not going to be installed
 indi-gpsd : Depends: libindi1 but it is not going to be installed
 indi-gpsnmea : Depends: libindi1 but it is not going to be installed
 indi-maxdomeii : Depends: libindi1 but it is not going to be installed
 indi-mi : Depends: libindi1 but it is not going to be installed
 indi-nexdome : Depends: libindi1 but it is not going to be installed
 indi-nexstarevo : Depends: libindi1 but it is not going to be installed
 indi-qhy : Depends: libindi1 but it is not going to be installed
 indi-qsi : Depends: libindi1 but it is not going to be installed
 indi-sbig : Depends: libindi1 but it is not going to be installed
 indi-sx : Depends: libindi1 but it is not going to be installed
 kstars-bleeding : Depends: libindi1 but it is not going to be installed
 libindi-dev : Depends: libindi1 (= 1.6.2+r3729~201801140557~ubuntu16.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
tegwilym@Tom-Ubuntu:~$


Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

oleg wrote: sudo apt-get -f install


Tried that many times, still the same problem.
tegwilym@Tom-Ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  astrometry.net libastrometry0 libcfitsio-bin liberfa1 libindidriver1 libkf5bookmarks-data libkf5bookmarks5 libkf5kiofilewidgets5 linux-headers-4.4.0-101 linux-headers-4.4.0-101-generic
  linux-image-4.4.0-101-generic linux-image-extra-4.4.0-101-generic python-astrometry python-astropy sextractor
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libindi1
The following packages will be upgraded:
  libindi1
1 upgraded, 0 newly installed, 0 to remove and 166 not upgraded.
4 not fully installed or removed.
Need to get 0 B/289 kB of archives.
After this operation, 1,048 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 520193 files and directories currently installed.)
Preparing to unpack .../libindi1_1.6.2+r3729~201801140557~ubuntu16.04.1_amd64.deb ...
Unpacking libindi1:amd64 (1.6.2+r3729~201801140557~ubuntu16.04.1) over (1.1.0-1ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libindi1_1.6.2+r3729~201801140557~ubuntu16.04.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libindidriver.so.1', which is also in package libindidriver1:amd64 1.1.0-1ubuntu1
Processing triggers for libc-bin (2.23-0ubuntu9) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Errors were encountered while processing:
 /var/cache/apt/archives/libindi1_1.6.2+r3729~201801140557~ubuntu16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
tegwilym@Tom-Ubuntu:~$


Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

Seems that the INDI problem is blocking me from installing any "apt-get install xxxx" packages.

Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

Tried Synaptic and get this familiar message.

tegwilym@Tom-Ubuntu:~$ sudo apt-get install synaptic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is to be installed
 libindi-dev : Depends: libindi1 (= 1.6.2+r3729~201801140557~ubuntu16.04.1) but 1.1.0-1ubuntu1 is to be installed
 synaptic : Depends: libept1.5.0 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
tegwilym@Tom-Ubuntu:~$


Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

oleg wrote: Tom,
you can download and try my open project "Ubuntu Astronomy 16.04" (64-bit).
IMHO, it can help you on your Linux newbie road :)


I already have! Excellent variation of Ubuntu. I have it as a dual boot on my laptop. Eventually I'll probably try dual booting with Windows 7 (yuck!) on my observatory computer. I just would have to reboot to Windows to control my dome since I don't see any support in INDI for the Technical Innovations dome. :(

Thanks for your work on Ubuntu Astronomy, I really do like it, and hopefully will be the main OS in my observatory one of these days! :)
Tom

Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

Tried this and the previous suggestion. Still the same thing.

Read More...

Tom Gwilym replied to the topic 'apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

Yep! Tried that. Got this result. (same thing)

sudo apt-get dist-upgrade
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is installed
 libindi-dev : Depends: libindi1 (= 1.6.0+r3702~201801031125~ubuntu16.04.1) but 1.1.0-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.


Read More...

Tom Gwilym created a new topic ' apt-get update problems with INDI (Unmet dependencies)' in the forum. 7 months ago

Hey guys,
A while back I installed the latest KStars or maybe it was Stellarium? That had the INDI drivers included. Since then when I do the apt-get upgrade/install I get a message about unmet dependencies and I can't get further.
This is the result:

tegwilym@Tom-Ubuntu:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 indi-full : Depends: libindi1 (>= 1.2) but 1.1.0-1ubuntu1 is installed
 libindi-dev : Depends: libindi1 (= 1.6.0+r3702~201801031125~ubuntu16.04.1) but 1.1.0-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.
Running the "-f" option doesn't do anything to fix the problem. Is there a way that I can remove INDI from my computer? I've checked other messages in this forum with similar problems and their fixes don't work either. I'm currently running Ubuntu 16.10 and will upgrade to 18 LTS, but just skipping 17.x for now since it seems to be a mediocre update. I do hope to get deep into INDI eventually, when I set up a new observatory (probably with a NexDome) since I plan on moving and will probably sell/donate my Technical Innovations dome (which isn't supported). I really want to get away from Windows 7 and go totally Linux eventually!

Any ideas how I can just remove it for now so I can run updates on my OS?
Thanks,
Tom

Read More...

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!