Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 1 week ago

Ok! ;)
I was just curious to test your change. I will wait for the final fix! Thank you! :)

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 1 week ago

Hi guys!
in which folder have I to insert the synscanmount.cpp fixed file? I think this should be the fixed package to replace somewhere...
I have a Mac OS Sierra and the tree folder of kstars is /Applications/kstars.app/Contents/

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 1 week ago

kecsap wrote: I created a fix for this issue ( github.com/indilib/indi/pull/598 ) and it was merged. It will appear tomorrow or after that in the PPA updates.

Disclamer: I don't have a Synscan cable nor an EQ mount. My change _should_ work out of the box, but no guarantee as it was not tested. Please test first carefully, do manual syncs without plate solving and see if +/- RA/DEC coordinates are synced correctly to the handset. And report back the results in any case.


Hi kecsap!
Thank you very much for your work. I will test your fix as soon as possible.

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 weeks ago

kross wrote: I played with this some over the weekend. I changed the code so it sends RA/Dec instead of Alt/Az. The Dec axis gets updated just fine, but the RA axis wouldn't update. Not sure what's going on. I will have to mess with it some more.


Brilliant!! :o
This sounds considerably good! Thanks for your efforts. I'm curious to see the final result and to finally use the SynScan also with ekos.
I look forward to hearing from you!
Bye! ;)

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 weeks ago

kecsap wrote: I don't have Synscan cable right now because I killed the previous one. The only thing you can do to record a log of the Synscan driver and attach here to have a look. At least I don't have any other idea how to progress further. You can change the logging levels before you connect to the INDI server in Ekos. There is a "Log" button where you can make verbose the logging. Then do a minimal test case with manual syncing on the sky map, stop the INDI and upload the log here.


I tried to do what you suggested me. I hope it is correct.
I attach the log file in this post. Thanks! :)

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 weeks ago

kross wrote: Had a quick look at the code. In the Sync function, it looks like you're converting the RA/Dec into Alt/Az. In reading the Synscan Serial Communication Protocol PDF, it looks to me like they want RA/Dec for EQ mounts, or Alt/Az for Alt/Az mounts, whereas you're always converting to Alt/Az. That could be the source of the problem.

I don't have my mount setup right now, or I'd make the change and test it out. I won't have it set up until Sunday at the soonest.

-- Kevin





Thank you for your interest Kevin!
Actually this could explain my problem. Unfortunately I have no idea how to change any part of the software, so the only thing I can do is to wait for your assistance.
The only thing I wonder is how it is possible that this problem occurred only to me.. I mean, if it is a problem of coordinate conversion from AR/DEC to Az-Alt, my problem should be common to every user of stars-ekos that has an equatorial mount...
Anyway, I hope that your inference is the solution to my problem! :)
Thank you again! I'll wait for your checks! ;)

A.

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 weeks ago

Ok thanks. I will try this procedure as soon as possible.
:)

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 3 weeks ago

Any news to solve this issue?
To date I have not fixed this problem. :(

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 months ago

I tried to follow your suggestion.
Unfortunately, the manual synchronization directly from the map of Kstars results unsuccessful for all the coordinates I tried: both positive or negative AR or DEC coordinates. For all the attempts I tried I always obtained that the crosshairs of the Synscan are far away from the coordinates I want to synchronize..
It's very very weird... :(

In the attached image I report you my attempt to synchronize the mount with the coordinates of Sirius ...

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 months ago

I took advantage of a small window of time in which no clouds appear in order to try again...
Unfortunately, even updating the firmware version does not fix the problem...
Even if the solver correctly detect the real coordinates of the field that is acquired, on the other hand the coordinates of the synscan are not synchronized to the solution, even if I choose the "Sync" option in the solver.
I attach some screenshots reporting the problem.
In the first image I report the sky map in which you can notice the Synscan cross in red, while the solution coordinates of the solver are highlighted inside the green circle I added.
The other image shows the solver panel in which you can see how the coordinates of the solver do not coincide with those of the mount.

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 months ago

I will report you if the update fixed the problem as soon as possible, once the weather conditions improve.
Thank you again!
:)

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 months ago

I am in a positive timezone (Palermo, that is UTC+2 owing to the daylight saving )
I am in the northern hemisphere (Palermo - Latitude: 38°07′55″ N )

Read More...

Angelo Franck replied to the topic 'Synscan coordinates differ from those of the solver' in the forum. 2 months ago

Yes, in my Mac it is installed the KStars release 2.9.2
Probably I linked an older version.

Read More...

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!