Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...

TOPIC: Help with GPSD

Help with GPSD 3 months 4 weeks ago #15590

  • danoid
  • danoid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 37
  • Thank you received: 0
I changed an existing Vendor / Product ID (total of 4 bytes) to the one I had written into the GPS and the next time I tried connecting to mount - nothing. reloaded old driver - mount works again. Problem is I am extremely inexperienced with Linux and it takes me far longer than it should to look up even the simplest stuff.

Please Log in or Create an account to join the conversation.

Help with GPSD 3 months 4 weeks ago #15592

  • Jochym
  • Jochym's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 111
  • Karma: 2
  • Thank you received: 29
So it works now? Or just the mount?

Please Log in or Create an account to join the conversation.

P.

Help with GPSD 3 months 4 weeks ago #15594

Dana, you read Serial Port Mapping tutorial I presume? This is not suppose to take a lot of time, unless there is no information at all to distinguish between devices. In this case, I'd probably use "Auto-Search" and let it find the devices automatically.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Help with GPSD 3 months 4 weeks ago #15595

  • danoid
  • danoid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 37
  • Thank you received: 0
Just the mount works. GPS is in the trash. I will have to buy another one. When that arrives I will not plug it into my USB hub, I will have to plug it in to the USB on the other side of the laptop, so UDEV can differentiate between it and my mount by USB bus. Previously they were on the same bus and it was random as to which got recognized and given a name first. It's a Linux problem that windows somewhat shared. With Windows I had to be careful to always plug the same device into the same port to assign the same COM port.

Please Log in or Create an account to join the conversation.

Help with GPSD 3 months 4 weeks ago #15596

  • Jochym
  • Jochym's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 111
  • Karma: 2
  • Thank you received: 29
Maybe you was too quick with the GPS. It is up to you but you can try to debug it a bit more. I simply doubt that it is totally toasted. Did it show up on the lsusb list? If it does the kernel and the core USB driver is *talking* to it and it is *responding*. Otherwise, if it is not there you are right - it is probably toasted.

Please Log in or Create an account to join the conversation.

P.

Help with GPSD 3 months 1 week ago #16214

  • danoid
  • danoid's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 37
  • Thank you received: 0
New gps puck
New udev rule to bind it to dev/globalsat (too many identical Prolific PL2303 serial thingamagigs)
Set gpsd device to dev/globalsat

Joy
┌───────────────────────────────────────────┐┌─────────────────────────────────┐
│ Time: 2017-04-16T02:00:10.000Z ││PRN: Elev: Azim: SNR: Used: │
│ Latitude: 42.xxxxxx N ││ 12 35 312 41 Y │
│ Longitude: 83.xxxxxx W ││ 6 82 280 34 Y │
│ Altitude: 1011.0 ft ││ 17 52 079 31 Y │
│ Speed: 0.6 mph ││ 19 69 049 31 Y │
│ Heading: 3.1 deg (true) ││ 2 39 243 28 Y │
│ Climb: 15.4 ft/min ││ 3 20 043 24 Y │
│ Status: 3D FIX (15 secs) ││ 24 18 268 25 Y │
│ Longitude Err: +/- 40 ft ││ 28 16 151 00 N │
│ Latitude Err: +/- 52 ft ││ 4 20 238 00 N │
│ Altitude Err: +/- 143 ft ││ 23 02 081 00 N │
│ Course Err: n/a ││ 135 21 237 00 N │
│ Speed Err: +/- 71 mph ││ │
│ Time offset: -0.737 ││ │
│ Grid Square: EN82ir ││ │
└───────────────────────────────────────────┘└─────────────────────────────────┘
,"epy":16.028,"epv":43.700,"track":274.5550,"speed":0.125,"climb":-0.011,"eps":3
2.06,"epc":87.40}
{"class":"TPV","device":"dev/globalsat","mode":3,"time":"2017-04-16T02:00:10.000
Z","ept":0.005,"lat":42.725089456,"lon":-83.302931171,"alt":308.160,"epx":12.345
,"epy":16.028,"epv":43.700,"track":3.1148,"speed":0.268,"climb":0.078,"eps":32.0
6,"epc":87.40}

Please Log in or Create an account to join the conversation.

Help with GPSD 2 months 1 week ago #16715

Is anyone noticing a problem with indi_gpsd where the timezone offset is not respecting daylight savings time? The UTC time is fine, but now our offset is 5, and indi_gpsd says offset 6. This is really confusing my mount on go-to.

Thanks
Jim

Please Log in or Create an account to join the conversation.

Help with GPSD 2 months 1 week ago #16722

  • Jochym
  • Jochym's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 111
  • Karma: 2
  • Thank you received: 29
It uses standard system/libc functions to establish local time. Are you sure you have current timezone data installed?
Is your computer showing proper UTC/Local times? What is gpsmon saying?

Please Log in or Create an account to join the conversation.

P.

Help with GPSD 2 months 1 week ago #16736

All of the timezone data is up to date. The GPS is reporting the accurate time in UTC. The system clocks are also reporting the correct time at the OS level. All computer clocks are in sync with ntp/chrony.

gpsmon:
Time: 2017-05-13T14:12:40.000Z Leap: ??
Fix:  9 = 26 16  3 23 22 31 14 29  9

sudo hwclock -r;date;date -u
2017-05-13 09:16:06.389065-6:00 {!!}
Sat May 13 09:16:07 CDT 2017
Sat May 13 14:16:07 UTC 2017

As you can see, the hardware clock does show a -6, does indi use the hw clock and not the system clock?

edit:

I found another command datetimectl. This command shows the offset correctly from all clocks. The hwclock command still lists an offset of -6 even though it has the right time. Now I am really confused. All times are correct in both local and UTC time, but the -0600 offset reported by hwclock seems to be the culprit. Will keep digging.

timedatectl
timedatectl status
      Local time: Sat 2017-05-13 10:44:39 CDT
  Universal time: Sat 2017-05-13 15:44:39 UTC
        RTC time: Sat 2017-05-13 15:44:39
       Time zone: America/Chicago (CDT, -0500)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no
[root@neptune ~]# timedatectl
      Local time: Sat 2017-05-13 10:46:12 CDT
  Universal time: Sat 2017-05-13 15:46:12 UTC
        RTC time: Sat 2017-05-13 15:46:12
       Time zone: America/Chicago (CDT, -0500)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

hwclock:
hwclock --debug
hwclock from util-linux 2.28.2
Using the /dev interface to the clock.
Last drift adjustment done at 1494689370 seconds after 1969
Last calibration done at 1494689370 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
...got clock tick
Time read from Hardware Clock: 2017/05/13 15:48:22
Hw clock time : 2017/05/13 15:48:22 = 1494690502 seconds since 1969
Time since last adjustment is 1132 seconds
Calculated Hardware Clock drift is 0.000000 seconds
2017-05-13 10:48:21.092867-6:00
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by xsnrg. Reason: more info from hwclock and datetimectl

Help with GPSD 2 months 1 week ago #16760

xsnrg wrote: Is anyone noticing a problem with indi_gpsd where the timezone offset is not respecting daylight savings time? The UTC time is fine, but now our offset is 5, and indi_gpsd says offset 6. This is really confusing my mount on go-to.

Thanks
Jim


GPSD returns offset based on the timezone configured in your operating system (the one your GPS is connected to). Anyway INDI is not using offset information at all and your mount driver uses UTC time. The offset is used by KStars to set your skymap view properly. You can sync your time both ways - device to KStars or KStars to device (see KStars configuration). You can also disable syncing and that's probably a fix for your issue. Why would GPSD return other offset than your operating system? I have no idea, because as Jochym said it uses standard system libraries. No custom magic whatsoever

Please Log in or Create an account to join the conversation.

Help with GPSD 2 months 5 days ago #16787

I had the same issue earlier in the spring and just made a quick hack for my setup and commented out this part in 3rdparty/indi-gpsd/gps_driver.cpp around line 194:
    // adjust offset for DST
    if (local->tm_isdst)
        offset -= 1;
I don't know what the point of this code is as the offset is what it is with DST included.
The following user(s) said Thank You: Jochym, xsnrg

Please Log in or Create an account to join the conversation.

Help with GPSD 2 months 5 days ago #16795

That is excellent, thank you jpaana.

[edit] Ticket opened: github.com/indilib/indi/issues/228

Please Log in or Create an account to join the conversation.

Last Edit: by xsnrg. Reason: opened ticket to address
Time to create page: 0.169 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica