×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

Management of large sensors in Raspberry pi

  • Posts: 3
  • Thank you received: 0
So, I think I have some good news to report.

On the 64-bit Raspbian OS and 8GB RPi4 that I am experimenting on, I tried rebuilding Indi and kstars again today using fresh clones from GitHub.It reports as being Version 3.5.3 Beta. It not only built, but this time I was able to use it to capture images from my ASI6200MC, which I was unable to do earlier.

I used the FITS Viewer with debayering checked and adaptive scaling checked, but auto-stretch not checked and also set it to reuse the same FITS window for each image. I then took 20 bias images with my camera (I am at my desk so I could not attach the camera to the telescope and take Lights) and they all displayed with no crash.Incidentally, though auto-stretch was NOT checked, it still auto-stretched. That appears to be a side-effect of having adaptive scaling checked.

I then unchecked adaptive scaling and ran another 20 bias captures. Incidentally, this is when I noticed that auto-stretching was occurring with adaptive scaling because it wasn't happening now, so I went ahead and checked auto-stretching. Anyhow, again, no crash.

In the first instance the system memory monitor reported usage fluctuating between 3GB and 3.75GB. In the second case it was between 3GB and 3.6GB. Those numbers are just from eye-balling it.

Unfortunately I don't know whether the good news is because of the 64-bit OS or because of adaptive scaling or just some other improvement in 3.5.3 Beta.

I have yet another 4GB RPi4, so I will attempt to get the bleeding-edge copy loaded on to that over the next day or two and try to determine if the 64-bit OS had any hand in things not crashing or if it was the other possibilities.

I do have one outstanding question on a related matter that I hope I can get help on (feel free to create a new thread to answer -- I am not fully up to speed on this interface to do that)... anyhow, when I use the version I built under the 64-bit OS, it appears as if all windows, icons, fonts, etc. are magnified by about a factor of 2. Even the start-up splash screen is oversized (I am attaching a screen shot). I have tried playing with the system settings to reduce font and icon sizes, but that isn't fixing the root problem (e.g., no effect on the splash screen). Is there some -geometry or other setting that I need to imbed in some start-up file so that things are properly scaled? It is very annoying as the EKOS window extends outside of my VNC window and I have to drag the window up and down to alternate access the top of the window and access the bottom of the window.
2 hours 41 minutes ago #69938
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.208 seconds