×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

About to Install Kstars/Ekos on a NUC with dual boot Win/Linux. Any advice from those who have done this?

  • Posts: 50
  • Thank you received: 0
1 month 2 weeks ago #82739

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
From what I understand, this script is specifically written for a raspberry Pi. Will this work for a minipc running Ubuntu as well?
1 month 2 weeks ago #82741

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 15
Yes, but it is better to modify it somehow. Fortunately it is very well commented.
The following user(s) said Thank You: Peter
1 month 2 weeks ago #82745

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
I got a small mini pc running Ubuntu now. I successfully installed Kstars etc, and it works fine. I can use nodesk to log in and rund the applications from it just fine. Now I want to try and use it only as an indiserver at the telescope and use my windows machine inside the house. So I went and tried to install the indiserver with instructions from the GitHub site. I am however unable to start the webmanager and I get the following message in terminal:
ser-Default-string:~$ python3 -m indiweb.main
2022-06-10 19:30:08,405 - WARNING: terminating indiserver failed code 1
2022-06-10 19:30:08,419 - WARNING: terminating indihub-agent failed code 1
Bottle v0.12.21 server starting up (using WSGIRefServer())...
Listening on http://0.0.0.0:8624/
Hit Ctrl-C to quit.
If I just use the command “indi-web” I get the same feedback. Can anybody help out here, because I do not know how to move on.

Thanks,

Peter
2 weeks 22 hours ago #83484

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 0
2 weeks 22 hours ago #83485

Please Log in or Create an account to join the conversation.

  • Posts: 819
  • Thank you received: 104
That sounds as if it tries at startup to terminate already running servers (and fails because there are none). So more a notification than an error. It seems to start up, and wait for connections.
Have you tried firing up EKOS on your desktop, and set up a profile to use that computer using indi-web?
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
2 weeks 50 minutes ago #83508

Please Log in or Create an account to join the conversation.

Time to create page: 0.518 seconds