×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Why this scheduler job was skipped?

  • Posts: 36
  • Thank you received: 4
Hi, last night I had a session with Ekos Scheduler consisting of two jobs, "LionNeb" and "SoulNeb" (in that order). Both had twilight and >40º altitude constraints. Aborted job management was set to "immediate" (300s) and re-schedule errors was enabled. 

When the first one lowered to 40º alt, Ekos aborted the capture (as expected) but the second job was never started, instead, it proceeded with the shutdown process. I think that those are the relevant log lines:
[2021-10-11T04:06:03.356 CEST INFO ][   org.kde.kstars.ekos.capture] - "Capturing 600,000-second Ha image..."
[2021-10-11T04:11:12.297 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' current altitude (40,00 degrees) crossed minimum constraint altitude (40,00 degrees), marking idle."
[2021-10-11T04:11:12.352 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' is stopping guiding..."
[2021-10-11T04:11:12.360 CEST INFO ][   org.kde.kstars.ekos.capture] - "Autoguiding stopped. Aborting..."
[2021-10-11T04:11:12.372 CEST INFO ][   org.kde.kstars.ekos.capture] - "CCD capture aborted"
[2021-10-11T04:11:12.379 CEST INFO ][     org.kde.kstars.ekos.guide] - "Autoguiding aborted."
[2021-10-11T04:11:12.518 CEST INFO ][           org.kde.kstars.indi] - MI G2-8300 :  "[INFO] Exposure aborted. "
[2021-10-11T04:11:13.365 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' 100x600\" Ha sees 56 captures in output folder '/home/aristarco/datos/LionNeb/LionNeb/Light/Ha'."
[2021-10-11T04:11:13.365 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' 100x600\" Ha requires a dither procedure."
[2021-10-11T04:11:13.368 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' estimated to take 07h 34m 48s to complete."
[2021-10-11T04:11:13.370 CEST INFO ][ org.kde.kstars.ekos.scheduler] - Option to sort jobs based on priority and altitude is false
[2021-10-11T04:11:13.392 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Warning: job 'LionNeb' execution overlaps daylight, it will be interrupted at dawn and rescheduled on next night time."
[2021-10-11T04:11:13.477 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' has a total score of -989 at 11/10 04:11."
[2021-10-11T04:11:13.501 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Warning: job 'SoulNeb' execution overlaps daylight, it will be interrupted at dawn and rescheduled on next night time."
[2021-10-11T04:11:13.508 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'SoulNeb' has a total score of +102 at 11/10 04:11."
[2021-10-11T04:11:13.510 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' has a total score of -989 at 11/10 04:11."
[2021-10-11T04:11:14.465 CEST INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'LionNeb' scheduled for execution at 11/10 21:13. Observatory scheduled for shutdown until next job is ready."
[2021-10-11T04:11:14.476 CEST INFO ][ org.kde.kstars.ekos.scheduler] - Starting shutdown process...

My interpretation is that Ekos deals with the altitude constraint as a failed job so it tries to re-schedule it inmediately (as configured), delaying it to the next night. (In the log though, it seems that Ekos even scores the second job positively, but just didn't try to start it.)

I was trying to use the 'altitude constraint' as a condition for jumping to the next job, and 'immediate re-schedule' as a strategy for handling capture errors (like clouds messing the guiding/capture). In essence "stay with the same object even if problems arise until it falls too low, then try the next object". How should I do this?

Thanks in advance!
Sergio

 
8 months 2 weeks ago #76527

Please Log in or Create an account to join the conversation.

  • Posts: 935
  • Thank you received: 285
Hi Sergio,
currently Ekos stops a job if one of it’s constraints is no longer met and waits until it may continue. If the time span is too long, it issues a shutdown to „sleep“ until it may restart. With this behaviour you can set up one single job that runs for several days without any need for a manual interaction.

The downside is exactly what you experienced, that Ekos doesn’t continue another job where all constraints are met. We are already in discussion to make this possible, but it’s not implemented yet.

As a workaround instead using an altitude constraint you may set a job‘s end manually with the „run until“ condition if you know, that it won’t complete, so that the next job may start when the first job ends. I know it’s not very elegant, but it works…

HTH
Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
The following user(s) said Thank You: Sergio
Last edit: 8 months 1 week ago by Wolfgang Reissenberger.
8 months 1 week ago #76591

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 4
Not a problem. Just needed to understand what these options really mean. Thank you so much for your assistance, Wolfgang!
8 months 1 week ago #76619

Please Log in or Create an account to join the conversation.

Time to create page: 0.472 seconds