Ben replied to the topic 'Guiding of Nexstar 4SE does not work' in the forum. 3 years ago

Wow! That's the perfect explanation for the observed behaviour. Your action list makes sense.

As I understand the driver uses the time guide command instead of the pulse guide command if switch "Use Pulse Cmd" is off? So PHD2 would be able to guide with these commands if the "pulse length" wouldn't exceed 2.55?

Thanks for the help!


Ben replied to the topic 'Guiding of Nexstar 4SE does not work' in the forum. 3 years ago

The mount is set up in equatorial mode, using the built in wedge. Before connecting to the driver I make a rough alignment and start equatorial tracking using the hand controller.

From what I've seen in my last test session I am pretty sure that the 4SE firmware can handle these commands. My test setup was the following:

  • 4SE mount is equatorial aligned but tracking is off so the mount does not move.
  • I open the "Manual tracking tool" in PHD2, which should work with the pulse commands. I configure the pulse length to the maximum of 5s.
  • I manually move to any direction using the buttons of the tool and I hear the drive moving for ~5s.

It's possible to get logging data by enabling full logging in the driver, this will show all the commands that te INDI driver sends to the HC.

This is a very good idea! I will check that on my next test.



Ben replied to the topic 'Guiding of Nexstar 4SE does not work' in the forum. 3 years ago

Ok, my last post was completely wrong!

First thing is, that the hand controller sends the pulse and not the software, so 3 wires to the hand controller should be ok, because a pulse command is just another RS232 command for the software.

I made a firmware update of my hand controller and tried again in a complete silent room.

With "Use Pulse Cmd" option "On" every pulse generates:

  • no sound

With "Use Pulse Cmd" option "Off" every pulse generates:
  • [Info] Moving toward West.
  • [Info] Moving toward West halted.
  • I hear the sound of the moving motor!!

So indeed, the pulse command works when "Use Pulse Cmd" option is turned "Off"! It still generates the warning and I was still not able to calibrate in my home with an artificial light and the wide angle lens of the ASI 120 MC, but I will try out with the guide scope in the next clear night.

I do not not know if the firmware update was important or not, because it is not easy to determine if the drive is executing a pulse command or not. I first had to switch off tracking and to shut down my PC before I was able to hear the noise of the moving motor. But I am glad to know that I am able to send a pulse command from the PI to the Nexstar.

Thank you very much for the useful hint! :cheer:


Ben replied to the topic 'Guiding of Nexstar 4SE does not work' in the forum. 3 years ago

In the INDI Control Panel SET option "Use Pulse Cmd" Off, this value is "Obligatory" for me with internal guide and Nexstar C8 GPS.

I have already found your own thread regarding that issue and I tried it several times with turning that option ON and OFF. But the only effect for me is that the driver generates additional messages when each pulse is sent, but unfortunately the behaviour is the same.

I took a look to the wiring now and I realized that only 3 wires are connected to the handcontrol of the mount. My version of the handcontroller is connected by a RJ11 plug, which is capable of 4 wires, but only 3 are connected. If that 3 wires are something like GND, RX and TX, I wonder how an additional pulse command should be transmitted?!


Ben created a new topic ' Guiding of Nexstar 4SE does not work' in the forum. 3 years ago

Hi all,

first of all I am new to this forum. I am a complete linux noob but I love all this great astro projects for raspberry pi so I joined the club. I have to say that you are doing a great work here!

I am running KStars Version 3.3.6 with Ekos on the Astroberry server 1.1.0, MATE Desktop Environment 1.16.2 on a Raspberry Pi 3 Model B.

With Ekos I am running my Nexstar 4SE, my Canon EOS 1300D and a ZWO ASI 120 MC-S.

Everything is running fine, alignment, solver, polar alignment, mount control and imaging - except the guiding. I want to use PHD2 for guiding, but even if I try with the internal guider of Ekos it fails. When I start the guiding process PHD2 selects a star and tries to calibrate. On every calibration step the INDI driver plots the message: [WARNING] PULSE STILL IN PROGRESS, POSSIBLE MOUNT JAM. After 60 calibration steps PHD2 stops the process with the message "RA Calibration Failed: star did not move enough".

I am sure the pulse guiding command is not working, because I cannot hear or see that the mount is moving when the calibration of PHD2 or the internal guider is running. I also get no reaction if I use the manual guide tool of PHD2 to control the mount. I know that the movement rate should be so slow that it is hard to see on the screen, but I even cannot hear any sound from the motor of the mount. In the INDI Control Panel the option "Use Pulse Cmd" is turned On.

If I am using Kstars or Ekos to control the mount everything works fine. I played around with backlash compensation and other options of the guider but nothing seems to make the mount move. I also tried with tracking ON and OFF, it seems to make no difference.

After installation I ran the software updater of the OS once and installed all updates, including updates for KStars and INDI drivers. When I run the software updater now, it does not show any updates for KStars or INDI drivers only for Ubuntu and other applications.

I am looking forward for any helpful hint!

Best regards,