kross wrote:

El Corazon wrote: My 2 cents on this is that upon microstepping down to 1/32 and using only one step for each move, the motor does not have enough torque to reliably move that one microstep.

When using the Waveshare INDI driver that I wrote, a single step in the INDI control panel will equate to 32 microsteps at the motor. I always end on a full step boundary. I use microsteps for smoothness and quietness, not for increased resolution. If it were to stop on less than a full step, then the motor would need to have power applied to it constantly to hold that position, thus using more power and causing the motor to get warm (or very hot if you haven't tuned the current limit). But with my approach, that allows me to turn off power to the motor when not actively moving for focus.

So I'm not sure if that is esb's problem of it not always moving the same amount with a single step. Does that also happen if you disconnect the belt, just letting the motor run free? If it works fine when the motor is running free, but misses a step when connected to the belt, then it is most likely a lack of torque. You can try slowing down the motor with the delay settings, since stepper motors lose torque when running faster. You can also try using less microstepping via the DIP switches. You will need to modify the source code to match the micrstepping setting of the DIP switches. Eventually I'll make that a configurable option in the INDI control panel.

Ha... our messages crossed. I think the timing is indeed my problem. With the geared stepper, the inconsistent (even reversed) movement happens under zero load. I think I'm just pulsing the motor too quickly.