Ron DeBry created a new topic ' KStars crashing' in the forum. 4 months ago

Ubuntu-mate 22.04 LTS on a mini-pc
KStars stable installed from ppa

Ran well a couple of nights, including an all-night session last night. Ekos stopped as normal at dawn, with KStars still open as normal. I tried to start a new Ekos session with the "main camera+simulators" profile to take flats (this is an existing profile I have used before), and KStars crashed.

Kstars now crashes very nearly every time I try to run it, regardless of the profile chosen. Have rebooted, power-cycled, run apt-get update, etc. no change. I unplugged every usb device and tried with only the simulators.

With the simulators profile, when KStars crashes I have hit the Run button and the INDI control panel window comes up, but there is no information in the Telescope Simulator tab (it's blank).

Ran kstars with dbg, and it says:

Thread 1 "kstars" received signal SIGSEGV, Segmentation fault.
__strlen_sse2 () at ../sysdeps/x86_64/multiarch/strlen-vec.S:126
126 ../sysdeps/x86_64/multiarch/strlen-vec.S: No such file or directory.

I did type bt, but I'm not sure how to capture the information - should I pipe it to something that will save the text to a file? (I used unix 35 years ago, but have forgotten 99.9% of what little I knew back then)

If I had to guess, given that there were no software or hardware changes in between 5:15am (dawn shutdown) and 8:00am, something on the hard drive may have gotten corrupted?

Is there a least painful way to re-install Kstars?

Read More...