I've been pre-programming capture sessions via the scheduler for the last few nights, and everything is currently running stable in the new 64-bit version. At the end of astronomical twilight the scheduler starts the jobs, at the end of the night it parks. Great stuff.

Even though I seem to know what to do,I feel that I use some workarounds as I do not understand the logic in some places, what to enter in Capture and what to enter in the Scheduler. Maybe someone can help me figure out where my logical error is.

I create sequences in the capture module and save them. As an example 90 images at 120 s with the correct camera gain and offset settings. I save this as a Sequence Queue (ESQ) file. In the scheduler, I specify the object name, then I load in the Sequence file and add that sequence to the scheduler. Press play and the night can come :)

In my understanding the ESQ file is simply a sequence for the camera but independent from the object. In the scheduler I assign this sequence to an object and add it to the list of the scheduler. But this separation seems not to be the idea of the programmers.

Two examples of what I do not understand and why I currently manipulate the esq files in the text editor. Both parameters belong for me rather in the scheduler than to the inputs from the capture module, because I re-use the same sequence file for different objects in the scheduler:

  1. When I apply the same sequence to the same object in another night to add more images, the scheduler reports the job is already done. Reason is apparently that the file path for the images stored in the esq file is used. Although I set to include timestamps in the filenames so there would be no naming conflict, the sequence is considered to be already done. If I change the folder name in the esq file, everything runs as expected, just to a separate folder. But I have to keep editing the esq files and can not use a library of e.g. numbers of exposures which I could simply apply whenever needed.
  2. There are some relevant options in the esq file, including the "Temperature force" option, which cools the astro camera first and only then starts the acquisition. I use this to avoid having to manually turn on the cooling beforehand, but wouldn't know how to include this default via the user interface when creating the esq file (or do I really have to switch on the cooler when saving the file just to have it in the file? I do that in the daytime). Currently I manipulate the esq file with the text editor and that works ok. As cooling settings should be valid for the whole night, I miss the counterpart to "Warm CCD" in the shutdown procedure in the scheduler for startup.

How do you guys do this if you want to shoot the same object on different nights? How do you specify that the camera should be cooled before startup? Are you manipulating the esq files as well? Am I missing a dialogue and the same could be achieved much easier?

Thanks for sharing your way of handling the settings in Schedulder and Capture modules.